Jump to content
meowcat

How to turn off any automated AI speaking for player-controlled units? Without breaking the capability for players to use the radio.

Recommended Posts

How to turn off any automated AI speaking for player-controlled units? Without breaking the capability for players to use the radio.

Share this post


Link to post
Share on other sites

 I play with a lot of AI under my control I will love to just be able to adjust the radio chatter to very low so its in the background but you can hear yourself think during a large firefight.

Share this post


Link to post
Share on other sites

Does it have the same effect as BIS_noCoreConversations?

Share this post


Link to post
Share on other sites

I only ever play MP/coop with my group, and never with friendly AI. I put this at/near the top of the init.sqf of every mission:

//Shut up!
{_x setVariable ["BIS_noCoreConversations", true]} forEach allUnits; 
0 fadeRadio 0;
enableSentences false;

MRB Voicestop (Gunter's link) works great, but if you don't want to use mods, the above does the trick.

  • Like 1

Share this post


Link to post
Share on other sites

> BIS_noCoreConversations

is obsolete in A3

Share this post


Link to post
Share on other sites
32 minutes ago, .kju said:

> BIS_noCoreConversations

is obsolete in A3

Huh! Now that I look, I can't find documentation for BIS_noCoreConversations  anywhere. I've been using that block in my init.sqf forever (well, since A2), has something new replaced that command or is

0 fadeRadio 0; enableSentences false;

all that is necessary? 

 

Share this post


Link to post
Share on other sites

> since A2

yes this is when they introduced that basic scripted conversation system

 

and it was dropped with A3 again

Share this post


Link to post
Share on other sites

thx for the answers so far. Is there a way to also turn off auto spotting for players? Sometimes AI is reported just by right mouse zooming.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×