Jump to content

Arma 3 Launcher: Crashes & Gives this Error

Recommended Posts

Hello, recently, I updated my windows 7, as it had been out of date for some time, and I noticed that after the update my Arma 3 launcher refuses to work. Note, I have noticed a few strange error messages on other programs, like, D3DComplier_47.dll is missing and so on, since I updated my windows so maybe that has something to do with this. This is the error message I get when I attempt to launch the launcher: https://imgur.com/a/JzSlP  Note, I can launch Arma 3 through the .exe but not through steam or the launcher.exe.


Here is what I have tried so far to resolve the issue:

1) I have searched other BI forum posts and FeedbackTracker tickets to see if anyone has resolved the issue. So far, none of them have worked, and it appears that the issue I am having seems to always have a unique fix.

2) I have downloaded the D3DComplier_47.dll file and I have placed it in the main Arma 3 folder and System32 folder.

3) I have downloaded a couple of registry error fix programs.

4) I have verified my game cache and reinstalled Arma 3.

5) I have deleted various files inside the \Launcher folder in the main Arma 3 directory and verified the cache to reinstall the files; no luck.

6) I have attempted to install various versions of Microsoft Net Framework, however, everytime I try to install them them, they fail or cannot be updated.

7) I have checked and updated my graphics drivers.

8) I have checked and updated my CPU drivers.

9) I have checked my computer for an update file known as KB307... something along those lines, and I don't have it on my computer.

10) I have tried using Windows Checker System via the CMD window as suggested by BIS_Wizard on another forum post, so far, no luck.


Here is the official error .txt file that is placed on my desktop everytime the launcher crashes


Arma 3 Launcher Exception Log

Arma 3 Launcher has encountered an unexpected error described below.
Sorry for the inconvenience.
Please report this on Arma 3 Feedback Tracker (http://feedback.arma3.com). Thanks to you we may fix the issue faster!

System information
Date:                2017-10-08 21:55:00 / 2017-10-08 17:55:00 -04
Current dir:         F:\Steam\steamapps\common\Arma 3
AppData dir:         C:\Users\William-02\AppData\Local
Command line:        "F:\Steam\steamapps\common\Arma 3\arma3launcher.exe"
CLR version:         4.0.30319.42000
OS Version:          6.1.7601.65536 (Microsoft Windows NT 6.1.7601 Service Pack 1)
OS 64 bit:           True
Process 64 bit:      False
Personal dir:        C:\Users\William-02\Documents
Culture:             en-US
UI Culture:          en-US
Point of log:        Unhandled Exception

System.TypeInitializationException: The type initializer for '<Module>' threw an exception. ---> <CrtImplementationDetails>.ModuleLoadException: The C++ module failed to load during appdomain initialization.
 ---> System.DllNotFoundException: C:\Windows\Microsoft.NET\Framework\v4.0.30319\WPF\wpfgfx_v0400.dll ---> System.ComponentModel.Win32Exception: %1 is not a valid Win32 application
   --- End of inner exception stack trace ---
   at MS.Internal.NativeWPFDLLLoader.LoadNativeWPFDLL(UInt16* relDllPath, UInt16* baseDllPath)
   at MS.Internal.NativeWPFDLLLoader.LoadCommonDLLsAndDwrite()
   at CModuleInitialize.{ctor}(CModuleInitialize* , IntPtr cleaningUpFunc)
   at ?A0x721f77f1.CreateCModuleInitialize()
   at ?A0x721f77f1.??__E?A0x721f77f1@cmiStartupRunner@@YMXXZ()
   at _initterm_m((fnptr)* pfbegin, (fnptr)* pfend)
   at <CrtImplementationDetails>.LanguageSupport.InitializePerAppDomain(LanguageSupport* )
   at <CrtImplementationDetails>.LanguageSupport._Initialize(LanguageSupport* )
   at <CrtImplementationDetails>.LanguageSupport.Initialize(LanguageSupport* )
   --- End of inner exception stack trace ---
   at <CrtImplementationDetails>.LanguageSupport.Initialize(LanguageSupport* )
   at .cctor()
   --- End of inner exception stack trace ---
   at Launcher.Program.StartGui(InitArgs param)
   at Launcher.Program.HandleCommandLine()
   at Launcher.Program.RunLauncher()
   at Launcher.Program.Main(String[] args)

Modules and assemblies
- mscorlib, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089; C:\Windows\Microsoft.NET\Framework\v4.0.30319\mscorlib.dll
- arma3launcher, Version=, Culture=neutral, PublicKeyToken=null; F:\Steam\steamapps\common\Arma 3\arma3launcher.exe
- log4net, Version=, Culture=neutral, PublicKeyToken=669e0ddf0bb1aa2a; F:\Steam\steamapps\common\Arma 3\Launcher\log4net.dll
- System, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089; C:\Windows\Microsoft.Net\assembly\GAC_MSIL\System\v4.0_4.0.0.0__b77a5c561934e089\System.dll
- System.Configuration, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a; C:\Windows\Microsoft.Net\assembly\GAC_MSIL\System.Configuration\v4.0_4.0.0.0__b03f5f7f11d50a3a\System.Configuration.dll
- System.Core, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089; C:\Windows\Microsoft.Net\assembly\GAC_MSIL\System.Core\v4.0_4.0.0.0__b77a5c561934e089\System.Core.dll
- System.Xml, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089; C:\Windows\Microsoft.Net\assembly\GAC_MSIL\System.Xml\v4.0_4.0.0.0__b77a5c561934e089\System.Xml.dll
- SharedResources, Version=, Culture=neutral, PublicKeyToken=null; F:\Steam\steamapps\common\Arma 3\Launcher\SharedResources.dll
- PresentationFramework, Version=, Culture=neutral, PublicKeyToken=31bf3856ad364e35; C:\Windows\Microsoft.Net\assembly\GAC_MSIL\PresentationFramework\v4.0_4.0.0.0__31bf3856ad364e35\PresentationFramework.dll
- WindowsBase, Version=, Culture=neutral, PublicKeyToken=31bf3856ad364e35; C:\Windows\Microsoft.Net\assembly\GAC_MSIL\WindowsBase\v4.0_4.0.0.0__31bf3856ad364e35\WindowsBase.dll
- PresentationCore, Version=, Culture=neutral, PublicKeyToken=31bf3856ad364e35; C:\Windows\Microsoft.Net\assembly\GAC_32\PresentationCore\v4.0_4.0.0.0__31bf3856ad364e35\PresentationCore.dll
- System.Xaml, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089; C:\Windows\Microsoft.Net\assembly\GAC_MSIL\System.Xaml\v4.0_4.0.0.0__b77a5c561934e089\System.Xaml.dll

Assembly resolution

Any help, suggestions, or input, is greatly appreciated. I'd defininetly like to get back to playing Arma 3. 



Share this post

Link to post
Share on other sites

I have this same problem. Going to try uninstalling and reinstalling A3 to see if it fixes it...


Edit: Err I replied to the wrong post my problem is the Launcher tells me my settings are corrupted when it starts...


Share this post

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now