Jump to content
jakeplissken

Keyframe animation system in DEV.

Recommended Posts

On 09/12/2017 at 4:18 PM, Andres97 said:

 

Correct me if I'm wrong, but this does not work on dedicated and multiplayer, right?

I tried to use it to animate a big temple gate opening and when testing in dedi it just skips the animation.

It's supposed to work in a MP environment, with a few considerations to have in mind, for example, an animation fully done in 3den without any scripting interaction will be simulated locally on every connected machine, which in some specific cases, where the animation may affect the game play,  it would probably be better to have the animation being simulated only on the server which already replicates the object position to the clients keeping the server as the object position authority while losing the smoothness the local simulation has. 

 

Meanwhile, I will take a look at this specific case with the dedicated server, feel free to report any other issues you come across. 

  • Like 1

Share this post


Link to post
Share on other sites
3 hours ago, neokika said:

It's supposed to work in a MP environment, with a few considerations to have in mind, for example, an animation fully done in 3den without any scripting interaction will be simulated locally on every connected machine, which in some specific cases, where the animation may affect the game play,  it would probably be better to have the animation being simulated only on the server which already replicates the object position to the clients keeping the server as the object position authority while losing the smoothness the local simulation has. 

 

Meanwhile, I will take a look at this specific case with the dedicated server, feel free to report any other issues you come across. 

 

The module "camera_F" has two typos in the tooltips of "Show HUD" and "Show Cinema Borders"

Share this post


Link to post
Share on other sites
3 hours ago, neokika said:

It's supposed to work in a MP environment, with a few considerations to have in mind, for example, an animation fully done in 3den without any scripting interaction will be simulated locally on every connected machine, which in some specific cases, where the animation may affect the game play,  it would probably be better to have the animation being simulated only on the server which already replicates the object position to the clients keeping the server as the object position authority while losing the smoothness the local simulation has. 

 

Meanwhile, I will take a look at this specific case with the dedicated server, feel free to report any other issues you come across. 

 

Okay, so I did a few tests with this in dedi.

First try, a mission already made, with lots of things, animation "wouldn't work" object skipped to end position after timeline was completed.

Second try, tom's example mission, it "worked" but it skipped certain points, what I mean is that the animation wasn't fluid, it skipped pieces of the 'track'.

 

Thanks for you help.

 

Quote

it would probably be better to have the animation being simulated only on the server which already replicates the object position to the clients keeping the server as the object position authority while losing the smoothness the local simulation has. 

 

Is there a not to complicated way to do this? Hope I'm not asking for too much.

Share this post


Link to post
Share on other sites

Hello,

 

I would like to test if the keyframe animation framework can be used to taxi planes on the Nimitz from elevator to catapult. For this purpose I would like to set up the keyframe animation objects by scripts rather than in Eden. Unfortunately I fail to figure out how to do this successfully. I created a timeline logic object and this seems operational, but the synchronized curve and key and object don't seem to be. I've placed the init.sqf at https://pastebin.ubuntu.com/26249888/ and a sample mission at http://tetet.de/arma/arma3/nimitz/missions/[sp]anewtaxi.Stratis.7z . The sample mission includes the init.sqf.

 

The mission is composed of two timelines:

  1. A completely Eden based timeline with curve, key, and object: The plane taxis from cat 3 to cat 2 and takes off then
  2. A half Eden based timeline with curve, key: The spawned plane is assigned to the curve via _curve synchronizeObjectsAdd [_plane];

Unfortunately the 2nd approach doesn't work for me and the spawned plane stays stationary. The mission uses the Nimitz and F/A-18 mod.

 

Any ideas what's wrong?

Share this post


Link to post
Share on other sites

The module does not work in 3den for me since late January.

 

Impossible to animate anything by following the Tutorial.

 

Do you have the same concerns?

 

 

 

 

 

Share this post


Link to post
Share on other sites

It's currently broken on the Stable branch. Have you tried using it on the dev-branch? Last I checked it was working fine on there.

Share this post


Link to post
Share on other sites

It seems that if you place down the Camera module after playing a scenario in 3DEN, it breaks the 3DEN camera. Looks like it's making the camera created by the module the active camera rather than the 3DEN camera.

  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×