Jump to content
bonko the sane

Arma 3 wont start in native resolution

Recommended Posts

Hi, i run Arma3 native resolution 1920x1080 and more often than not, especially since latest patch when i fire it up i get a full screen view of a very small section of the start up menu in a miniscule resolution, cant even do a thing as seen area is probably a corner of the start menu and the cursor arrow is about a third of the screen.

Tried setting .cfg to read only, doesnt matter as the .cfg has the correct settings and its not changing anyway.

My only workaround, and its totally random when this error happens is shutting down Arma on task manager, going to Nvidia Control panel and changing anything in the adjust size and positon of monitor and restarting Arma, normally that does the trick. But since last patch its almost impossible to play, takes me ages to finally get the game to start in native resolution.

Help please.

Share this post


Link to post
Share on other sites

When game is launching, mouse click once on loading small window.

Game should enter native ress, but sometimes it dont, so try few times.

Share this post


Link to post
Share on other sites

yeah, thank you, theres no solution in sight it seems, one of those Arma "features" only god knows how the f**c they exist, gotta love this game :D

Share this post


Link to post
Share on other sites

Since update today I experience the same problem, never had this before. Resolution is on 640*480 at game start... restart "fixes" it (sometimes).

Share this post


Link to post
Share on other sites

Thank you for the replies.

In full windowed mode it seems to start every time in the correct resolution, i hope BIS finds whats happening, because its not really a solution, just a workaround.

Share this post


Link to post
Share on other sites

Since the latest patch this happens often for me as well, hope they can sort it.

 

/KC
 

Share this post


Link to post
Share on other sites

After installing the newest Nvidia drivers and restart of computer it's good for me again.

How many tries you gave to it? For me the problem is random so sometimes it's good for many game stars and then it appears again. I also tought I fixed it couple of times but after two days it happened again and it really wasn't fixed at all.

Share this post


Link to post
Share on other sites

I'm not 100% sure yet but it seems like disabling multi monitor support in nVida control panel fixed it for me. Did not experience it after that and hopefully it stays that way.

 

/KC

Share this post


Link to post
Share on other sites

Are you folks running MSI Afterburner along with Rivatuner Statistics Server (RTSS) by chance?

 

I find if I set detection level to none in RTSS this issue stops.

Share this post


Link to post
Share on other sites

Before you start game disable Desktop Window Manager Session Manager in your services. If this helps you then you can make cmd or batch file to start game.

@ECHO off
sc stop UxSms
START "ArmA 3" /D "D:\Steam\SteamApps\common\Arma 3" "D:\Steam\SteamApps\common\Arma 3\arma3.exe" -cpuCount=4 -exThreads=7 -maxMem=3072 -name=Horus -nosplash -showScriptErrors -noPause

PS

this is fix for Win7

Edited by Horus
  • Like 1

Share this post


Link to post
Share on other sites

Before you start game disable Desktop Window Manager Session Manager in your services.

 

Thanks, this seems to be the best solution.

Share this post


Link to post
Share on other sites

Are you folks running MSI Afterburner along with Rivatuner Statistics Server (RTSS) by chance?

 

I find if I set detection level to none in RTSS this issue stops.

Stopping both programs didn't help me.

Need to test the multi monitor and alt+enter.

Share this post


Link to post
Share on other sites

Thanks, this seems to be the best solution.

If you don't use Aero Glass Theme you can safely disable this service.

In Windows Vista and Windows 7, desktop composition is enabled only with the AERO Glass Theme.

If you use Aero Glass Theme then just make 2 .cmd files to stop (before you start the game) and start this service after you finish the game.

 

stopDWM.cmd

@ECHO off
sc stop UxSms

startDWM.cmd

@ECHO off
sc start UxSms

Share this post


Link to post
Share on other sites

Stopping both programs didn't help me.

Need to test the multi monitor and alt+enter.

 

No, you don't have to stop the programs, just add arma3.exe to the RTSS profile list and set detection level to none. Google if unsure how to do this. Try Horus method to disable the service, it worked for me.

 

@Horus, I don't use Aero so no problems for me.

Share this post


Link to post
Share on other sites

No, you don't have to stop the programs, just add arma3.exe to the RTSS profile list and set detection level to none. Google if unsure how to do this. Try Horus method to disable the service, it worked for me.

 

@Horus, I don't use Aero so no problems for me.

Well I really doubt that would help if having both programs closed didn't help.

And yes need to test the service thing also. Though I can't do anything in this year so I'll see how these help in the next year.

Share this post


Link to post
Share on other sites

Well I really doubt that would help if having both programs closed didn't help.

 

True.

 

But who can play without Afterburner. :)

Share this post


Link to post
Share on other sites

Well I really doubt that would help if having both programs closed didn't help.

All of you who use AB+RTSS -> before you start game check in AB do you have run some other 3D process, press bold i in AB UI and see in Active 3D process , then make profile for that process in RTSS and set detection level to none. After that add arma3launcher.exe and arma3battleye.exe in RTSS and set detection level to none.

Share this post


Link to post
Share on other sites

How many tries you gave to it? For me the problem is random so sometimes it's good for many game stars and then it appears again. I also tought I fixed it couple of times but after two days it happened again and it really wasn't fixed at all.

 

I started Arma about 30 times since then, no problems after drivers update. I start with Arma3-Sync, my graphic card is GTX570. Hope you guys get it fixed for you.

Share this post


Link to post
Share on other sites

same problem since the last arma 3 update and RTSS for me. Pressing two times ALT+Enter helps. Since i have Vysnc enabled i need to alt+tab out anyways to surcumvent arma's weird 30fps lock. I hope this will be fixed with the next update.

Share this post


Link to post
Share on other sites

ALT and Enter twice I think it is always fixes it for me.

 

I do this and it fixes but I'm stuck in 60hz instead of 144hz.....

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×