Jump to content
skruis

Athena - An ARMA 2nd Screen Application

Recommended Posts

Hey guys, sorry for lack of updates and response. I relied on notifications via email to let me know when someone replied to the thread or sent me a message and those notifications stopped working for some reason. The reason for lack of updates is: I bought a 100yo house and updating it and work is keeping me pretty busy. I have some updates that I want to get pushed out but it's not the whole package that I was hoping for.  I'll decide what to do with these updates over the next week or so and let you know.

 

Thanks!

 

-bus

  • Like 2

Share this post


Link to post
Share on other sites
On 6/22/2018 at 2:40 PM, skruis said:

Hey guys, sorry for lack of updates and response. I relied on notifications via email to let me know when someone replied to the thread or sent me a message and those notifications stopped working for some reason. The reason for lack of updates is: I bought a 100yo house and updating it and work is keeping me pretty busy. I have some updates that I want to get pushed out but it's not the whole package that I was hoping for.  I'll decide what to do with these updates over the next week or so and let you know.

 

Thanks!

 

-bus

Good luck with the renovation. It always takes longer than expected but in the end it's often worth it!

Share this post


Link to post
Share on other sites

Thanks man, it's a huge project. Just about done ripping it apart and we're going to start putting it back together soon.

  • Like 1

Share this post


Link to post
Share on other sites

Yep, thanks for letting me know. The server that hosted the site was moved and I haven't republished yet.

Share this post


Link to post
Share on other sites

Thanks skruis for the info.

 

Another question: We want to use the mod but want disable the ability to see players or vehicles on the map. Is there a way to do this?

Share this post


Link to post
Share on other sites

Not currently. It's a planned feature to allow scripters to control what the visibility levels are. Out of curiosity, do you only want to see yourself, like a GPS?

Share this post


Link to post
Share on other sites

Hi skruis, nope. We just want the map with the ability to write on it on a second monitor/device. We try to play realistic as possible and usually people don't have a gps. Or we know the map good enough that we don't need a gps :-)

Share this post


Link to post
Share on other sites

Oooooh how 'elite' of you ;-)

 

Well, you can run the app w/o running the mod, setup a community server and join the same room. That would allow you to share ink w/o tracking.

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

Yeah, that seems to be one solution! Thank you.

 

Another problem: How do set it up? Website/Docu is offline :-D

 

Or is there another docu?

Share this post


Link to post
Share on other sites

I have a YouTube video up about how to set one up. I believe the ACS is included in the Athena distribution on Steam. You just run it, port forward and connect to it.

 

*EDIT* - link: 

 

  • Thanks 1

Share this post


Link to post
Share on other sites

I'm going to give this a shot on our Linux DS and report back on whether or not I can get it working but in the meantime, do you know if it should work on a Linux server @skruis?

Share this post


Link to post
Share on other sites

@stingray_ I don't think it will. I believe Arma Linux supports extensions but I haven't written the Linux extension. Sorry.

Share this post


Link to post
Share on other sites

That's unfortunate, I'm going to try anyway. Before I begin tackling it on the DS though, I am trying to get it to run locally. However, the import/export process doesn't appear to be initiating. I have tried running single player and multiplayer (self hosted LAN) and neither appear to prompt anything in terms of import/export. I've looked at the relay log and i see a couple lines that seem to be errors. Any thoughts on what might be causing the process to not start? 

 

8/9/2018 09:33:48 :: Listener.Listen :: Only one usage of each socket address (protocol/network address/port) is normally permitted
8/9/2018 09:34:46 :: SendPipeMessage :: Error: Pipe is broken.
8/9/2018 09:34:46 :: Listener.AcceptCallback :: Connection failed during connection acceptance. More info: Cannot access a disposed object.
Object name: 'System.Net.Sockets.Socket'.

 

PS. I'm using no other mods and I"m running in Admin mode.

Share this post


Link to post
Share on other sites
Listener.Listen :: Only one usage of each socket address (protocol/network address/port) is normally permitted.

This indicates that a relay is already running or another application is using the same port. You shouldn't have to start anything manually and the relay should close automatically when Arma does. Check your processes for relay.exe (Athena Relay) and if it's running, shut it down and try launching Arma again. The relay 'should' start automatically when the first mission in Arma starts...you should  see the relay process start and remain running via Task Manager. Then you should be able to launch Athena Desktop and click 'Start'. At that point, it should prompt to import/export.

Share this post


Link to post
Share on other sites

UPDATE. So I moved the mod from the workshop folder to a custom mods folder and launched via a config file and it worked. It's odd it didn't work in the !workshop folder but :shrug:-its arma

Share this post


Link to post
Share on other sites

That's odd... is your workshop folder in a non-standard location?

Share this post


Link to post
Share on other sites

Is there a way to zoom out past .01 or whatever the bottom of the slider is? Flying jets around could benefit from it, especially on maps like South Asia or 40x40km ones.

Share this post


Link to post
Share on other sites

I have an issue that I cannot seem to figure out.

Athena is not loading the map and connection status all say pending

Am I missing something here?


Update: Nevermind now it is working okay.

Edited by DeathCharmer

Share this post


Link to post
Share on other sites

Hey. Huge bug. so I've recently found that if I have Athena running before I start ARMa that it will cause arma to hold down the W key... causing me to run forward for a few seconds after i release the key. Needless to say, this has proved fatal.  It might be the way I have th monitor i run it on set up, but i also have noticed that the WASD keys all seem to pan, even though do not have them bound. I'm wondering if maybe this may be the cause of my glitch. I love this mod, and even though I would love it more if I had a decentered version where up was always the direction I was facing, I still love it tremendously (the flight direction up option is because I fly IRL, and decentered track up is default for our maps).

Also, Android. there's a game called Artimis that allows the android version to connect to the PC version. You can do it too. I'd literally pay you $80 for an android version that had both north up and track up options. If you want to see my cockpit, check out this video.

 

  • Like 2
  • Thanks 1

Share this post


Link to post
Share on other sites

I havent seen that particular bug. Athena doesnt generate keystrokes. It does listen for them via a windows hook and then take actions within the app. One of the unreleased changes I made drops the windows hook and instead listens for keys via the ‘custom controls’ function in the arma keybinds. Basically, a script is launched when the custom control keybind is triggered that then notifies athena that the control was triggered. Based on your control to action mappings in Athena, an action may or may not occur. That being said, theres definitely a bug in the current version where a action appears unbound but athena is still listening for it. You can try setting the keybind, highlight the field and then hit escape to clear it again...I think its escape. If theres a stored setting, that might clear it. As far as continuing to move forward, like I said, Athena doesnt generate keystroke kea and it definitely doesnt issue a command to walk forward :-D, it ‘might’ be possible that theres a bug in the windows hook thats somehow causing a repeat of keystrokes or perhaps if the system is a little sluggish or laggy, that the arma io might be flaking out. Arma has a history of input lag so there might be conditions that are amplifying that issue. 

 

As fas as rotating, its on my radar. I love when a gps rotates to my orientation. Its possible but not a high priority unfortunately. 

 

Ill look into artimis. Ive been thinking of toying around with unity but ... time. I appreciate you saying that you would pay for it but I wouldnt be able to provide a level of support that would make me feel comfortable accepting payments. 

 

Btw - the cockpit is really f***ing cool!

  • Like 2

Share this post


Link to post
Share on other sites

@skruis I just unsubscribed, and resubscribed and it seems to have fixed the problem. Maybe there was just some leftover error... but you did help... that statement about stored settings was the real clue, I just figured resetting was the best bet. Thanks a ton.

Share this post


Link to post
Share on other sites

Hey there, I've been working on trying to get the map to download. Clicking the Start Button on the Desktop App doesn't prompt me to download the map. The troubleshooting: I've run Arma, Steam, Athena App, and Athena Relay with admin privs to see if that was the issue. No dice. I've moved the mod from the workshop folder and installed it manually. Nope. I also tried unsubbing, deleting, and resubbing. Still didn't work. Everything is allowed through the firewall. If you've got any ideas, I'll be grateful!

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×