Jump to content
Sign in to follow this  
zooloo75

Ragdoll'd

Recommended Posts

line 3 of regdoll.sqf needs berfore it.

private ["_unit","_dir","_pos","_unitPos","_force","_o"];

line 28 needs this before it.

private ["_shooter","_pos","_projDir","_data","_unit"];

line 18 could be changed to this

_o setVelocity [(sin(_dir + 180)) * 6, (cos(_dir + 180)) * 6, 0]; //Brace for impact!

and

_shooter is never actually used in the script.

Use Squint. Although its an old program it works well at debugging and finding little errors that can cause unknown issues, when unchecked.

Thanks, changes applied.

Share this post


Link to post
Share on other sites

Regarding the responsiveness of ragdolling: I will continue efforts on improving the ragdoll effect.

Share this post


Link to post
Share on other sites

Is this needed for or did you already fixed that?

Originally Posted by Lordprimate

line 3 of regdoll.sqf needs berfore it.

private ["_unit","_dir","_pos","_unitPos","_force","_o"];

line 28 needs this before it.

private ["_shooter","_pos","_projDir","_data","_unit"];

line 18 could be changed to this

_o setVelocity [(sin(_dir + 180)) * 6, (cos(_dir + 180)) * 6, 0]; //Brace for impact!

and

_shooter is never actually used in the script.

Use Squint. Although its an old program it works well at debugging and finding little errors that can cause unknown issues, when unchecked.

Share this post


Link to post
Share on other sites
Is this needed for or did you already fixed that?

The code suggestions have already been applied. They aren't necessary to have, just conventions.

Share this post


Link to post
Share on other sites

New mod v1.0 available at withSIX. Download now by clicking:

@ragdolld.png

@ zooloo75 ;

Soon you will be able to manage the promo pages of your content on our web platform and publish new content yourself.

To do so, please hit 'this is me' button on the page while logged in and you will get connected to your work.

For now you can send new content or releases our way through withsix.wetransfer.com or add your notification at getsatisfaction.withsix.com.

Share this post


Link to post
Share on other sites

false alarm... just needed to update CBA, somehow I missed the may, 25th update. seems to work now, and it looks awesome

although, it sometimes doesn't fire off when shooting at CSAT soldiers, as mentioned by another poster above. also, sometimes they get propelled by the bullet impact and fly a good 2-3 meters before falling down, looks kind of ridiculos, though fun.

Edited by sorophx

Share this post


Link to post
Share on other sites

Does this mod add sounds when units hit the ground? It is a bit weird when a unit falls down, say, from a balcony without making a single noise.

Share this post


Link to post
Share on other sites

I don't know if this was already mentioned.

But after i saw the 2nd gif (Explosion) this needs a little adjustment. =D

Because the delay is so big before the ragdoll activates AND the force should be little higher.

But nice to see thanks for that.

Share this post


Link to post
Share on other sites

Release frontpaged on the Armaholic homepage.

================================================

We have also "connected" these pages to your account on Armaholic.

This means in the future you will be able to maintain these pages yourself if you wish to do so. Once this new feature is ready we will contact you about it and explain how things work and what options you have.

When you have any questions already feel free to PM or email me!

Share this post


Link to post
Share on other sites
I don't know if this was already mentioned.

But after i saw the 2nd gif (Explosion) this needs a little adjustment. =D

Because the delay is so big before the ragdoll activates AND the force should be little higher.

But nice to see thanks for that.

More reasons why we should get proper ragdoll scripting commands. These workarounds aren't perfect.

Sent from my HTC One V using Tapatalk

Share this post


Link to post
Share on other sites

Tried this and gotta say bravo zooloo75. You delivered!

When civs/other models get shot in lower leg/feet I wonder if they could be forced to fall? It's odd for their foot to snap and just remains standing up.

Share this post


Link to post
Share on other sites

so, am I the only one for whom it doesn't work 100% of the time? the ragdoll activates only 30% of the time, roughly. I'd like to try and figure out if it's something on my end

Share this post


Link to post
Share on other sites
so, am I the only one for whom it doesn't work 100% of the time? the ragdoll activates only 30% of the time, roughly. I'd like to try and figure out if it's something on my end

Are you using tpw fall?

Share this post


Link to post
Share on other sites
so, am I the only one for whom it doesn't work 100% of the time? the ragdoll activates only 30% of the time, roughly. I'd like to try and figure out if it's something on my end

If you are playing on a CPU intensive mission, it may affect the performance of the script, causing a delay in the effect. I am still working on improving the method though, so hang in there :P

Share this post


Link to post
Share on other sites

no, it's an absolutely empty Stratis mission with 20 AI to test and one playable unit. no scripts at all, not even a description.ext

the funny thing is, while the title screen shows I have CBA 212, the Expansions menu shows it's 1403. maybe it's a conflict of some sort, I don't know

Share this post


Link to post
Share on other sites
so, am I the only one for whom it doesn't work 100% of the time? the ragdoll activates only 30% of the time, roughly. I'd like to try and figure out if it's something on my end

To be honest, I've noticed as well when running it only. They look like they are starting the ragdoll and stops mid-way and stands there. Then the only time the full ragdoll comes in is when they are dead. Running latest CBA and this.

Share this post


Link to post
Share on other sites

Are you on Stable or Dev build?

Share this post


Link to post
Share on other sites
To be honest, I've noticed as well when running it only. They look like they are starting the ragdoll and stops mid-way and stands there. Then the only time the full ragdoll comes in is when they are dead. Running latest CBA and this.

Same issue here. Stable build.

Share this post


Link to post
Share on other sites

Update: Ragdoll responsiveness improved.

Note: A message will appear upon mission start notifying about a missing texture. This is normal and is an intended side-effect.

Share this post


Link to post
Share on other sites

I'm pretty sure _o setObjectTexture [0,""]; works if you just want to hide the object.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×