Jump to content
major_shepard

ArmA3Sync - launcher and addons synchronization software for ArmA 3

Recommended Posts

Hmmm yea when I put the directory url in it says the directory doesnt exist even though I know it does. In theory should I be able to just generate the .a3s repo folder/contents through the build command on my local windows machine (using a folder with all of the mods/userconfig) and then put that in the directory of our linux server which hosts the mods? 

 

Yes or if you can open a remote terminal to the Linux machine, just install ArmA3Sync on the Linux machine and run ArmA3ync-console.sh (see the wiki).

Share this post


Link to post
Share on other sites

First off, thanks for the great work on this.

 

I was using A3sync for month before I had o wipe my computer and start again. Now, it refuses to update.

 

I cannot connect to a repo which I know works because its the same repo I have been using for months and my friends connect with no pain.

 

I recently tried to update to see if that helps. I hit "Check for updates" and I get the error :"Failed to connect to updates repository"

 

I am using the same internet provider, hardware and software. 

 

Any thoughts or suggestions regarding this will be welcome.

Share this post


Link to post
Share on other sites

First off, thanks for the great work on this.

 

I was using A3sync for month before I had o wipe my computer and start again. Now, it refuses to update.

 

I cannot connect to a repo which I know works because its the same repo I have been using for months and my friends connect with no pain.

 

I recently tried to update to see if that helps. I hit "Check for updates" and I get the error :"Failed to connect to updates repository"

 

I am using the same internet provider, hardware and software. 

 

Any thoughts or suggestions regarding this will be welcome.

Presumably firewall/antivirus blocking arma3sync internet connection attempts.

Share this post


Link to post
Share on other sites

I have been having an issue for a while now setting up my repo.

I have been having an error stating that the .a3s directory was not found (550 CWM Directory Not Found /.a3s) so I manually created one and now on my Filezilla server I am seeing that there is a missing file which should be ok. Here is the issue, I have set up the repository on ArmA3Sync as referred to in multiple tutorials using ftp://Localhostas the URL (The FTP is being hosted on the local machine) Upon connecting to the repo I get an error about not having a sync file but that is fine since it should make one right? The answer is no because on the right hand side of the screen where the 3 buttons are supposed to show up (http://www.sonsofexiled.fr/wiki/images/arma3sync/arma3sync_repository_button.png) I am only getting the top download button. I have been searching all over for answers and have not received any help from anyone. If someone could find the time to help me out I would greatly appreciate it!

Share this post


Link to post
Share on other sites

I have been having an issue for a while now setting up my repo.

I have been having an error stating that the .a3s directory was not found (550 CWM Directory Not Found /.a3s) so I manually created one and now on my Filezilla server I am seeing that there is a missing file which should be ok. Here is the issue, I have set up the repository on ArmA3Sync as referred to in multiple tutorials using ftp://Localhostas the URL (The FTP is being hosted on the local machine) Upon connecting to the repo I get an error about not having a sync file but that is fine since it should make one right? The answer is no because on the right hand side of the screen where the 3 buttons are supposed to show up (http://www.sonsofexiled.fr/wiki/images/arma3sync/arma3sync_repository_button.png) I am only getting the top download button. I have been searching all over for answers and have not received any help from anyone. If someone could find the time to help me out I would greatly appreciate it!

this button ftp://www.sonsofexiled.fr/ArmA3/ArmA3Sync/development/screens/arma3sync_administrate_repository.png

Share this post


Link to post
Share on other sites

Presumably firewall/antivirus blocking arma3sync internet connection attempts.

 

 

I have turned off both antivirus and firewall and still doesn't work.

Share this post


Link to post
Share on other sites

Hi,

I'm having an error while trying to compare the addons with the repository. This is the log generated:

Generated by ArmA3Sync 1.5.80
31-may-2016 0:30:48

Check for Addons finished with errors for repository name: ST1
An unexpected error has occured.
StackTrace:
java.lang.ArrayIndexOutOfBoundsException: -1
	at fr.soe.a3s.jazsync.FileMaker.mapMatcher(FileMaker.java:534)
	at fr.soe.a3s.jazsync.FileMaker.getCompletion(FileMaker.java:135)
	at fr.soe.a3s.jazsync.Jazsync.getCompletion(Jazsync.java:118)
	at fr.soe.a3s.dao.connection.HttpDAO.getFileCompletion(HttpDAO.java:359)
	at fr.soe.a3s.service.connection.HttpService.determineFilesCompletion(HttpService.java:305)
	at fr.soe.a3s.ui.repositoryEditor.workers.AddonsChecker.run(AddonsChecker.java:151)

It shows on clients and the local machine aswell. No idea what's the cause. I'm using http protocol and never had any issue building or updating my repos.

 

EDIT: solved. It seems that there were some corrupted pbos.

Share this post


Link to post
Share on other sites

workshop mods are now in Steam\SteamApps\workshop\content\107410 and not only that, their folder names are now freaking numbers. That was baaaaad bohemia grrrrrrrr.

Share this post


Link to post
Share on other sites

Hi,

I'm having an error while trying to compare the addons with the repository. This is the log generated:

Generated by ArmA3Sync 1.5.80
31-may-2016 0:30:48

Check for Addons finished with errors for repository name: ST1
An unexpected error has occured.
StackTrace:
java.lang.ArrayIndexOutOfBoundsException: -1
	at fr.soe.a3s.jazsync.FileMaker.mapMatcher(FileMaker.java:534)
	at fr.soe.a3s.jazsync.FileMaker.getCompletion(FileMaker.java:135)
	at fr.soe.a3s.jazsync.Jazsync.getCompletion(Jazsync.java:118)
	at fr.soe.a3s.dao.connection.HttpDAO.getFileCompletion(HttpDAO.java:359)
	at fr.soe.a3s.service.connection.HttpService.determineFilesCompletion(HttpService.java:305)
	at fr.soe.a3s.ui.repositoryEditor.workers.AddonsChecker.run(AddonsChecker.java:151)

It shows on clients and the local machine aswell. No idea what's the cause. I'm using http protocol and never had any issue building or updating my repos.

 

EDIT: solved. It seems that there were some corrupted pbos.

 

You had corrupted .zsync file(s) into the repository.

Share this post


Link to post
Share on other sites

Added  Steam\SteamApps\workshop\content\107410

 

Would it be possible for Armasync to recognize the numbered folders, and show their names instead in armasync?

 

http://pasteboard.co/1kAKL45j.png

 

A lot of furor over this right now because many use your program :) .

 

https://forums.bistudio.com/topic/191137-launcher-doesnt-store-mods-where-i-told-it-to/

Share this post


Link to post
Share on other sites

Hello, friends. I have bit of a problem here.

 

My GU runs a Arma3Sync server, but, apparently, couple of days ago my provider decided to block it.

If I enable proxy in my browser (FriGate), I'm able to connect to http frontpage of that website.

So, is there a way I could use Arma3Sync with proxy or maybe there's another solution to that?

Share this post


Link to post
Share on other sites

Hello, friends. I have bit of a problem here.

 

My GU runs a Arma3Sync server, but, apparently, couple of days ago my provider decided to block it.

If I enable proxy in my browser (FriGate), I'm able to connect to http frontpage of that website.

So, is there a way I could use Arma3Sync with proxy or maybe there's another solution to that?

 

Nope ArmA3Sync doest not have proxy option. Maybe you could configure your router to use another DNS server like the Google one.

Share this post


Link to post
Share on other sites

Added  Steam\SteamApps\workshop\content\107410

 

Would it be possible for Armasync to recognize the numbered folders, and show their names instead in armasync?

 

http://pasteboard.co/1kAKL45j.png

 

A lot of furor over this right now because many use your program :) .

 

https://forums.bistudio.com/topic/191137-launcher-doesnt-store-mods-where-i-told-it-to/

 

Will see what I can do eventually.

See https://forums.bistudio.com/topic/191137-launcher-doesnt-store-mods-where-i-told-it-to/?p=3033577

Share this post


Link to post
Share on other sites

Hello,

are there any plans to add periodic remote repo checking / automatic update in addition to the startup-time check? Or alternatively a check before game start?

Would be very useful to ensure people are starting the game / joining a server with the latest mod versions.

I know there are other launchers that can do it, but they either lack the feature set of a3s or require completely custom metadata and repo duplication.

Thanks!

Share this post


Link to post
Share on other sites

Would it be possible to add a tick box to enable battleye to avoid having to change the exe each time you want to start up with battleye? It would be greatly appreciated!

Share this post


Link to post
Share on other sites

Do i need to open Ports? 

 

Have the Repo on my Dedi machine but when i try to connect from my pc it says this https://gyazo.com/d8661fcd30e1be5ec56ea1009947c9b5.

 

but the .a3s config is there

Paste the repository url on a web browser an try to browse the repo / download file.

There are many causes (router, firewall, antivirus, bad server conf...)

Share this post


Link to post
Share on other sites

Would it be possible to add a tick box to enable battleye to avoid having to change the exe each time you want to start up with battleye? It would be greatly appreciated!

Yes it is. However you can create ArmA3Sync profiles (see profiles menu) with specific exe associated and switch from one profile to another.

Share this post


Link to post
Share on other sites

Paste the repository url on a web browser an try to browse the repo / download file.

There are many causes (router, firewall, antivirus, bad server conf...)

Testet it. Cant connect on web browser to the repo. But dont know what i have done false

Share this post


Link to post
Share on other sites

Hello,

are there any plans to add periodic remote repo checking / automatic update in addition to the startup-time check? Or alternatively a check before game start?

Would be very useful to ensure people are starting the game / joining a server with the latest mod versions.

I know there are other launchers that can do it, but they either lack the feature set of a3s or require completely custom metadata and repo duplication.

Thanks!

Auto-update repository option: it is possible yes

Check before game start: there are several ways in ArmA3sync to launch the game with addons.

If people use the online Panel, set a Join with Modset from the good repository, use the Join server combo box properly then it is ok to do the check.

Now if the same people make custom addon groups and click Start Game button, there is no way to make the association between the addons list and the targeted game server.

Share this post


Link to post
Share on other sites

Testet it. Cant connect on web browser to the repo. But dont know what i have done false

if the repository url needs login and password, autoconfig wont work (anonymous access is required). Simply add credentials manually.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×