Jump to content
major_shepard

ArmA3Sync - launcher and addons synchronization software for ArmA 3

Recommended Posts

Thank you to the people behind Arma3Sync[/i]

Edited by modest

Share this post


Link to post
Share on other sites

eney body running there repo from a synology server???

Share this post


Link to post
Share on other sites

Big Thank you to the people behind Arma3Sync - i love this Launcher

Feature-Request:

Categorie for Favorite Server

Enable/Disable Favorite Server

Translation-File (i want translate it to german)

Share this post


Link to post
Share on other sites

Hi, arma3sync GUI is not launching on our server since the last update. I can see it in task manager and if I run the .bat file I get this (running as administrator with java 8 installed):

ArmA3Sync Installed version = 1.4.63
DevMode = false
JRE installed version = 1.8.0_25
Exception in thread "main" java.lang.NullPointerException
       at fr.soe.a3s.service.AddonService.getAvailableAddonsTreeInstance(AddonS
ervice.java:78)
       at fr.soe.a3s.service.AddonService.getAvailableAddonsTree(AddonService.j
ava:168)
       at fr.soe.a3s.ui.mainEditor.AddonsPanel.updateAvailableAddons(AddonsPane
l.java:400)
       at fr.soe.a3s.ui.mainEditor.AddonsPanel.init(AddonsPanel.java:387)
       at fr.soe.a3s.ui.mainEditor.MainPanel.init(MainPanel.java:492)
       at fr.soe.a3s.main.ArmA3Sync.start(ArmA3Sync.java:184)
       at fr.soe.a3s.main.ArmA3Sync.main(ArmA3Sync.java:55)

Share this post


Link to post
Share on other sites
Hi, arma3sync GUI is not launching on our server since the last update. I can see it in task manager and if I run the .bat file I get this (running as administrator with java 8 installed):

ArmA3Sync Installed version = 1.4.63
DevMode = false
JRE installed version = 1.8.0_25
Exception in thread "main" java.lang.NullPointerException
       at fr.soe.a3s.service.AddonService.getAvailableAddonsTreeInstance(AddonS
ervice.java:78)
       at fr.soe.a3s.service.AddonService.getAvailableAddonsTree(AddonService.j
ava:168)
       at fr.soe.a3s.ui.mainEditor.AddonsPanel.updateAvailableAddons(AddonsPane
l.java:400)
       at fr.soe.a3s.ui.mainEditor.AddonsPanel.init(AddonsPanel.java:387)
       at fr.soe.a3s.ui.mainEditor.MainPanel.init(MainPanel.java:492)
       at fr.soe.a3s.main.ArmA3Sync.start(ArmA3Sync.java:184)
       at fr.soe.a3s.main.ArmA3Sync.main(ArmA3Sync.java:55)

Go to ArmA3Sync installation directory -> Profiles -> delete all files

Do not use addon search directories like "C:\" (Windows) or "/" (Linux)

Fixed for next update.

Share this post


Link to post
Share on other sites

Thanks for the quick reply but I tried that and there was no change. However, deleting a3s.cfg allowed it to run so I could update the repository. I don't think I had any addon search directories set since we are only using this as a repository so perhaps the update was expecting one. Thanks for your time

Share this post


Link to post
Share on other sites

Good morning,

I hope I'm not redoing this question.

I run the arma3 sync now/host for a while with lot of fun.

I just ran into a issue I might or missed or not understand at the moment.

We have been switching providers and I got a new IP address !

I went to the online tab and changed it to the proper ip and port.

Problem is that it doesn't save the ip and port number but the old one keeps coming back !

So peeps that get the repository get the wrong ip/server in the online tab or join server.

With regards,

KillerBee

Share this post


Link to post
Share on other sites
clan Killer Bee;2965348']Good morning' date='

I hope I'm not redoing this question.

I run the arma3 sync now/host for a while with lot of fun.

I just ran into a issue I might or missed or not understand at the moment.

We have been switching providers and I got a new IP address !

I went to the online tab and changed it to the proper ip and port.

Problem is that it doesn't save the ip and port number but the old one keeps coming back !

So peeps that get the repository get the wrong ip/server in the online tab or join server.

With regards,

KillerBee[/quote']

From ArmA3Sync running on the server repository -> Online panel: set the proper IP -> Build options: select the Favourite servers -> Build repository.

Share this post


Link to post
Share on other sites

Thank you for the reply Major.

I have done that and I also have changed it like F2 and and reset the ip and the ports but no result the old ip came back.

Also have tried to delete the online with the red cross and added a new online with name and ip and port !

Also that failed and the old op came back again !

I made a extra with another name in the online with the new ip and started from the list and it booted arma3 and all the addons and went straight to the server.

When I restarted the arma3sync it was gone and behold the old freaking ip was still there !

It seems more that the ip don't get saved for some or other reason ?

Only when you enter it directly in the online and than start is seems to do what is needs to be doing after that is is all the same old !

With regards,

Killer Bee

Ps sorry that the reply took so long kids vacation and so on and so on :P

---------- Post added at 17:40 ---------- Previous post was at 16:30 ----------

Okay I think that I found out what went wrong !

You were right about how too change it major only you need to make one more step to let it remember.

You have too build the repo sent it to the server and than get the public auto config url and import it !

That why the old one gets overwritten .

I thought there would be a repo update announcement you get the update and fixed !

You need to rerun auto config by import and than all comes together ! Now just see if it works :p

Share this post


Link to post
Share on other sites
clan Killer Bee;2965841']Thank you for the reply Major.

I have done that and I also have changed it like F2 and and reset the ip and the ports but no result the old ip came back.

Also have tried to delete the online with the red cross and added a new online with name and ip and port !

Also that failed and the old op came back again !

I made a extra with another name in the online with the new ip and started from the list and it booted arma3 and all the addons and went straight to the server.

When I restarted the arma3sync it was gone and behold the old freaking ip was still there !

It seems more that the ip don't get saved for some or other reason ?

Only when you enter it directly in the online and than start is seems to do what is needs to be doing after that is is all the same old !

With regards' date='

Killer Bee

Ps sorry that the reply took so long kids vacation and so on and so on :P

---------- Post added at 17:40 ---------- Previous post was at 16:30 ----------

Okay I think that I found out what went wrong !

You were right about how too change it major only you need to make one more step to let it remember.

You have too build the repo sent it to the server and than get the public auto config url and import it !

That why the old one gets overwritten .

I thought there would be a repo update announcement you get the update and fixed !

You need to rerun auto config by import and than all comes together ! Now just see if it works :p

There is no need to re-import the autoconfig. Pretty sure you have some mess with permissions access on ArmA3Sync files.

Share this post


Link to post
Share on other sites

Okay I have checked it I just noticed that when the ip was correct but the addons in the addons tab wasn't checked.

After this you need to check the addons if there checked if the addons are not there check the modset.

Of course that is if the repomaker included that in the repo.

Hope this might help someone who might run into the same problem !

Thanks for the reply Major.

With regards,

KillerBee

---------- Post added at 18:22 ---------- Previous post was at 18:16 ----------

There is no need to re-import the autoconfig. Pretty sure you have some mess with permissions access on ArmA3Sync files.

I didn't do that!

I installed the program as it was never changed anything and ran administration.

The problem was that it didn't get saved (in my case) the new ip.

Apparently the ip did get changed in the new repo but not by the program itself there on the spot !

Got another member that had the same problem we been testing it !

Might be a glidge or something like antivirus or something that prohibit the changing of certain files no idea !

Still love the program ;)

Share this post


Link to post
Share on other sites

Hi. I am trying to setup repository, but I ran into an issue. When I go to Check Addons, after I uploaded them to remote server via ftp I get 403 or access denied error. I nailed it down to my .htaccess in the root which is fine and has many rules for blocking all kinds of pests. If I disable it, A3Sync works. Permissions are fine, paths are fine too.

Question is which method do you use in A3Sync which triggers my .htaccess rule to block it? I even tried to overide with new .htaccess in the repo folder ( which is on a subdomain now ) but it simply wont work, probably being intercepted as bad bot or other grabber method. I will not post my .htaccess in public, neither repo url since its a private server. I can send it to you via PM, or other means if needed.

Please assist. Thanks.

PS: Anonymous access via ftp is not possible, it is not allowed by my provider, so I cant use it as a way of managing repo.

PPS: Most of the rules can be found here > http://pastebin.com/u/hackrepair

Edited by Jastreb

Share this post


Link to post
Share on other sites
Hi. I am trying to setup repository, but I ran into an issue. When I go to Check Addons, after I uploaded them to remote server via ftp I get 403 or access denied error. I nailed it down to my .htaccess in the root which is fine and has many rules for blocking all kinds of pests. If I disable it, A3Sync works. Permissions are fine, paths are fine too.

Question is which method do you use in A3Sync which triggers my .htaccess rule to block it? I even tried to overide with new .htaccess in the repo folder ( which is on a subdomain now ) but it simply wont work, probably being intercepted as bad bot or other grabber method. I will not post my .htaccess in public, neither repo url since its a private server. I can send it to you via PM, or other means if needed.

Please assist. Thanks.

PS: Anonymous access via ftp is not possible, it is not allowed by my provider, so I cant use it as a way of managing repo.

PPS: Most of the rules can be found here > http://pastebin.com/u/hackrepair

Past the url of the repo into a web browser and try browsing/downloading files (especially /.a3s/*)

Configure the server as it should and then once it works use ArmA3Sync.

Be sure that the server is configured to allow range request (true by default on Apache).

ArmA3Sync can perfectly manage a FTP repo requiring credentials to login.

Share this post


Link to post
Share on other sites

So I should configure it to use ftp instead of http? Nope either way it fails. I cant configure apache it is already configured by the host and I can access the files perfectly if I point to them directly trough the web browser even if .htacces is there. Your app cant.

Try autoconfig

Edited by Jastreb

Share this post


Link to post
Share on other sites

Hi guys, I am new here and since I cant start a thread or find the relevant thread I though I would post here (sorry if I am breaching any rules) , I am having this problem within the editor where I sync the modules and everything but once support is called and the pawnee and wipeout arrive at the designated location they just fly over without engaging... any ideas?

Share this post


Link to post
Share on other sites
So I should configure it to use ftp instead of http? Nope either way it fails. I cant configure apache it is already configured by the host and I can access the files perfectly if I point to them directly trough the web browser even if .htacces is there. Your app cant.

Try autoconfig

send me the login info of the http repo by PM.

---------- Post added at 09:20 AM ---------- Previous post was at 09:19 AM ----------

Hi guys, I am new here and since I cant start a thread or find the relevant thread I though I would post here (sorry if I am breaching any rules) , I am having this problem within the editor where I sync the modules and everything but once support is called and the pawnee and wipeout arrive at the designated location they just fly over without engaging... any ideas?

wrong place ^^

Share this post


Link to post
Share on other sites

Could you advise me on where I should post? would it have to be a thread precisely for this problem or...

Share this post


Link to post
Share on other sites

The 403 error comes from the fact that your HTTP server is configured to allow only HTTP request with declared User-Agent => https://en.wikipedia.org/wiki/User_agent

As ArmA3Sync does not declare a User-Agent in the header, you have to edit the Apache httpd conf to workaround this right now (see Access control by environment variable) => http://httpd.apache.org/docs/2.2/howto/access.html

Edited by Major_Shepard

Share this post


Link to post
Share on other sites

I think I have that in the rules in .htaccess to block empty user agents. Will check.

Edit: I dont know which rule that is, I tried disabling any that refers to blank user agents and it still failes to work. If I disable .htaccess it works. can you help me nail which rule it is?

RewriteCond %{HTTP_USER_AGENT} ^$
RewriteRule ^(.*)$ - [F]

Disabled all of those I found and still nothing. It is disabled completely now (.htaccess) and you may try it will work now. But I dont want to leave it this way.

#restored back - site cant operate without it properly

Edit: And actually your user agent with the arma3sync is not blank

Date: Jul 15 12:22:46
HTTP Code: 200
HTTP Version: HTTP/1.1
Referer:
Size (in bytes): 19739
User Agent: ArmA3Sync

I have disabled the hacklist user agent blacklist in main .htaccess and now it works, but this is not a real solution.

Edited by Jastreb

Share this post


Link to post
Share on other sites
I think I have that in the rules in .htaccess to block empty user agents. Will check.

Edit: I dont know which rule that is, I tried disabling any that refers to blank user agents and it still failes to work. If I disable .htaccess it works. can you help me nail which rule it is?

RewriteCond %{HTTP_USER_AGENT} ^$
RewriteRule ^(.*)$ - [F]

Disabled all of those I found and still nothing. It is disabled completely now (.htaccess) and you may try it will work now. But I dont want to leave it this way.

#restored back - site cant operate without it properly

Edit: And actually your user agent with the arma3sync is not blank

Date: Jul 15 12:22:46
HTTP Code: 200
HTTP Version: HTTP/1.1
Referer:
Size (in bytes): 19739
User Agent: ArmA3Sync

I have disabled the hacklist user agent blacklist in main .htaccess and now it works, but this is not a real solution.

The user agent is blank when ArmA3Sync tries to retrieve the /.a3s/*.* files but it's is not blank when it performs range request. You may have intercept my tries in the server log.

I will fix this in next update. However be aware that blocking user-agent is a complete useless method nowadays against bots as it is very easy to workaround.

Edited by Major_Shepard

Share this post


Link to post
Share on other sites
The user agent is blank when ArmA3Sync tries to retrieve the /.a3s/*.* files but it's is not blank when it performs range request. You may have intercept my tries in the server log.

I will fix this in next update. However be aware that blocking user-agent is a complete useless method nowadays against bots as it is very easy to workaround.

Ah that is why I got 403 when trying to initialize the repo and check addons. Well, removing blacklist fixed it, but you should still add user agent. I know that blocking bots is not bulletproof, but it can at least save some bandwidth and reduce error log size. I will not block empty user agents anymore, but will apply rules for specific bots if I find it necessary. The bigger the htaccess the slower the site. Everything has a price I guess.

Thanks for cooperation.

Share this post


Link to post
Share on other sites

Shepard, help please. I get error "ioexception caught while copying" everytime whenever I try to connect to repository. I read this forum topic, but i didn`t found anything useful.

Arma3Sync.bat console content

ArmA3Sync Installed version = 1.4.63

DevMode = false

JRE installed version = 1.8.0_05

Connection updates repository Success

ArmA3Sync Available update version = 1.4.63

---------- Post added at 09:21 ---------- Previous post was at 09:11 ----------

Now I tried to install Java 7

ArmA3Sync Installed version = 1.4.63

DevMode = false

JRE installed version = 1.7.0_79

Connection updates repository Success

ArmA3Sync Available update version = 1.4.63

org.apache.commons.net.io.CopyStreamException: IOException caught while copying.

at org.apache.commons.net.io.Util.copyStream(Util.java:134)

at org.apache.commons.net.ftp.FTPClient._retrieveFile(FTPClient.java:187

4)

at org.apache.commons.net.ftp.FTPClient.retrieveFile(FTPClient.java:1846

)

at fr.soe.a3s.dao.FtpDAO.downloadFile(FtpDAO.java:111)

at fr.soe.a3s.dao.FtpDAO.downloadSync(FtpDAO.java:126)

at fr.soe.a3s.service.FtpService.checkRepository(FtpService.java:90)

at fr.soe.a3s.ui.mainEditor.MainPanel$25.run(MainPanel.java:985)

at java.lang.Thread.run(Unknown Source)

Caused by: java.net.SocketTimeoutException: Read timed out

at java.net.SocketInputStream.socketRead0(Native Method)

at java.net.SocketInputStream.read(Unknown Source)

at java.net.SocketInputStream.read(Unknown Source)

at java.io.BufferedInputStream.read1(Unknown Source)

at java.io.BufferedInputStream.read(Unknown Source)

at java.io.FilterInputStream.read(Unknown Source)

at org.apache.commons.net.io.Util.copyStream(Util.java:100)

... 7 more

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×