Jump to content
Sign in to follow this  
NebulaePC

PhysX3_x86.dll Crash

Recommended Posts

And its only NV cards that have the issue.

Wrong.

I'm using Crossfire HD7950, and I'm getting PhysX crashes every 5-20 minutes when playing online.

Share this post


Link to post
Share on other sites

Issue still exists in "stable" release/Final release.

Have opted out of the DEV branch, and the issue still exists.

Additionally, I'm also now running the NV BETA drivers, and I am still having issues.

EDIT: I can offload the PhysX to the CPU via. the NVCP, however the issue still remains. I was benching my system last night and have performed a full OS rebuild for that purpose, still the same thing. Purged the local cache, removed one of my 690's, still the same thing.

Been playing since Alpha, and this has only become an issue since ~ ver. 0.74 or something

Edited by Lord_OverKill

Share this post


Link to post
Share on other sites

Still having this issue. I can play about 10 minutes online before crash. It happens on every server I've tried, just like in the alpha.

Specs:

i7 920 @ 4ghz

7870XT Tahiti

6GB DDR3 2ghz

Share this post


Link to post
Share on other sites
Additionally, I'm also now running the NV BETA drivers, and I am still having issues.

EDIT: I can offload the PhysX to the CPU via. the NVCP, however the issue still remains. I was benching my system last night and have performed a full OS rebuild for that purpose, still the same thing. Purged the local cache, removed one of my 690's, still the same thing.

Been playing since Alpha, and this has only become an issue since ~ ver. 0.74 or something

Same here.

Share this post


Link to post
Share on other sites

i always had random gamecrashes in multiplayer mode due to that physx thingie through the beta, and wonder they continue to happen in final release. its totally random to me, sometimes in menu, sometimes after loading, sometimes within the first 15 minutes, sometimes after 3 hours .. i have no clue what that happens.

to my specs:

win7 64bit, i7 870, 8 gigs of ram, ati radeon 6870 .. already tried bunch of different drivers (chipset, graphics card, direct x, etc etc etc). i also reinstalled windows .. no change..

i hope you can fix it soon, because by now the game is some sort of unplayable for me

Share this post


Link to post
Share on other sites

Yeah still crashing post release on the stable version.

Atm this thread is in the top ten most viewed in troubleshooting. Some attention to this issue by the devs would be nice because many of us are sitting with a product that don't work. And by the looks of it we can't do anything about it.

Have a ticket about my crashes here:

http://feedback.arma3.com/view.php?id=12532

Share this post


Link to post
Share on other sites

Wow. Just played a full night without a crash from this.

I turned on Windows Aero (Win7 x64).

I also Installed the @CBA addons to use the VTS Weapon Rest.

Edited my PageFile to use 8192mb for min & max. Who knows.

For what it's worth.

*Edit*

Crashed tonight with the PhysX error. Oh well, so much for that.

*Edit*

Godamnit! Can't be a driver/pilot or a player of importance due to this sporadic game-ender!

Edited by Kridian

Share this post


Link to post
Share on other sites

Recently got Arma 3 and was getting this message without fail every 10-30 mins in games.

Updated PhysX to 9.13.0604 and haven't had a problem since.

Share this post


Link to post
Share on other sites
Recently got Arma 3 and was getting this message without fail every 10-30 mins in games.

Updated PhysX to 9.13.0604 and haven't had a problem since.

ive also tried updating physx --> did not help :/

Share this post


Link to post
Share on other sites

still crashing in MP from time to time. sometimes I can play 30 mins sometimes 2 hours...

it always happens when there are fights in the viewing range... why does the whole client crash from physx? cant they just make the function redundant? i need to see this code...

I always spent hours days for my code that it never crashes - and if so it should say me why..

Share this post


Link to post
Share on other sites
ive also tried updating physx --> did not help :/
How can you update PhysX if you run AMD software?hardware?.

---------- Post added at 16:19 ---------- Previous post was at 16:16 ----------

Recently got Arma 3 and was getting this message without fail every 10-30 mins in games.

Updated PhysX to 9.13.0604 and haven't had a problem since.

How does updating PhysX change the DLL in the Game folder? And "9.13.0604" is a legacy driver for pre 2007 games. You want (if your updating your Nvida cards PhysX) 9.13.725 (august update) http://www.nvidia.com/object/physx-9.13.0725-driver.html But still it wont change your ARMA3 DLL. But the old legacy DLLs might just keep any Nvida DLL from getting in the way...?

Odd to see the AMD cards having this issue. It would be nice to know what drivers your on, and how you installed .Net. Let windows do it from Update, or let AMDs driver give it to you, Or did you download DotNet4.5 and install at time of OS install?

Edited by kklownboy

Share this post


Link to post
Share on other sites
How can you update PhysX if you run AMD software?hardware?.

---------- Post added at 16:19 ---------- Previous post was at 16:16 ----------

How does updating PhysX change the DLL in the Game folder? And "9.13.0604" is a legacy driver for pre 2007 games. You want (if your updating your Nvida cards PhysX) 9.13.725 (august update) http://www.nvidia.com/object/physx-9.13.0725-driver.html But still it wont change your ARMA3 DLL. But the old legacy DLLs might just keep any Nvida DLL from getting in the way...?

Odd to see the AMD cards having this issue. It would be nice to know what drivers your on, and how you installed .Net. Let windows do it from Update, or let AMDs driver give it to you, Or did you download DotNet4.5 and install at time of OS install?

1.

I didnt know i was able to, but as i read the physx ist a cpu thingie which CAN be unloaded to the gpu if the gpu supports it - but maybe im wrong no clue.

due to this game currently being unplayable for me ive tried what he suggested.

http://www.nvidia.com/object/physx-9.13.0604-driver.html

downloaded, installed, it didnt say "no nvidia gpu detected" as it would normally do - i dont know if it could have affected game behaviour or not for me, but at least it DIDNT ;)

2.

i usually download .net frameworks

l2jl-2-c81e.jpg

Share this post


Link to post
Share on other sites

New drivers today 327.23 did NOT fix the PhysX3_86.dll crash. If anyone was wondering.

Share this post


Link to post
Share on other sites

Why should physx drivers fix the problem?

The game doesn't seem to require them, they are not installed as a required redistributable.

Latest libraries in newest physx drivers seem to be for up to the 2.8 physx SDK and the game comes with libraries from the 3.2 physx SDK, so I doubt they are ever used.

Share this post


Link to post
Share on other sites

Have you guys ever set the maxmem that the game can use? I set mine to 4097 and it hasn't crashed in a while on missions I used to crash on, so maybe this is a memory leak or something?

Share this post


Link to post
Share on other sites

please realize that GPU drives / physx drivers dependent is PhysX 2 ...

as Arma 3 uses PhysX 3 (CPU only), has own libraries delivered wih the game itself ...

so it's highly unlikely You need any physx driver updates

also STOP looking on Eventviewer !

we need Your .RPT .MDMP .BIDMP files created by Arma 3 engine,

compress them and upload to Arma 3 feedback tracker and upload to here

btw. make sure You tested DEVelopment branch of game http://forums.bistudio.com/showthread.php?149411-How-to-change-between-stable-Arma-3-Alpha-versions-amp-release-candidates-STEAM-client

Edited by Dwarden

Share this post


Link to post
Share on other sites
Dan;2510552']Have you guys ever set the maxmem that the game can use? I set mine to 4097 and it hasn't crashed in a while on missions I used to crash on' date=' so maybe this is a memory leak or something?[/quote']

Yeah atm i have mine at 8192 I'll try 4097 but i think it's a long shot. Nice to see you're reporting back though.

A small update on my end, my feedback ticket on this have finally been assigned to a dev http://feedback.arma3.com/view.php?id=12532 so there's hope.

Maybe we have the devs ears on this now so i recommend everyone to fill out a feedback ticket at feedback.arma3.com

http://feedback.arma3.com/how-to-user.html.html and if you cant find your appdata folder then the map is probably just hidden.

Share this post


Link to post
Share on other sites
Yeah atm i have mine at 8192 I'll try 4097 but i think it's a long shot. Nice to see you're reporting back though.

A small update on my end, my feedback ticket on this have finally been assigned to a dev http://feedback.arma3.com/view.php?id=12532 so there's hope.

Maybe we have the devs ears on this now so i recommend everyone to fill out a feedback ticket at feedback.arma3.com

http://feedback.arma3.com/how-to-user.html.html and if you cant find your appdata folder then the map is probably just hidden.

Been playing for about 3-4 days with that and cpucount = 4 and it hasn't crashed a single time, even though I have been playing sessions that were 4 hours long (playing occupation by Bangabob), game also runs smoother for me with that so its certainly worth trying both of those commands. (don't count your hyperthreaded cores, only real ones)

Share this post


Link to post
Share on other sites

download_button.png

Upload my 2 mdmp/rpt for tonight game.

Crash reason : PhysX3_x86.dll

Mods : no mods (neither server or me)

Island : Altis

Mission : Ahoy Invade & Annex (modified by NGBC french team)

Latest event while alive : My last action in the game on the second crash was when my chopper wheel touch the ground at the main air base of that mission. I was on the third person view while looking the wheel animation touching the ground.

Side note : I noticed on the second crash that arma3 process was using around 2Go of RAM. I got 12Go of RAM in my PC, so it can't get higher if needed, i guess there is a default limit in the process itself. Don't know if that can helps understand the problem with PhysX3 dll

----

I am now downloading the Development branch, i'll report any dumps i got while trying this one as soon as i... crashed :yay: ;)

Edited by Paul-Hewson

Share this post


Link to post
Share on other sites

Had another crash today, It was on a invade and annex server, it was full too, and it crashed within 20 mins of the game starting, in comparison of it not crashing for about a week (on stable) when playing with about 10 players on insurgency), I definitely think there must be something wrong as far as a potential leak or cpu choke.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×