Jump to content

Haymaker

Member
  • Content Count

    45
  • Joined

  • Last visited

  • Medals

Community Reputation

13 Good

2 Followers

About Haymaker

  • Rank
    Lance Corporal

Profile Information

  • Gender
    Not Telling

Contact Methods

  • Youtube
    youtube.com/haymakerproductions

Recent Profile Visitors

848 profile views
  1. Haven't been able to fix this problem. Note, it works exactly as it's supposed to in SP, however, when it gets to multiplayer, the hold action only appears after the target has gone unconscious and come to again. I figure this has either something to do with the way that hold actions are handled on the dedicated, or more likely, respawn on start? Anyone have any ideas?
  2. So I'm working on the conditional to the hold action to apply to civilians and other units. I have my mission running on my server and people are having the following issue. I want the units to only have the hold action if they are conscious and restrained. Now I thought I had this fixed, but am currently away and not on a computer that can actually test this. They only get the action if they become unconscious. I've tested this without the negation and with false instead of true. I thought this worked but it isn't. I'd like to figure this out and replace this one script on the server so it works until I can get to it, could someone help my logic here? My issue is with this particularly: !(_target getVariable ['ACE_isUnconscious', true]); Or the whole script (I removed my script calls because they aren't necessary here): [_this, //Object "talk to the civilian", //Text "\a3\ui_f\data\IGUI\Cfg\holdactions\holdAction_connect_ca.paa", //Initial icon "\a3\ui_f\data\IGUI\Cfg\holdactions\holdAction_connect_ca.paa", //Progress icon "(alive _target) && (typeOf vehicle _this == 'rhsusf_usmc_recon_marpat_d_rifleman_fast') && !(_target getVariable ['ACE_isUnconscious', true]);", //Condition show action "(alive _target) && (typeOf vehicle _this == 'rhsusf_usmc_recon_marpat_d_rifleman_fast') && !(_target getVariable ['ACE_isUnconscious', true]);", //Condition progress action { _anims = ["STAND_U1","STAND_U2","STAND_U3"]; _anim = selectRandom _anims; [(_this select 0), "STAND_U1", "none"] call BIS_fnc_ambientAnim; }, //Code start {Hint "May I speak with you for a moment?";}, //Code progress { hint "Sure"; }, //Code completed {Hint "Don't bother me again.";}, //Code interupted [], //Arguments 2, //Duration 0, //Priority true, //Remove when completed false //Show when unconscious ] remoteExec ["BIS_fnc_holdActionAdd", [0,-2] select isDedicated, true]; Any help is greatly appreciated! -Haymaker
  3. Trying to get a killed unit to drop intel once killed. Script is executed on random spawned units. Take a look below but note that I am well aware that there are some variables changed for testing purposes. My issue is that for whatever reason, I get "type any, expected string" on the _spawnIntel line, which has been used prior successfully. I've tried using the position of "_unit", "killer", and "unit", each with no luck. Any help is much appreciated! Thanks! _unit = _this select 0; _intelPool = ["Land_Wallet_01_F","EvPhoto","EvMoney","EvMap","EvKobalt","EvMoscow","EvDogTags","Intel_File2_F","Leaflet_05_Old_F","Leaflet_05_New_F","Leaflet_05_F","Land_Camera_01_F","Land_HandyCam_F","Land_Laptop_F","Land_MobilePhone_smart_F","Land_MobilePhone_old_F","Land_PortableLongRangeRadio_F","Land_SatellitePhone_F","Land_Tablet_01_F"]; if (1 > .5) then { _unit addEventHandler ["killed", { // Get position of the killed unit _position = position killer; // Create intelligence at the position of the unit _intel = selectRandom _intelPool; _spawnIntel = createVehicle [_intel, _position, [], 0, "NONE"]; // Execute script on intel _spawnIntel execVM "scripts\hm_hardIntel\hm_checkIntel.sqf"; } ]; };
  4. Looking for the best way to get selectBestPlaces to return a value that is only on land, to avoid my script from spawning units underwater, if possible without having to create another loop. Thanks for the help! -Haymaker
  5. Not sure why I can't seem to get this to work. I get the script error "Type array, expected object, location". This also occurred when I tried to use modelToWorld. However, the script works correctly when executed on the player via debug console. Any help is much appreciated! Thanks! // Excerpted from another script of mine // Create the random unit on position of the recruitment station _unit = _group createUnit [_unitType, _spawnPosition, [], 0, "FORM"]; _unit execVM "scripts\hm_talibanLoadoutGenerator.sqf"; // Create a flare soldier if (random 1 < .5) then { _unit addEventHandler ["firedNear", {_this execVM "scripts\flareSoldier.sqf";}]; }; // flareSoldier.sqf if (!isServer) exitWith {}; _flares = ["F_40mm_red","F_40mm_green"]; _flare = selectRandom _flares; if (daytime >= 18 || daytime < 6) then { _flareSpawn = _flare createVehicle position _this; };
  6. Disabling Tobii worked! Thank you so much for your help! I'll also try to get my friend to recreate the issue and get a crash dump.
  7. Not quite sure how to use the CBA garrison function and would like to avoid writing my own if I could avoid it. Error - Undefined variable in expression. #cba_fnc_waypointGarrison **Steps to reproduce:** - Script executed on an object (not entire script, there is a unit defined) _spawnPosition = position _this; _group = creategroup east; _unit = selectRandom _unitPool; _unit createUnit[_spawnPosition, _group]; _garrison = [_group, _spawnPosition] call cba_fnc_waypointGarrison; //Also tried: [_group, _group, 150, "MOVE", "AWARE", "YELLOW", "FULL", "COLUMN", "leader _GROUP spawn CBA_fnc_waypointGarrison", [3,6,9]] call CBA_fnc_addWaypoint; *CBA_A3/addons/ai/fnc_waypointGarrison.sqf* I'm assuming I'm calling this function wrong but can't seem to be able to find documentation or examples to help. Thanks.
  8. His laptop is actually running Tobii Eye Tracking, I can have him do that for you, but he's going to disable it, and/or uninstall, and give it a try first to see if that's the problem.
  9. My community is having a small issue with ACRE2. I've been a user of ACRE since early Arma 2, and I love the mod and prefer it over all other radio mods, and would like to have it as a dependency on my scripted game-mode which I will soon be releasing to the public. There is one specific player that is a part of our playgroup who cannot join any server while running ACRE2. He gets stuck in the loading screen on joining a server, and if he leaves it long enough, he gets a DXGI error. This occurs on both local host and dedicated. He reinstalled all of his mods, his game, verified integrity of game cache, updated all of his graphics drivers, and reinstalled DirectX. We are certain that this problem is strictly caused by ACRE2 because he can join servers without issue while running other mods, while if he is running only ACRE2, he cannot join. If there is any known fix or any help you can provide to us, that would be fantastic. Otherwise I'm afraid we will have to make a switch to TFAR (which I REALLY, REALLY, do not want to do). Thank you!
  10. Mod has some serious potential but has unfortunately been remarkably broken for a long time.
  11. Any fixes yet? I changed direction to be _direction = random 360; which makes it work, but at the expense of vehicles being lined up with the road.
  12. Cheers! I'm going to have to credit you with all the help you've been giving me
  13. // _warlord is a unit classname, _position is a predetermined location, _group is a group (just clarifying) _warlord createUnit [_position, _group]; _cellLeader = nearestObject [_position, _warlord]; _cellLeader execVM "scripts\warlord.sqf"; warlord.sqf: _this addEventHandler ["killed", {success = success - 1; Hint "You have killed a cell leader";}]; Does absolutely nothing. I also tried adding the event handler to execute the script, with the script only containing the calculations (success = success - 1;). Not sure why I can't get this to work! All help is appreciated.
  14. // Determine nearestBuilding _nearestBuilding = nearestBuilding _position; // Create the warlord group _group = createGroup East; // Issue occurs somewhere within the nested if if (player distance _position > 400) then{ // Determine whether to spawn station in a building or outside if (_nearestBuilding distance _position < 400) then { // Spawn a station in the nearestBuilding _spawnFlag = createVehicle [_flag, _nearestBuilding buildingPos 1, [], 0, "NONE"]; // Spawn a cache in the nearestBuilding _spawnCache = createVehicle [_cache, _nearestBuilding buildingPos 1, [], 0, "NONE"]; } else { _cache = "CUP_TKVehicleBox_EP1"; _spawnflag = createVehicle [_flag, _position, [], 0, "NONE"]; _spawncache = createVehicle [_cache, _position, [], 0, "NONE"]; _spawntent = createVehicle ["Land_TentA_F", _position, [], 0, "NONE"]; }; _spawnVehicleStation = createVehicle [_vehicleStation, _position, [], 0, "NONE"]; _warlord createUnit [_position, _group]; }; No I did not include the entire script because it isn't necessary, the problem that is occurring is occurring somewhere within this excerpt - so assume all undeclared variables have been declared. So I've been working on some dynamic spawning scripts for some insurgent objects. I added a nested if to determine whether to spawn some of the assets inside a building or outside. Now this works about half of the time, the other half of the time it only spawns "_warlord" and "_vehicleStation" in the location, and throws "_cache" and "_flag" to the origin. I'm assuming that this could be because it doesn't recognize certain buildings as enterable with positions, in which case I will just have to prepare an array of buildings to look for. Any help or opinions are much appreciated. Thank you.
  15. Having a tough time adding a vest to _bomber for some reason. I've added the following line in several places in SSSB.sqf but no matter what it seems that the suicide bombers don't want to wear vests. Edit: It was the vest. I'm very stupid.
×