Jump to content
ICE_MAN

Custom faces have no shadow, can see eyeballs after latest update

Recommended Posts

Hello all! 

 

As part of my group's addon, we use a couple of custom faces (complete with custom models too). After this latest update where Mr. Crowe, Mr. Buchta, Mr. Pettka, and a couple other developer heads were added, I noticed that I could see my character's eyeballs now, and so could another group member. Both of us are using custom faces I built. I think it has to do with a config problem. I temporarily fixed the eyeball problem by creating a view-pilot lod and removing all objects from it. The shadow issue persists, though. (I tried creating a shadowvolume lod but it resulted in some pretty bad graphical glitches (I sharped the edges, merged near vertices, and triangulated the object in object builder)

 

Here is the config for Vori's head (at the end of my config.cpp):

 

class Default_A3{};
    class DefaultHead_A3: Default_A3{};
    class bun_female_bun_01: DefaultHead_A3
    {
        model="\A3_female_heads\Models\female_head_bun.p3d";
        selectionHeadWound="injury_head";
        selectionPersonality="personality";
    };

 

I looked in the new config.bin for the heads in the latest update, and saw where the new heads were added, so I attempted to use one of those classnames in hopes that her face would inherit the new heads' properties. I was wrong, the issue was the same. 

 

class Default_A3{};
    class DefaultHead_A3: Default_A3{};
    class Hladas: DefaultHead_A3{};
    class bun_female_bun_01: Hladas
    {
        model="\A3_female_heads\Models\female_head_bun.p3d";
        selectionHeadWound="injury_head";
        selectionPersonality="personality";
    };

 

 

Here is my actual config for the face itself:

class Default;
    class Man_A3: Default
    {
        class Default;
        class X_female_bun_01: Default
        {
            author="Iceman";
            displayname="Vorian";
            head="bun_female_bun_01";
            texture="\A3_female_heads\female_head_ICEMAN\female_01\xxx_co.paa";
            material="\A3_female_heads\female_head_ICEMAN\female_01\f_white.rvmat";
            
            materialWounded1="\A3_female_heads\female_head_ICEMAN\female_01\f_white.rvmat";
            materialWounded2="\A3_female_heads\female_head_ICEMAN\female_01\f_white.rvmat";
            ////////////////////////////////////////////////////////////////////////////////////////
            textureHL="\A3_female_heads\female_head_ICEMAN\female_01\F_HL_co.paa";
            materialHL="\A3_female_heads\female_head_ICEMAN\female_01\F_HL_white.rvmat";
            
            textureHL2="\A3_female_heads\female_head_ICEMAN\female_01\F_HL_co.paa";
            materialHL2="\A3_female_heads\female_head_ICEMAN\female_01\F_HL_white.rvmat";
        };

 

Does anybody know what I can do to fix this issue?

 

Thank you in advance for your help, and most respectfully,

 

Sam

Share this post


Link to post
Share on other sites

Ondrej,

 

Thank you very kindly for helping with this! I will look into it and let you know how I fare!

 

Sam

 

Share this post


Link to post
Share on other sites
On 12/7/2018 at 6:57 AM, oukej said:

I am sorry about the caused troubles :( There have been related changes in the Update 1.86 (https://dev.arma3.com/post/spotrep-00082)

Here is a short info about the changes with a how-to guide for updating models:

 

 

 

 

Ondrej,

 

I am having some issues still. My shadow LOD is triangulated, sharp edges, and smaller than the model itself, but it's creating some pretty wild visual glitches. I should clarify, I am not using any custom uniforms here. Just BI ones. I can see the shadows from the teeth, eyes, base of the neck, etc. through the object. Perhaps I just haven't set up the shadow LOD correctly. unknown.pngunknown.pngArmA_3_Screenshot_2018.12.12_-_20.07.55.

 

Of course without the shadowLOD the character has no shadow.

 

Thanks again and most respectfully,

 

Sam

Share this post


Link to post
Share on other sites

Make sure the texture changing named sections are not in the shadow LOD

i.e. you don't want the selections like personality and injury_head in the shadow mesh - it breaks the closed topology when the texture on those polygons is changed

  • Thanks 1

Share this post


Link to post
Share on other sites

Excellent, thanks guys! I was able to get everything working.

  • Like 1

Share this post


Link to post
Share on other sites

Is there any way to like.. bypass this? My group and I are using older face model packs that aren't active so there isn't much hope of them getting fixed.

Share this post


Link to post
Share on other sites

Most probably not, I am really sorry about that. Can you point us to the pack please?

Share this post


Link to post
Share on other sites

We are using "More Heads" from Zee Identity Pack. not sure if the link even works still!

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×