Jump to content
james2464

1.60+ Terrain Config Update Example

Recommended Posts

Hi guys,

 

Just thought I'd post the new Kunduz config for anyone interested in updating their terrain for 1.60 or Apex.

 

I believe this is the minimum required in order to inherit any future changes to lighting and terrain parameters.

 

Tested and inherits well without RPT errors.

class CfgPatches
{
	class PRA3_Kz
	{
		units[] = {};
		weapons[] = {};
		requiredVersion = 0.1;
		requiredAddons[] = {"A3_Data_F","A3_Roads_F","A3_Structures_F","A3_Map_Data","A3_Map_Stratis"};
	};
};

#include "cfgSurfaces.h"
#include "cfgVehicles.h"
#include "cfgEnvSounds.h"

class CfgWorlds
{
	class DefaultWorld
	{
		cutscenes[] = {"Kunduz_intro1"};
	};
	class CAWorld : DefaultWorld{};
	class DefaultLighting;
	class Stratis : CAWorld
	{
		class DefaultClutter;
		class Sea;
		class Underwater;
		class SeaWaterShaderPars;
		class WaterExPars;
		class HDRNewPars;
		class Lighting;
		class DayLightingBrightAlmost;
		class DayLightingRainy;
		class Weather;
		class SimulWeather;
		class EnvMaps;
		class OutsideTerrain;
		class Grid
		{
			class Zoom1;
			class Zoom2;
			class Zoom3;
		};
		class Sounds;
		class Animation;
		class Subdivision;
	};
	
	class Kunduz : Stratis
	{
		class Sea : Sea{};
		class Underwater : Underwater{};
		class SeaWaterShaderPars : SeaWaterShaderPars{};
		class WaterExPars : WaterExPars{};
		class HDRNewPars : HDRNewPars{};
		class Lighting : Lighting{};
		class DayLightingBrightAlmost : DayLightingBrightAlmost{};
		class DayLightingRainy : DayLightingRainy{};
		class Weather : Weather{};
		class SimulWeather : SimulWeather{};
		cutscenes[]			= {"Kunduz_intro1"};
		icon				= "";
		worldName			= "\pra3\pra3_kz\kunduz.wrp";
		pictureMap			= "\pra3\pra3_kz\data\icons\pictureMap_ca.paa";
		pictureShot			= "\pra3\pra3_kz\data\icons\ui_kunduz_ca.paa";
		plateFormat			= "AS$-####";
		plateLetters			= "ABCDEGHIKLMNOPRSTVXZ";
		author				= "$STR_PRA3_CFGWORLDS_KUNDUZ_AUTHOR";
		description			= "$STR_PRA3_CFGWORLDS_KUNDUZ_DESCRIPTION";
		newRoadsShape			= "\pra3\pra3_kz\data\roads\roads.shp";
		startTime			= "07:30";
		startDate			= "6/7/2009";
		midDetailTexture		= "A3\Map_Data\middle_mco.paa";
		access				= 3;
		worldId				= 1;
		mapSize				= 5120;
		mapZone				= 42;
		longitude			= 68.873;
		latitude			= -36.712;
		elevationOffset			= 0;
		clutterGrid			= 1.5;
		clutterDist			= 125;
		noDetailDist			= 65;
		fullDetailDist			= 20;
		minTreesInForestSquare	        = 2;
		minRocksInRockSquare	        = 2;
		safePositionAnchor[]	        = {1024,1024};
		safePositionRadius		= 1024;
		centerPosition[]		= {2048,2048,2048};
		seagullPos[]			= {1024,1024,1024};
		ilsPosition[]			= {0,0};
		ilsDirection[]			= {0,0,0};
		ilsTaxiOff[]			= {};
		ilsTaxiIn[]			= {};
		loadingTexts[]			= {"$STR_PRA3_CFGWORLDS_KUNDUZ_LOADINGTEXT1"};
		class EnvMaps : EnvMaps{};
		class OutsideTerrain
		{
			satellite = "pra3\pra3_kz\data\outsideterrain\s_satout_co.paa";
			enableTerrainSynth = 0;
			class Layers
			{
				class Layer0
				{
					nopx 	= "pra3\pra3_kz\data\kz_sanddesert_nopx.paa";
					texture = "pra3\pra3_kz\data\kz_sanddesert_co.paa";
				};
			};
			colorOutside[] = {0.8549,0.7019,0.3764,1};
		};
		class Grid : Grid
		{
			offsetX = 0;
			offsetY = 5120;
			class Zoom1 : Zoom1{};
			class Zoom2 : Zoom2{};
			class Zoom3 : Zoom3{};
		};
		class Sounds :  Sounds{};
		class Animation : Animation{};
		class Subdivision : Subdivision{};
		class AmbientA3
		{
			#include "cfgAmbience.h"
		};
		class Names
		{
			#include "cfgNames.h"
		};
	};
	initWorld = "Kunduz";
	demoWorld = "Kunduz";
};
class CfgWorldList
{
	class Kunduz{};
};
class CfgLensFlare{};
  • Like 13

Share this post


Link to post
Share on other sites

hi, tried the config above and it errors on the include sections when re-packing with pboProject

 

Also the cfgNames.h is not included with version 1.08 which is current release

Share this post


Link to post
Share on other sites

ok cool ill give it a go thanks

 

just need to work out the mapArea[] as its currently in long and lat - left as your example for now to see if it works can alter it after.

 

further add unable to repack due to missing textures for the roads.

Share this post


Link to post
Share on other sites

I warned this will happen on twitter months ago, exactly on Feb 11 :/ all custom maps broken...

  • Like 2

Share this post


Link to post
Share on other sites

Its turned out to be a clusterfcuk, with this and the addon mess up.

Ive stopped using the steam workshop and went back to the old way using Armaholic.

  • Like 1

Share this post


Link to post
Share on other sites

I had the same issue... when I rePBOd the path was wrong... there is an easy fix by downloading metal craze cup lighting and adding a few lines as posted in dev branch

Altho that is an old mod and cup was updated...

Share this post


Link to post
Share on other sites

I've updated the config in the OP to fix an issue where the moon and stars were not inheriting correctly and thus not showing in-game.

This config is for anyone who wants to model their new terrain config off this one.

 

 

 

 

Also the cfgNames.h is not included with version 1.08 which is current release

The extra includes will be merged with the config in the pra3_kz PBO. This happens when I build the terrain with PboProject.

  • Like 2

Share this post


Link to post
Share on other sites

Thanks James great info and brill work on version 1.2. At www.16aa.net we have been using your map to play a campaign for the past few weeks now and its going well. We have just updated to 1.2 and will next be playing on Sunday so will let you know if there is any feedback. our numbers on each mission are typically around 90+ members so its a good performance test but version 1.08 was working ok for us.

Share this post


Link to post
Share on other sites

Thanks James great info and brill work on version 1.2. At www.16aa.net we have been using your map to play a campaign for the past few weeks now and its going well. We have just updated to 1.2 and will next be playing on Sunday so will let you know if there is any feedback. our numbers on each mission are typically around 90+ members so its a good performance test but version 1.08 was working ok for us.

Yes i've seen your mission videos on Youtube, great viewing.

 

I'll have an update out before the weekend for AI river crossing issues with the two main bridges and stars and moon missing.

As for performance very interested to know more about the frame drops supposedly due to the poppy fields or zooming into certain areas... Thanks.

Share this post


Link to post
Share on other sites
        class Sea : Sea{};
        class Underwater : Underwater{};
        class SeaWaterShaderPars : SeaWaterShaderPars{};
        class WaterExPars : WaterExPars{};
        class HDRNewPars : HDRNewPars{};
        class Lighting : Lighting{};
        class DayLightingBrightAlmost : DayLightingBrightAlmost{};
        class DayLightingRainy : DayLightingRainy{};
        class Weather : Weather{};
        class SimulWeather : SimulWeather{};

unless you want to change something in those subclasses, you don't need to define them in order to inherit subclasses from the parent class. It's only required if you want to change something in them.

  • Like 2

Share this post


Link to post
Share on other sites

James, thanks for the update to 1.20.02 this has fixed the above problem :)

Your welcome to join us on an operation James if you would like a see us and the map in action? Let me know 

Share this post


Link to post
Share on other sites

Is there a way to dull down the ground textures as they are just so bright now they simply look sh*t

 

 

Before update

 

2015-12-09_13-52-59.jpg

 

 

After update:-

 

20160610223052_1.jpg

 

Share this post


Link to post
Share on other sites

Hello.

Try this with your old  config

 

first add this lines

 

skyColorInfluencesFogColor = 1;
tonemapMethod = 0;

 

and add this class

 

class HDRNewPars
        {
            minAperture = 1e-005;
            maxAperture = 256;
            apertureRatioMax = 4;
            apertureRatioMin = 10;
            bloomImageScale = 1;
            bloomScale = 0.3;
            bloomExponent = 1;
            bloomLuminanceOffset = 0.8;
            bloomLuminanceScale = 1;
            bloomLuminanceExponent = 1.2;
            tonemapMethod = 2;
            tonemapShoulderStrength = 0.22;
            tonemapLinearStrength = 0.3;
            tonemapLinearAngle = 0.1;
            tonemapToeStrength = 0.2;
            tonemapToeNumerator = 0.01;
            tonemapToeDenominator = 0.3;
            tonemapLinearWhite = 11.2;
            tonemapExposureBias = 2;
            tonemapLinearWhiteReinhard = "2.5f";
            nvgApertureMin = 1;
            nvgApertureStandard = 7;
            nvgApertureMax = 15;
            nvgStandardAvgLum = 3;
            nvgLightGain = 100;
            nvgTransition = 1;
            nvgTransitionCoefOn = "40.0f";
            nvgTransitionCoefOff = "0.01f";
            nightShiftMinAperture = 0;
            nightShiftMaxAperture = 0.002;
            nightShiftMaxEffect = 0.6;
            nightShiftLuminanceScale = 600;
            eyeAdaptFactorLight = 0.6;
            eyeAdaptFactorDark = 0.2;
        };

 

this photos its from our FFAAMOD LYTHIUM map

 

version 1.60 with new config ligthing with this new lines in config

 

0F055C424E29634E7CC910C65049E226EBD3542B

 

 this photos with my old config (old ligthing version 1.58)   run in ver.1.60 with this new lines in config

 

 

4BCF4B8B4FC5555490E1E8DF3CAEFA9E0E011B88  

 

 

 

 

in Stratis ver 1.60

 

2E9953009D32944F32B651A566B91728C10CFB71

 

 

in Lythium old config (old ligthing version 1.58)   run in ver.1.60 with this new lines in config

 

D7DC86E378A8424EC5A4D1F01087A6ED0CFB2F92

 

starts /night in Lythium old config (old ligthing version 1.58)   run in ver.1.60 with this new lines in config

F53ED41392DA5B4B1F01911123523AABFD4566A0

 

the last step its adapt the new system of clouds in the old config .Anyone helpme?

 

2AB3EA50E2F8099316A391BE7E2DE8A297ED959E

  • Like 2

Share this post


Link to post
Share on other sites

greenberet40: I did several tests of your config and it seems all nights (even without full moon) are very very bright. Also, some of the details are wierd:

 

tonemapMethod = 0; in the config then you make new class that has this line inside:

tonemapMethod = 2; ?

 

 

Here's an example shots with both configs:

v5O1gP3.jpg

  • Like 1

Share this post


Link to post
Share on other sites

i think the top version is better tbh, 

Share this post


Link to post
Share on other sites

@ Ice   - Any chance you can pm your config for the top image  as I am really struggling setting up my config as it all seems so bright and just looks strange !

 

Thanks

Share this post


Link to post
Share on other sites

I set the HDR to 2 and it increased the brightness off the ground textures to unplayable levels, i'm going to experiment by darkening the sat

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×