Jump to content
Sign in to follow this  
RadicalAtHeart

Tutorial: How to fix pip flickering sli

Recommended Posts

I found out how to solve PIP flickering in ArmA 3.

It is really easy!

0. Make sure to have the latest drivers installed.

1. Download and install Nvidia Inspector http://www.techspot.com/downloads/5077-nvidia-inspector.html

2. Open Nvidia Inspector

3. Find ArmA 3 Profile

4. Change Nvidia Predefined SLI Mode to SLI_PREDEFINED_MODE_FORCE_SFR

5. Hit APPLY button.

6. start game.

7. Enjoy, please give me credits ;) (Jonas Hendrickx, Belgium)

70199986.png

22836507.png

Those who want to buy me a beer are always welcome! ;) See you ingame!

  • Like 1

Share this post


Link to post
Share on other sites

You can force single frame rendering in nvidia control panel as well, why bother with nvidia inspector?

  • Like 1

Share this post


Link to post
Share on other sites

My GPU only showe Single GPU, alternate frame rendering 1 and alternate frame rendering 2

The previous frame is probably always black which is why you shouldnt have the GPUs draw in turns (AFR1 or AFR2) because the last frame drawn was 2 frames ago.

SFR mode splits the work across the 2 gpus for 1 frame.

Share this post


Link to post
Share on other sites

k, neato.

apparantly it's called split frame rendering. wonder why it's not used more? guess it doesn't perform as well in benchmarks.

edit:

http://developer.download.nvidia.com/whitepapers/2011/SLI_Best_Practices_2011_Feb.pdf

"This SLI rendering mode is typically not as desirable as AFR mode, since some of the work is duplicated and communications overhead is higher."

there's even a bit about Render to texture in that document.

Edited by Leon86

Share this post


Link to post
Share on other sites

I don't notice a severe performance degradation it's completely the same as with AFR2. I havent benchmarked but my FPS seems to be the same.

It's either SFR or a different implementation for PIP rendering as far as my research went.

Share this post


Link to post
Share on other sites

do you notice a difference in performance between sli on and sli off? it's pretty easy to be cpu limited in arma.

Share this post


Link to post
Share on other sites

I have been using SLi for a long time and never found SFR to be that great, any game I tried it on, the result where not very good compared to the AFR's. It may actually be possible that you could still use inspector to fix this flicker problem though. One of the (many) Sli compatibility bits would probably be the key. The only problem is the time it takes to go through all the settings, having to reload Arma and bench mark every time, pain in the butt :). There was a similar problem with DCS:Blackshark/A10 with clouds and PinP displays that was fixed using one of the compatibility bits.

I am sure though that Nvidia will fix this with an updated profile for Arma3. Hopefully that is not too far away.

I don't know if its my imagination, but have any of you noticed that the flicker seems to happen less than it was initially? Some vehicles I get in now (boats), and there is no flicker on the PiP monitors.

Share this post


Link to post
Share on other sites
I have been using SLi for a long time and never found SFR to be that great, any game I tried it on, the result where not very good compared to the AFR's. It may actually be possible that you could still use inspector to fix this flicker problem though. One of the (many) Sli compatibility bits would probably be the key. The only problem is the time it takes to go through all the settings, having to reload Arma and bench mark every time, pain in the butt :). There was a similar problem with DCS:Blackshark/A10 with clouds and PinP displays that was fixed using one of the compatibility bits.

I am sure though that Nvidia will fix this with an updated profile for Arma3. Hopefully that is not too far away.

I don't know if its my imagination, but have any of you noticed that the flicker seems to happen less than it was initially? Some vehicles I get in now (boats), and there is no flicker on the PiP monitors.

Lazy people could always disable PIP. I mean its a small bug really. They probably have to change the way it is drawn. If they give me pseudocode or a scheme of how PIP is drawn I could maybe correct the issue finding a better algorithm.

I havent noticed it. I am going to test with compatability bits and AFR2

Share this post


Link to post
Share on other sites

Sorry for resume this old thread but I've tried this solution and doesn't work.

I'm gona crazy, I've also tried to disable PIP but nothing... Still there flashing ...

Someone found another solution?

Thanks...

Share this post


Link to post
Share on other sites

This is not a fix, it is a work around at best. It does stop the flickering in Arma 3, however I have to revert back to defaults when I play another game, as this "fix" on average reduces the fps on my other games from 150 to 15.

Share this post


Link to post
Share on other sites
This is not a fix, it is a work around at best. It does stop the flickering in Arma 3, however I have to revert back to defaults when I play another game, as this "fix" on average reduces the fps on my other games from 150 to 15.

Easiest solution is to just Disable SLI, No benefit in this game.

Share this post


Link to post
Share on other sites
This is not a fix, it is a work around at best. It does stop the flickering in Arma 3, however I have to revert back to defaults when I play another game, as this "fix" on average reduces the fps on my other games from 150 to 15.

You can also enable the "fix" just for Arma3. Just search and select Arma3 in the Dropdown-Menu on the top

Share this post


Link to post
Share on other sites

so is this SFR solution basically making my 690 into a single gpu?? as I loose 25fps when doing so through the control panel... this looks interesting I will give it a shot though nonetheless

---------- Post added at 08:11 ---------- Previous post was at 08:10 ----------

Easiest solution is to just Disable SLI, No benefit in this game.

wrong buddy look at the above post of mine :)

Share this post


Link to post
Share on other sites
You can force single frame rendering in nvidia control panel as well, why bother with nvidia inspector?

Can you tell me how? I only see "SLI rendering mode" in the options and I've tried both alternates but neither fixes the issue.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×