Jump to content
noahtheboah36

Can't Play Arma 2 Multiplayer

Recommended Posts

Okay, so I bought Arma 2 and Arma 2 OA from Steam. I want to play multiplayer but I couldn't. My friend told me to "make an account" for Arma 2. How does one do that?

Share this post


Link to post
Share on other sites

Hi Welcome to BIS forums!

Sorry to read about your troubles. Making an account as your friend had suggested probably meant an account here on BIS forums.

If you bought Arma2OA on steam then obviously you already have an account on steam.

What we need to know is why you are unable to play multiplayer.

Please answer the following questions if you could:

-So what have you tried and or have done since you bought Arma2 and OA?

-When you clicked on multiplayer and seen the server listings, what color were the dots next to each server for you?

-Have you tried singleplayer at all?

-After launching the game on the right bottom side of the screen is a version number, what version is your game? 1.62, and some numbers after?

-With steam have you verified the integrity of your Cache?

-When you launch the game are you launching Arma2 only, OA only, or both as Combined Ops?

=================

answer those and lets see what we can figure out.

  • Like 1

Share this post


Link to post
Share on other sites

I have tried playing multiplayer, and launching the game via steam, my desktop shortcut, and dayz commander.

The server listings, when selected, had green dots next to the name on the bottom of the screen with the description of the specific server.

I've done a bit of single player to get used to the controls.

My version is 1.62...

Actually, I have verified my steam cache, and as I type this I am doing it a second time.

I am launching OA only. I don't know how to launch it as Combined Ops.

EDIT: Quick update, I just tried to launch a multiplayer server, it said "Bad version, server rejected connection."

Share this post


Link to post
Share on other sites

Hi, sorry for my late reply,

Bad version, server rejected usually means you dont have the same version/game as the server, in that case your issue might be that

your not running combined ops but just OA, I'm not a 100% on that but from the steam thread:

all You need is run ARMA 2 once then run OA (and A2: CO will be active by default)

This is after you installed the game of course.

If you need further help with steam related issues I suggest asking here:

ARMA2 & OA's Steam Thread: All Steam Q's/discussions go here [covered by Dwarden]

http://forums.bistudio.com/showthread.php?73554-ARMA2-amp-OA-s-Steam-Thread-All-Steam-Q-s-discussions-go-here-covered-by-Dwarden

Share this post


Link to post
Share on other sites

Thanks for the help, but I actually logged on just now to tell you that I got it to run. I guess maybe I had some internet router issues. Either way, thank you for your help, even if I didn't end up needing it or using it. After all, it's the thought that counts, and you've certainly shown that you thought about helping me. Anyway, thank you for the help.

Share this post


Link to post
Share on other sites

Excellent!

Glad you figured it out, and your welcome, I help where and if I can, I just hate seeing fellow players not enjoy this awesome game, and struggle with stuff.

Share this post


Link to post
Share on other sites

I'm having trouble playing online myself. I'm into the second mission on OA and stepped over to multiplayer.

When I try to log into a server, I'm always getting a response saying that I need to download more content. The content itself appears to be a textural bit or something. Should I take a screenshot?

EDIT: I'm starting to realize they're probably having a bunch of issues with moving to Steam. Hopefully someone here can help.

Share this post


Link to post
Share on other sites

that probably means that you don't have the DLC's like British Armed Forces or Private Military Company. the servers might use the full versions and this will mean that you will only see the light versions of it. (might also be that they use the Army of the Czech Republic DLC where there is no official Light version from)

maybe when you buy those DLC's you might have less problems

Share this post


Link to post
Share on other sites
that probably means that you don't have the DLC's like British Armed Forces or Private Military Company. the servers might use the full versions and this will mean that you will only see the light versions of it. (might also be that they use the Army of the Czech Republic DLC where there is no official Light version from)

maybe when you buy those DLC's you might have less problems

I can play single player. When trying to get into a server though, it just kicks me right back out. Always a new error. The 2 most common are Battle Eye failed to update, and I have deleted content that is required to play on this server. I don't know who has the deleted content me or the server. All I did was download this through Steam. Such a shame because this is the only game I want to play. Was even thinking of a new game rig to play Arma 3 on, now I just don't know. I've tried all the fixes you can find on YouTube for the 2 problems I've listed. One post had me copy add-ons folder to OA from Arma2 folder. Another showed how to update Battle Eye through Steam, but that option didn't show when I tried it in Steam. I know this game is great, I'm so disappointed. All the dots in the server list are yellow and have a question mark on them. Some are just green but no matter the color of the dot I get kicked back out. I've actually gotten into a few (with green dots) where I could go as far as selecting a team and a position, but when I hit ok to play, back out to the menu. Well, I hope someone can help me cuz Ill feel so ripped off if not. Don't understand why I have to jump through hoops to get this to play? And it seems I'm not the only one with this problem.

Share this post


Link to post
Share on other sites

The message you are getting is: "You cannot play/edit this mission, because it is dependent on content that is missing/has been deleted"

It means, that you dont have the required mods.

Find solution Here.

Edited by Mirek

Share this post


Link to post
Share on other sites

Hello maybe its not right topic here but i cant create any topics my self right now

because im new here i think but ill get to the point 

i cant play arma 2 ao multiplayer it dosent show any servers and when i try connecting manualy it says session lost .

 

Can anyone help please ?

Share this post


Link to post
Share on other sites

Hello maybe its not right topic here but i cant create any topics my self right now

because im new here i think but ill get to the point 

i cant play arma 2 ao multiplayer it dosent show any servers and when i try connecting manualy it says session lost .

 

Can anyone help please ?

Is it only OA? or do you have arma 2 too?

Try Verifying the game cache, it lately proved as solution to almost everything to me.

It might be caused by you having different game version than the servers you try to connect are using, or you lack a mod they are using, or they run ARMA 2 CO (Arma2 + Arma2OA)and you run only OA, or they have ACR DLC and you dont,  Or you use mods that are not alowed on the server, or your Firewall or antivirus blocks the connection, or your battleeye doesnt work properly.

Also it might be possible that your internet connection is just bad.

 

 

Edit: It realy might be  batleeye as it proven to be fucked up for lot of my friends lately.

Do this:

There are 3 folders in your computer containing battleeye files. 2of them are in your Arma 2 OA folder, one should be somewhere in your appdata/local folder. In one of them there are uninstallbattleeye.exe, run the uninstall first, then delete all the remaining files from all three folders, then verifi integrity of OA gamecache and then run A2OA trough steam. It shoul install battleeye again if it does, restart the game then, and try multiplayer if you see the servers now, if not, try entire procedure again. if it wouldnt help, then iam clueless.

Share this post


Link to post
Share on other sites

I don't know if it was the right topic but i have problem joining Arma:oa servers in multiplayer it keep sending me this error in the link  qGe8http://www.pictub.club/image/qGe8

 

-when i open multiplayer most of server have yellow dots and i run Arma2 for first time before run Arma2:oa.

 

-i have game version 1.63.131129.

 

-i now download it again.

 

Plz help 

 

Thanks....

Share this post


Link to post
Share on other sites

Abdalla the error message your getting is telling you what your missing all sorts of mods, which is DayZ, and many others, to find out,

go to armaholic and put the names in the search you see there, something will come up for them.

Your issue has nothing to do with the game in general but the mods your missing that the server requires for the mission your trying to join.

  • Like 1

Share this post


Link to post
Share on other sites

Abdalla the error message your getting is telling you what your missing all sorts of mods, which is DayZ, and many others, to find out,

go to armaholic and put the names in the search you see there, something will come up for them.

Your issue has nothing to do with the game in general but the mods your missing that the server requires for the mission your trying to join.

Thanks a lot Gunter Severloh i didn't know there are many other mods for weapons,etc...

 

i will try to download what i miss.

Share this post


Link to post
Share on other sites

I know it's a stupid question.. but.. Is the multiplayer actually playable after gamespy shut down? Did BI fix it? since I heard something about them trying to solve it..

I'd like to buy Arma 2 Complete Collection because it's a great game to me. I would be a bit disappointed if the multiplayer doesn't work properly.

Share this post


Link to post
Share on other sites

I know it's a stupid question.. but.. Is the multiplayer actually playable after gamespy shut down? Did BI fix it? since I heard something about them trying to solve it..

I'd like to buy Arma 2 Complete Collection because it's a great game to me. I would be a bit disappointed if the multiplayer doesn't work properly.

Sure, it is.

The game already has an update for Steam to 1.63. So you can find every server online using the classic finder.

Share this post


Link to post
Share on other sites

Hello all, Not sure if this is appropriate here?

 

The old GameSpy system is working again. In theory, most of the games that GameSpy supported should work with the gamerecon system (based on the gamemaster open source project) with minimal work

 

I'm happy to work through the details to see if it can be added to the support list. if anyone's interested in give it a try? Gamerecon  (no for-profit)  

 

 

- JH

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×