Jump to content

Bad serial number given in setup - use this thread for help

Recommended Posts


I have had the worst experience with this serial number thing.

I have searched far and wide for a solution but I have found none.

It's clear the moderators are trying their hardest to try to help us but I need a more specific help.

If you can call my number or even Skype me reply to my comment.

Please Help Me. thanks

---------- Post added at 12:40 ---------- Previous post was at 12:36 ----------

Ok, before I start I want to let you guys know that I realize there is a million other posts exactly like this, but I'm sick of searching. I have tried everything like running steam as admin, deleting both games and reinstalling them, exiting out of steam then back in, restarting my computer, and more. Arma 2 seems to work its just OA. In regedit in the Behemia Interactive NOT Behemia Interactive Studio it says in the Arma 2 AND Arma 2 OA Folders the only thing it has is (Default) No key, data, or main. Just (Default)

Please help

I also have this problem but i have another folder cal key with 000000000000000000 for a value.

Share this post

Link to post
Share on other sites

Hi everyone. I bought ArmA 2 Combined operations quite a while ago. When I got the game it worked fine for a month or two. Then it started to show the bad serial number given during setup. It does this for both Arma 2 and Arma 2 OA. I try a bunch of different things including re-buying it. Im really confused as to why this is happening. If anyone can help, that would be much appreciated.

Share this post

Link to post
Share on other sites
So, getting this wonderful serial number issue after downloading the game for the first time on this new rig. I've tried the most basic solutions, but I've noticed some issues in the registry that I haven't been able to resolve through these steps:



3, Expand Software

4, Expand Wow6432Node

5, Expand Bohemia Interactive Studio Not Bohemia Interactive

6, Click ArmA 2 OA, If you only see 1 file named "(Default)" And type REG_SZ then,

7, Right click the ArmA 2 OA file and go to Permissions

8, Left click YOUR USER, NOT! Users

9, After selecting your user click on Advanced

10, Yet Again click on your username for your pc and click on edit

11, In the drop down menu select This Key and Subkeys

12, You will see allow and deny make sure all allow boxes are ticked then click ok

13, you will be taken back one Dialogue box, Click Apply and OK and the same again on the

next dialogue box.

14, Now you should see 4 files sat in your ArmA 2 OA folder, Names, "(Default)" "Data" "Key" & "main"

15, Now play your game hassle free

My problems start at step 8. The only groups/users I have are

  • Administrators
  • Users

And, for the most part, I'm unable to change permissions settings even though I should have full access with admin. So is one of the groups listed in fact the user account on my computer, but named differently? Or is it for some reason missing entirely?

Another odd bit is that I can already see all 4 files in the OA folder, but still get the bad serial number, even when running steam as admin and after starting up either Arma 2 or OA as administrator straight from the Steamapps/common directories. I poked around on the forums quite a bit and haven't been able to find anything quite as unique as my particular problem, unless I'm missing something incredibly simple. In any case, I'd really like some help with this - I did pay for the game and the hurdle seem quite high with me unsuccessfully mucking around in my computer's registry.

This is happening to me to, I would like to figure this out except all you see is the same fix all over the place, I tried to figure it out but I cannot I have the exact simptoms as you. I hope we will have a fix for us.

Share this post

Link to post
Share on other sites

Wrong CD key!!!

Regards Placebo

My friend is having a problem with installation, recently when Arma was on Steam sale i bought it to myself even if i had already buyed game from BIStore so i decided to give the serials to my friend as gift,I played for some time with that serials,then uninstalled the whole game and installed my new arma over steam,he installed the Arma 2 and Arma OA and everything worked fine,recently he had some problems with his laptop and he re-installed Windows 7 and he tried to install game again using those serial keys,and Arma 2 goes well,but when he come to Arma OA it say to him that serial key is not valid.

PS. We did check every letter(number) is it correct tried typing it,copy-paste it nothing work,even i one moment he had problem that he cant enter the 5th digit in 4th rove of serial key,and when he reset setup it worked.


Share this post

Link to post
Share on other sites

Entered all my retail keys for ARMA 2, ARMA 2 OA, PMC, BAF, ACR and ARMA 2 Reinforcents into steam and all was accepted and added into my steam library as steam game. Then I spent two days to trying install it to be able to play 1.63 version. Without success. No matter if I followed guides, uninstalled retail versions and deleted all from disk and registry and run steam as admin (although I run my user as admin anyway) I always get same result. Arma 2 run ok, ARMA 2 OA throw some errors on startup and PMC/BAF DLCs I am unable to play.

I am unable to play game now.





Share this post

Link to post
Share on other sites

I purchased Combined Operations through Steam yesterday, and can run vanilla Arma II just fine. However, OA refuses to install, and the Beta (Obsolete) gives me the 'bad serial number' error message. I have tried the REGEDIT procedure, as well as verifying cache, but have had no luck so far.

On OA, I install the program in Steam, and it downloads, but then does not seem to recognize that it was downloaded, as I receive no option to play the game, only to install it again.

Share this post

Link to post
Share on other sites

Hi everyone, I have a steam copy of arma 2 pmc and all of the rest of the DLC and to keep a long story short I got pissed at being hacked 24/7 and downloaded a program which I thought did nothing but after i ran it a few days later I got global banned.(i was F%^$ing stupid) That was nearly a year ago, since then i've been playing on a new copy of arma 2 + all DLC with keys I bought and downloaded from BIS store. I understand the hatred people have with hackers and I understand some people might think I hacked but all that happened was my key got stolen switched with banned ones and both got banned in the end.

Now the reason I am here is that I have a predicament with steam, because I have banned arma 2 keys on steam, and I have new unbanned keys that I want to use because of this new patch which from what i've read is steam exclusive the only way I will be able to play is by using my keys on steam.

which I've tried by "activating a product using steam" option but it wont accept the new keys cos I already have arma2 on there.

so is there a way I can convert the keys into the hex format used in the registry, I understand that steam will switch them back every time

I boot the game but if I block permissions to overwrite them then that should not be a problem.

if anyone can help me then that's grand, if not then ill just wait on steam support to do something.


Share this post

Link to post
Share on other sites

Hello! I recently got a non-steam version of ArmA II - Combined Operations. When I launch it, it shows that bohemia intro and the crosshair, then closes and gives me the error "bad serial number given in setup". How do I fix this? I've tried the suggested solution, and I don't even see "Bohemia Interactive Studios" in my registry.

Note: I don't have admin rights on my computer, so I cannot edit the registry.

Edited by S Iyengar
forgot to specify that I had already tried the suggested method.

Share this post

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now