Jump to content
Placebo

Bad serial number given in setup - use this thread for help

Recommended Posts

Yes, my antivirus was active when I reinstalled Arma 2: OA, but the first time I installed it it was active as well and there was no problems whatsoever.

Share this post


Link to post
Share on other sites
same happebed to me, someone told i could get weapons and now bad serial is given to me ;(
The Program what was in the WinRar file is called DayZ script Bypass V2.exe and has two other folder with it Resourses+BEpass and scripts folder And a note with RUN AS ADMIN!!!!!

Edit: After some quick research it seem this bypassv2.exe is a hacking tool to cheat in games. For hacking/cheating your product key will be permanently banned on BattlEye no matter what excuse you come up with. So that error message you guys are getting has something to do with that.

Exactly this. Best case you ran a trojan which stole your CD Key, worst case you ran cheats/hacks online and your CD Keys will be permanently banned from all Battleye protected multiplayer servers, either way we have a zero tolerance policy for anyone hacking/cheating so there will be no further support help provided.

Yes, my antivirus was active when I reinstalled Arma 2: OA, but the first time I installed it it was active as well and there was no problems whatsoever.

Well I would suggest you try the following:

Disable antivirus

Launch steam with Admin permanently ticked

uninstall Arma2 and OA

reboot

Disable antivirus

Launch steam ensuring it's as admin

Install A2, let it auto update, run once, exit, close steam

reboot

disable antivirus

Launch steam ensuring it's as admin

Install OA, let it auto update, run once, exit, close steam

reboot

Now you should be able to launch Combined Operations

If that doesn't work I'd suggest opening a support ticket: https://store.bistudio.com/index.php?option=com_contact&view=contact&id=1&Itemid=50

Share this post


Link to post
Share on other sites

Few days ago I bought Arma 2 and Arma 2 : Operation Arrowhead.

This is how I installed them :

Downloaded and Installed Arma 2 to C:\Program Files (x86)\Bohemia Interactive\ArmA 2

Ran Arma 2 and started a mission, saved the mission and closed Arma 2.

Downloaded and Installed Arma 2 : Operation Arrowhead at the default setup location : C:\Program Files (x86)\Bohemia Interactive\ArmA 2 (Same file I installed Arma 2 in).

Ran Arma 2 : Operation Arrowhead and this is the error I received. http://prntscr.com/detvq .

I've spent literally about 10 hours browsing forums, asking friends etc to try to fix this, obviously nothing worked so I concluded that I should make a thread about this.

This is what I've tried already to fix this.

-Fully Uninstalled and Re-Installed the game ( Both Arma 2 and Arma 2 : Operation Arrowhead )

-Patch Both games and this is the error I got trying to do so : http://prntscr.com/deu2p

-Tried the program Regfixer.exe.

More Information: I do not have this game on steam. I use Six Launcher in order to launch this game and play DayZ.

This game is located in HKEY_CURRENT_USER\Software\Bohemia Interactive Studio\ArmA 2 according to REGEDIT.exe

Any help or Remote assistance would be grateful.

Thanks.

Regards,

Cythose.

Share this post


Link to post
Share on other sites
Hello. I've got some problems because i reinstalled windows. Now,i can't start OA because i get an error saying:"Bad serial number given in setup." I know this is a registry problem because the game can't find the serial in the registry. So the question is,is there any way to fix this without reinstalling the game? I would appreciate the help,thanks. :D P.S:Sorry for my bad english :(

go to the 1st page and check the first link for the Working solution

Edited by Placebo

Share this post


Link to post
Share on other sites

Alright, I'm getting bad serial key when I start it up.

He said this method works... http://forums.bistudio.com/showthread.php?138564

But what do they mean by the steps? I'm so confused on regedit? Hkey?! WTF.

EDIT: Looked up regedit, figured out how to run it.

There was still 1 file in the Arma 2 folder instead of 4.

http://gyazo.com/dcccf7fee86d12bb64eb9a2c608934d6.png

Please help!

Edited by itsJonny

Share this post


Link to post
Share on other sites

Alright, I'm getting bad serial key when I start it up.

He said this method works... http://forums.bistudio.com/showthread.php?138564

There was still 1 file in the Arma 2 folder instead of 4.

http://gyazo.com/dcccf7fee86d12bb64eb9a2c608934d6.png

He said that make sure all of your "allow" boxes are all ticked, but they ALL were already ticked so I couldn't make any changes.

Please help!

EDIT: I bought Arma 2 combined operations on steam.

Edited by itsJonny

Share this post


Link to post
Share on other sites

If you don't have the tech abilities to help yourself by reading advice on the forums (perfectly understandable, not meant as a slight), your best option is to open a support ticket explaining the issue and what you've tried so far: https://store.bistudio.com/index.php?option=com_contact&view=contact&id=1&Itemid=50

Share this post


Link to post
Share on other sites

Well guys the first link in the fix probably should work there is only one issue. The only user on this computer is automatically admin. i go through all the regedit process just to find out that i cant change any of the permissions for my user and everything is already checked anyway. so i figured i would leave you guys a message in case this has happened to anyone else and try to find some help on the issue. i got the game through steam and the cd key is there, i just dont understand the problem. thanks for any help i can get.

Share this post


Link to post
Share on other sites

Hi there i recently purchased ARMA II: Combined Ops from the Steam marketplace. ARMA II downloaded and installed fine but im having problems with operation arrowpoint. When I first installed I was given an error message: bin\config.bin/ctgIngameUI/MPTable.shadow and when the game was about to boot up another error showed up: compilingpixelshader.PSSpecularAlpha:0. However I solved this by running Steam as admin and pasting -mod=C:\Program Files (x86)\Steam\SteamApps\Common\ArmA 2;EXPANSION;ca. This worked and Operation Arrowpoint booted up. However at the Bohemia Interactive screen the game crashed and showed error message: Bad serial number given in setup. I tried verifying the install and no files were missing, but when attempting the fix given in this thread I notice that there was only 1 file where there should be 4. My main computer account is my admin account and already has all permissions set to allow but I still cannot get the 4 files to appear. The only profile shown that does not have full permission is the CREATOR OWNER profile which I cant seem to make change from special permissions. I dont know if this is relevant. Any help would be greatly appreicated.

Share this post


Link to post
Share on other sites
Hi there i recently purchased ARMA II: Combined Ops from the Steam marketplace. ARMA II downloaded and installed fine but im having problems with operation arrowpoint. When I first installed I was given an error message: bin\config.bin/ctgIngameUI/MPTable.shadow and when the game was about to boot up another error showed up: compilingpixelshader.PSSpecularAlpha:0. However I solved this by running Steam as admin and pasting -mod=C:\Program Files (x86)\Steam\SteamApps\Common\ArmA 2;EXPANSION;ca. This worked and Operation Arrowpoint booted up. However at the Bohemia Interactive screen the game crashed and showed error message: Bad serial number given in setup. I tried verifying the install and no files were missing, but when attempting the fix given in this thread I notice that there was only 1 file where there should be 4. My main computer account is my admin account and already has all permissions set to allow but I still cannot get the 4 files to appear. The only profile shown that does not have full permission is the CREATOR OWNER profile which I cant seem to make change from special permissions. I dont know if this is relevant. Any help would be greatly appreicated.

Dont worry about it. I found out that after a reboot everything runs perfectly. Such an idiot not to reboot

Share this post


Link to post
Share on other sites

Thanks for the links!

Had this problem but it's now working :)

Share this post


Link to post
Share on other sites

my pro6lem is weird. same as some of these guys. i tried the 6old letter guide into regedit. my issue comes in that i dont see just 1 that says default. all 4 are already there. and the key is there. 6ut its not a complex key like what i see in the arma 2 file. i ordered the game from gamestop through its gamestop app. not steam. nor can i seem to attach it to steam to verify like people keep suggesting. i tried reinstalling. patching as i was told. and now regedit. i tried the regedit thing n turned on permissions to everything it just doesnt change anything. anytime i run oa as admin i get the error a6out the cd key in setup.

Share this post


Link to post
Share on other sites
my pro6lem is weird. same as some of these guys. i tried the 6old letter guide into regedit. my issue comes in that i dont see just 1 that says default. all 4 are already there. and the key is there. 6ut its not a complex key like what i see in the arma 2 file. i ordered the game from gamestop through its gamestop app. not steam. nor can i seem to attach it to steam to verify like people keep suggesting. i tried reinstalling. patching as i was told. and now regedit. i tried the regedit thing n turned on permissions to everything it just doesnt change anything. anytime i run oa as admin i get the error a6out the cd key in setup.

correction. the code shows now. i did exactly what the regedit thing said. im fully allowed now. yet it still claims i have a 6ad cd key and that i need to contact customer service..

Share this post


Link to post
Share on other sites
correction. the code shows now. i did exactly what the regedit thing said. im fully allowed now. yet it still claims i have a 6ad cd key and that i need to contact customer service..

correction again. i followed through with a new installation with no anti virus on. still claims my cd key is bad. cd key has been disabled. please help me :(

Share this post


Link to post
Share on other sites

Gents, if you installed ArmA 2 or OA in a path other than: c:\program files\ Bohemia interactive\ArmA 2. You will need to edit your regedit. If you have, no worries; I will send you directions to address this. Just pm me.

Semper Fi!

Share this post


Link to post
Share on other sites
I bought ArmA 2 combined ops yesterday. I played ArmA 2 with no complications, but when I try to run Operation Arrowhead, "No entry '.profilePathDefault'." shows up. Then, once the screen goes black and fullscreen, "Bad serial number given in Setup" pops up. I bought this through Sprocket, and have tried most of the suggestions in those threads.

My Specs:

Processor : AMD Turion II Dual-Core Mobile M500 2.2 GHz

Graphics (If you can even call it that) : AMD M880G w/ ATI Mobility Radeon HD 4200

4GB RAM

64 bit Win 7

Any help would be appreciated.

NVM I just downloaded OA weirdly.

did you do exactly what the regedit thing said ?

if yes then go back there and undo everything you did then go to arma ao in regedit and delete the folder it self oa and that works for arma 2 i think

now have fun ;)

Share this post


Link to post
Share on other sites

i have been playing this game for about 4 months and have enjoyed it so much. the main reason i play it is for dayz. Today out of nowhere i got this error while trying to launch the game through dayz commander: wrong CD key.

Now i taught it was a commander problem so i tried launching the game normally to see what would happen and i get to the Bohemia screen and the game crashes and says: bad serial number given on setup. Arma 2 does work properly so i am thinking it has to do with OA.

I have tried the following:

1: deleting and installing both arma2 and arma 2 operation arrowhead

2: i have been in regedit and yes the 4 files that should be there are there. it does not let me edit anything in the Arma 2 OA , i have made sure the permission were right.

4: ran the program as Admin

5:verified all the files were right through steam.

6:ran steam as admin.

7: tried to start game through the directory.

8: i have tried deleting the key from regedit so when i start the game i get a new one.

9: reinstalled battle eye (just in case)

10: i have tried this forums.bistudio.com/showthread.php?138564

i have speant many hours today trying to fix this. so i am hoping this can get fixed.

Share this post


Link to post
Share on other sites

@ deadlyfudger

I moved your post into the sticky thread for this question. Next time please search before posting!

And, read this thread which is filled with info how to fix this.

Share this post


Link to post
Share on other sites
i have been playing this game for about 4 months and have enjoyed it so much. the main reason i play it is for dayz. Today out of nowhere i got this error while trying to launch the game through dayz commander: wrong CD key.

Now i taught it was a commander problem so i tried launching the game normally to see what would happen and i get to the Bohemia screen and the game crashes and says: bad serial number given on setup. Arma 2 does work properly so i am thinking it has to do with OA.

I have tried the following:

1: deleting and installing both arma2 and arma 2 operation arrowhead

2: i have been in regedit and yes the 4 files that should be there are there. it does not let me edit anything in the Arma 2 OA , i have made sure the permission were right.

4: ran the program as Admin

5:verified all the files were right through steam.

6:ran steam as admin.

7: tried to start game through the directory.

8: i have tried deleting the key from regedit so when i start the game i get a new one.

9: reinstalled battle eye (just in case)

10: i have tried this forums.bistudio.com/showthread.php?138564

i have speant many hours today trying to fix this. so i am hoping this can get fixed.

We you uninstalled, did you also delete your Config and @dayz (if it appears) file from \Documents\Arma 2\? Same for any remaining core files (inlcuding @Dayz) in the C:\Program Files\Bohemia Interactive\ArmA 2 - Along with deleting the registry entries?

I ask, as sometimes remaining core files or mod files associated with the game or mod your trying to run, could be the cause!

Did you restart the computer after clean installation?

Share this post


Link to post
Share on other sites

I apologize for posting in the troubleshooting area about this issue, I hope I've found the right place to address this problem as I've spent countless hours of clicking around threads looking to solve my problem.

I have read through the "Bad serial number given at setup" sticky's and have not found a solution. That is why I am asking for further help

I asked about help regarding editing the registry in REGEDIT. I'll provide some more information below,

I Can play ARMA 2: Operation Arrowhead, and the beta patch.

I Can play on the Zargabad Life server and Dominion servers.

I CANNOT play ARMA 2, because I have to Run the game once before proceeding to install DayZ

I CANNOT play Takistan Life: Revolution server, because I get the

'You cannot play/edit this mission, it is dependent on downloadable content that has been deleted.caweapons_ammoboxes" message

I Have a legit/purchased copy of Arma 2: Combined Operations from Steam

I Have version 1.62

I Have ran Steam as administrator, installed games separately through as administrator, reinstalled, and verified integrity of local game cache.

I have not messed with the registry keys, that is why I am asking for further information on this thread,

http://forums.bistudio.com/showthrea...=1#post2204884

I Have Windows 7 and I followed the instructions in the link above, but in the instructions I become confused where he says "user" not "users". Please see screenshot I have attatched, which "Group" or "username" do I pick?

http://i1212.photobucket.com/albums/.../whichuser.png (104 kB)

I will provide further screenshots if you need me to.

I hope my question has more clarity in it now. I'd appreciate the help because this is frustrating!

Share this post


Link to post
Share on other sites

I've been having some serious troubleshooting issues. I originally had the "no entry" bug, but fixed it via a modline (-mod=D:\Steam\SteamApps\Common\ArmA 2;EXPANSION;ca-nosplash). After fixing that although I get to the part on loadup where it says "Bohemia Interactive" then I get the bad serial message.

The method that seems to work for most is this one, but I am having a major problem with it.

1, Run REGEDIT

2, Expand HKEY_LOCAL_MACHINE

3, Expand Software

4, Expand Wow6432Node

5, Expand Bohemia Interactive Studio Not Bohemia Interactive

6, Click ArmA 2 OA, If you only see 1 file named "(Default)" And type REG_SZ then,

7, Right click the ArmA 2 OA file and go to Permissions

8, Left click YOUR USER, NOT! Users

9, After selecting your user click on Advanced

10, Yet Again click on your username for your pc and click on edit

11, In the drop down menu select This Key and Subkeys

12, You will see allow and deny make sure all allow boxes are ticked then click ok

13, you will be taken back one Dialogue box, Click Apply and OK and the same again on the

next dialogue box.

14, Now you should see 4 files sat in your ArmA 2 OA folder, Names, "(Default)" "Data" "Key" & "main"

, Now play your game hassle free

I do the steps in blue I assume properly, but when I complete them the result (as highlighted in red) does not occur. I still only see "1 file named "(Default)" And type REG_SZ."

Anyone else running into this problem? Arma 2 runs fine, this problem only occurs when I attempt to run Operation Arrowhead. And before anyone asks, yes I've tried running it as an administrator.

Share this post


Link to post
Share on other sites

Hey i just bought arma 2 oa and it isnt working it always says that a bad serial number was given in setup but i dont know how to do any of the stuff in the help thread.:confused:

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×