Jump to content
Sign in to follow this  
an1mal_69

Display adapter does not support format D24S8 for X8R8G8B8

Recommended Posts

Hi all..

Shame this is my 1st post, but being a newbie im sure its an easy fix.

I have googled it & found reference to the same prob' on ArmA2, but cant seem to find the hardware acell' slider here. For the record I dont get the error all the time, I have managed to log a couple of hours in-game.

My machine is a new build with a GTX560 Ti card if thats any help?

Many thanks in advance,

Nik..

Share this post


Link to post
Share on other sites

no ideas.??

tried pretty much everything now to no avail

Its not fun when you have ,say an hour or 2 to fit a little gaming in and it takes half that to get it to run!!

Ive updated the drivers, re-installed DX 'umpteen' times (from the TOH directory), ran dxdiag (cannot alter any values in there!), been to 'troubleshoot' the graphics adapter & the properties box is greyed out..cant think of much else to do.??

Share this post


Link to post
Share on other sites

thanks for the reply..

Its 8.17.12.8566 the driver date is showing 20\10\2011

I updated the driver last night with a 01\2012 driver, I'll investigate the numbers.

Just to add, when I first downloaded & ran the software last week (via steam) there was no issue! Its only a recent thing & I've not 'tinkered' with anything?

*edit* the 01\2012 is the date the d'load was modified it seems as its showing 06\01\2012

Edited by an1mal_69

Share this post


Link to post
Share on other sites

I give up, cant get in at all now, after 2hrs of trying..!!

Ive uninstalled..re-installed..installed ASUS drivers, Nvidea drivers, the old drivers from the disc that came with the card.

back to rFactor it is then

Share this post


Link to post
Share on other sites

cheers..I'll give that a go.

Getting really dis-heartened now!! The whole PC is brand new as of 23rd Dec, and I've happily been playing rFactor, Dirt3 & DeusX until I discovered TOH whilst away over new yr.

So, got back Mon' D'loaded TOH via Steam most of Tues', was too busy Weds' to play, got it to run for an hour or so last night & today..no chance. Cant even get my bubbles screensaver to run now, says it needs a newer card or one that's compatible with direct3D.

Share this post


Link to post
Share on other sites
Cant even get my bubbles screensaver to run now, says it needs a newer card or one that's compatible with direct3D.

That alone indicates to me it's a problem with your config and not TOH...

Hope you'll find what's causing this! :(

Cheers,

Sylvain

Share this post


Link to post
Share on other sites
That alone indicates to me it's a problem with your config and not TOH...

Hope you'll find what's causing this! :(

Cheers,

Sylvain

Me too.. Only thing that seems to be out of date is the intel graphics, but the download centre was down. How would I go about re-installing TOH? Would it need d'loading again..if so it'll be the last game I buy via Steam.

Awesome!! That 1st minute or so just about somes up my evening..lol

Share this post


Link to post
Share on other sites
Me too.. Only thing that seems to be out of date is the intel graphics, but the download centre was down. How would I go about re-installing TOH? Would it need d'loading again..if so it'll be the last game I buy via Steam.

So I figured by your words you have an Intel graphics card on board plus an nvidia card in your pci slot? What about disabling the on board gpu in your bios ...

Share this post


Link to post
Share on other sites
So I figured by your words you have an Intel graphics card on board plus an nvidia card in your pci slot? What about disabling the on board gpu in your bios ...

+1 even if it’s the Intel graphics on CPU like with I7-2600k etc, having both active at the same time is perhaps causing some confusion.

Share this post


Link to post
Share on other sites

cheers for the replys..

I've disabled the Intel Graphics & 'faffing' with DX now. Its seems everything is upto date (Jun 2010 redist'), but something has gone t*ts up somewheres, and it seems its all occured after the initial run of TOH :mad:

the only other 'event' was an update to SP1..could that of caused any mischief.?

Share this post


Link to post
Share on other sites

You could try removing your “TakeOnH.cfg†(move to temp/backup folder) or some of the others like username.TakeOnHProfile found at “C:\Users\USER NAME\Documents\Take On Helicopters\†i.e. your “My Documents†folder > Take On Helicopters.

If that fails you can reinstate TakeOnH.cfg/username.TakeOnHProfile from the temp/backup folder.

are other games working ok?

Share this post


Link to post
Share on other sites

minor progress..

If I goto custom and do a clean install of the GPU drivers, everything is smashing..bubbles, games, Nvidea spinning logo etc. If I restart, its back to square 1??

Share this post


Link to post
Share on other sites

Ok that then would definitely signify PC hardware/windows software conflict rather than a game or steam conflict as being the root cause.

Are you logged onto the PC with an account that has full administrator privileges? (hence why changes are being lost on reboot if not)

In the bios is there a setting for something like “initial display first†which may be set now at “auto, default or onbored†which may benefit being set to “PCI-E 0 or PCI-E 1†etc dependent on which your 560ti is in, this would help force the 560ti to be the default starting adapter, rather than the onbored (on motherboard or on CPU graphics) being assigned that privilege each time windows starts/reboots.

There are some forums at www.guru3d.com that may be worth a look at, they have Nvidia/graphics hardware specific forums which may be more helpful than here with a larger pool of people who may have similar hardware (i.e. on-cpu intel graphics + Nvidia PCI-E 560ti)

Share this post


Link to post
Share on other sites

Thanks muchly for your input!!

As predicted it was a simple fix (so far so good *touches his wood*), and seemed only to require a 'thorough' removal of the drivers (using the driver sweeper) & reinstallation.

Hopefully I can get on with mastering the hover & asking other n00b questions like, where's the switch for the PIP monitor, how do I change viewpoints, is there a simpletons keymap..other than scanning through the options...

Share this post


Link to post
Share on other sites

I'm glad the Driver Sweeper recommendation helped you out!

Now make sure you enjoy buzzing through the skies :-)

S.

Share this post


Link to post
Share on other sites

Key by default.

To look around you have many solution.. Using your mouse, a hat.. two hat? (One for rotation the other for translation. A track IR :yay:

You can enable or disable the pip in video option. (You'll win some fps if you turn it off). It switch on automaticaly when you approach from a precise objectif. I don't know how it work :o

Press "Num -" twice to get a better fox while flying.

You can modify these lines in the folder TakeOnProfile here C:\Users\XPS Antoine\Documents\Take On Helicopters

fovTop=0.75;
fovLeft=1.3333334;

Enjoy !

Share this post


Link to post
Share on other sites

Same thing just happened to me. So I just need to install a driver, that's it? So if I install DriverSweeper the software tells me if I need a driver and which one? Cool. Please confirm this.

Share this post


Link to post
Share on other sites

Can you put down your PC configuration, including the GFX type?

In theory, you should be running the latest driver available for your video card.

Make sure you:

1. have your intel on-board gfx card drivers up to date or it might be conflicting with switching from on board to PCI one (you can even turn those off from the bios).

2. make sure you have the latest dx 9 installed. Just google it

3. make sure you have the latest gfx drivers installed. nvidia has an option to clean install, but it is always better to uninstall your gfx drivers completly using drivers sweeper (from safe mode that is)

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×