Jump to content
Sign in to follow this  
sickboy

Six Updater: Install/Update mods, missions. Delta patching. Server browser, and more!

Recommended Posts

Known incompatibility issue with Microsoft WPF based apps like SU and PwS, and other 3rd party software or drivers:

http://getsatisfaction.withsix.com/withsix/topics/graphics_related_utilities_can_cause_graphical_corruption_crash_on_startup_or_performance_issues

(also logged in SU FAQ)

Hmm, that refers to Black Stripes or Black Screen, whereas what's happening here is sections of text in the GUI are being magnified or disappearing but assuming it's the same bug, I'm not sure what I'm running that might cause it. I have Gamebooster but that's shouldn't be doing anything sitting in the tray until I click Boost, when it kills some programs/services. I also have MSI Afterburner/OSD and Radeon Pro in the tray but again they shouldn't be doing anything until a 3D/Game is detected. I'll experiment and see if I can find a cause though. I already have API Monitoring disabled in Radeon Pro for PwS so perhaps doing the same for SU will fix it.

His additions will not be removed, but in SU the user will at least be warned if there are mods active which are not set as allowed nor required mods.

Required mods are always added to the preset, and cannot be removed from the preset.

That's cool, I'll just remove the mods that some people don't want to use then and everyone who does will have to add them manually. Perhaps a "Add all Allowed Mods" feature would be useful though, to add all the Allowed mods with one click. If they're not already installed, a prompt for each one to confirm the user wants to download and install it would be good.

EDIT: Yep, seems disabling API monitoring in Radeon Pro has fixed the problem with SU. You might want to add that to the list of apps that can cause the problem.

Edited by doveman

Share this post


Link to post
Share on other sites

hello guys,

running Six Updater 2.9.7 pre under XP is ending up today in a black window / last action message by Six Updater Launcher is "loading data", then window opens and goes "black" (no content) -> process in task manager is running ("six updater gui.exe" @about 185 kbyte) . Issue is very new, just 2 days back from today no problem at all with starting up and managing mods etc. didn't do any changes, except installing Catalyst 13.1 legacy for my 4870-card and latest regular MS window xp updates.

Framework is at 4.0

any ideas anybody ?

EDIT: uninstall and reinstall newest version didn't help ...

EDIT2: WORKS AGAIN (me, I did nothing new since last "edit", just waited some hour and ... "bingo") ... magical remote hands which have been working meantime are yours, Sickboy :-) ? thx

Edited by langgis08

Share this post


Link to post
Share on other sites
hello guys,

running Six Updater 2.9.7 pre under XP is ending up today in a black window / last action message by Six Updater Launcher is "loading data", then window opens and goes "black" (no content) -> process in task manager is running ("six updater gui.exe" @about 185 kbyte) . Issue is very new, just 2 days back from today no problem at all with starting up and managing mods etc. didn't do any changes, except installing Catalyst 13.1 legacy for my 4870-card and latest regular MS window xp updates.

Framework is at 4.0

any ideas anybody ?

EDIT: uninstall and reinstall newest version didn't help ...

EDIT2: WORKS AGAIN (me, I did nothing new since last "edit", just waited some hour and ... "bingo") ... magical remote hands which have been working meantime are yours, Sickboy :-) ? thx

Hi,

Black stuff and other such corruption usually is:

http://www.six-projects.net/wagn/Six_Updater+FAQ#Graphical%20corruption%20in%20Six%20Updater%20GUI

also see; http://getsatisfaction.withsix.com/withsix/topics/graphics_related_utilities_can_cause_graphical_corruption_crash_on_startup_or_performance_issues

Share this post


Link to post
Share on other sites

Hi Sickboy, please i spend four days trying to solve this problem with my custum repository, may you help me? I dont know what to do anymore :(.

I'm creating my custum repository, i created it on repo manager then i upload all the files to a web server, the problem is that i dont have a htdocs folder because the owner of the webserver is the ADMIN of the clan (I'm doing the repository because he desn't know how to do), so on the "Remote adress" i put the repository link, exemple: http://rinoserver.tk/repository (the folder that i've uploaded those archives) and the host i put the same, the problem is when i push i receive the message: "ERROR 12 ... " sometimes "ERROR 255..." , i tried to put ftp:// and i got a new error.

I dont know what to do anymore, everytime i edit the archives and comit and push i upload it on the webserver, removing the older and putting the new.

When i go to: sixupdater://rinoserver.tk/repository/server.yml (exemple) the server opens in six but when i put to download my own mod (RNUser...) i cant because i get the error: "Failed" and :

I put" ..." but it's not the name of the webserver (obviusly)

" 21:42:43: Fetching latest server info for http://.../repository/config.yml

21:42:45: Executing Install or Update Mods: ['install']

21:42:45: Not allowed mods: expansion/beta, @rnuserx

Cannot confirm server and client version.

21:42:49: Updater (v1.0.0) by Sickboy [Patrick Roza] <sb_at_dev-heaven.net>

21:42:49: Run with --help for help

21:42:49: WARNING: Please make sure anything ARMA related has been closed / shutdown, incl explorer windows, etc

21:42:49: ARMA Path: c:/program files (x86)/steam/steamapps/common/arma 2 operation arrowhead

21:42:49: ARMA exe: c:/program files (x86)/steam/steamapps/common/arma 2 operation arrowhead/expansion/beta/arma2oa.exe

21:42:49: Manager for: C:\Program Files (x86)\Steam\SteamApps\Common\ArmA 2;expansion;expansion\beta;expansion\beta\expansion;servermods\@RNUserX

21:42:49:

21:42:49:

21:42:49: Processing:

21:42:49:

21:42:49: = expansion/beta

21:42:49: Already installed, trying to update...

21:42:49: Mod is tagged 'skip' (probably no updates detected). Skipping...

21:42:49:

21:42:49: = @RNUserX

21:42:49: Already installed, trying to update...

21:42:49: Required Version: 1 - Required GUID: abc8c06e-8673-4823-99a0-e19e41808d69

21:42:49: Selected host: http://.../repository/RNUserV/@RNUserX

21:42:49: Processing .repository.yml

21:42:55: RuntimeError (RuntimeError) zSync error 3 while processing fetch_file: -i ".repository.yml" -o ".repository.yml" "http://.../repository/RNUserV/@RNUserX/.repository.yml.zsync". See log for details.

21:43:19: RuntimeError (RuntimeError) Failed transfer for .repository.yml. See log for details.

If you believe this is a program error, please report the issue to SU Support incl details and logfiles.

21:43:20: RuntimeError (RuntimeError) zSync error 3 while processing fetch_file: -i ".repository.yml" -o ".repository.yml" "http://.../repository/RNUserII/@RNUserX/.repository.yml.zsync". See log for details.

If you believe this is a program error, please report the issue to SU Support incl details and logfiles.

21:43:21: RuntimeError (RuntimeError) Failed transfer for .repository.yml. See log for details.

If you believe this is a program error, please report the issue to SU Support incl details and logfiles.

21:43:21: RuntimeError (RuntimeError) Exhausted all hosts. See log for details.

If you believe this is a program error, please report the issue to SU Support incl details and logfiles.

21:43:21: No updates found (Current version: 0)

21:43:21: RuntimeError (RuntimeError) WARNING: Update was unable to complete. This could be due to a server / connection problem, or due to files in use or out of synch repositories. Please make sure ARMA is closed, retry, otherwise reset and retry. See log for details.

If you believe this is a program error, please report the issue to SU Support incl details and logfiles.

21:43:21:

21:43:21:

21:43:21: There were errors, please review the logfile

21:43:21: Aborted

21:43:22: Not allowed mods: expansion/beta, @rnuserx

Cannot confirm server and client version.

21:57:26: (TEMP) Sync starting

21:57:53: (TEMP) Sync done

21:57:53: Fetching latest server info for http://.../repository/config.yml

21:57:58: Not allowed mods: expansion/beta, @rnuserx

Cannot confirm server and client version.

21:58:34: Fetching latest server info for http://....tk/repository/config.yml

21:58:36: Not allowed mods: expansion/beta, @rnuserx

Cannot confirm server and client version."

Please help me, im very sad, i spend time doing it :(.

Share this post


Link to post
Share on other sites

As said, the used version of zsync (currently latest) is not compatible with IIS. Don't run it on IIS if you intend to host content on the repo.

If things appear working, it is only appearances, once a file already exists on the user's computer but needs updating, the process should fail, or it will fallback to full file transfers, negating the awesome features of zsync/rsync where delta patching is applied to perform realtime differential updates, only transfering the changed bits and bytes.

If the logs do not say anything about zsync incompatibility, fallbacks, and everything appears to be working - for both - new, and updated, files,

I would be extremely surprised, and would love to hear what Windows OS the repo is running, and what (special?) settings were made to IIS (not talking about added mime types :))

Share this post


Link to post
Share on other sites

He tried to add this mime in IIS ( I DONT KNOW IF IT IS THE CORRECT MIME, WHAT SHOULD HE PUTS AND HOW SHOULD HE PROCEED?S :

"text/yaml

text/x-yaml

application/yaml

application/x-yaml"

Like Mime extension: .yaml

Mime type: application/x-yaml

(error) then he tried:

Mime extension: text/yaml

Mime type: application/yaml

(error) then he tried to add some other famous mimes, but the error proceeds.

but here is the error:

" The system can't find the mime (or specified way/path) .. " Do he has to register this mime somewhere on his computer? Please, i know we're close to the victory.

Is this the correct mime? all the mimes that we're trying has this error. .FLV / and others!

Edited by carlos2912

Share this post


Link to post
Share on other sites

Hello quick question. Is there a way to manually select existing mods and install/update them? I am used to doing that in the old 6 updater. In the current UI the only method I can see for getting mods is to select a game and them play it in order to initiate the download. I play single player missions requiring mods as well, and find it easier to download mods manually by selelcting them Thx in advance for your help.

Share this post


Link to post
Share on other sites
Hello quick question. Is there a way to manually select existing mods and install/update them? I am used to doing that in the old 6 updater. In the current UI the only method I can see for getting mods is to select a game and them play it in order to initiate the download. I play single player missions requiring mods as well, and find it easier to download mods manually by selelcting them Thx in advance for your help.
Hi,

You can add the wanted mods to a modset, and then hit Install or Update at the modset directly. If it is already installed and no updates are available, the button is hidden and instead Diagnose is shown.

Btw the PwS thread is over at http://forums.bistudio.com/showthread.php?138444-Play-withSIX-Community-Preview-Evolution-of-SIX-Launcher-and-in-time-also-SU

Share this post


Link to post
Share on other sites

can i still use the sixupdater i got installed? Is ACE up to date in there? Need to update our server. And a new buddy needs ACE too. Is there still a chance to download sixupdater? i have no clue about that play with six , i got the updater and i'm fine with that cheers

Share this post


Link to post
Share on other sites

Installed Win 7 now finally back, remembered why I went back to Xp before.. Because these kinda problems. Trying to run six updater.

GUI error:

IronRuby.Builtins.RuntimeError

Model is not of type Six::Serialization::Models::Mod. @a3a_units (Arma3Mod)

I have no idea what this means, why it conflicts with A3 alpha mod anyway, I tried... I even downloaded the addon but deleted it since it didnt help in any form. Hopefully somebody can help.

Share this post


Link to post
Share on other sites
Installed Win 7 now finally back, remembered why I went back to Xp before.. Because these kinda problems. Trying to run six updater.

GUI error:

IronRuby.Builtins.RuntimeError

Model is not of type Six::Serialization::Models::Mod. @a3a_units (Arma3Mod)

I have no idea what this means, why it conflicts with A3 alpha mod anyway, I tried... I even downloaded the addon but deleted it since it didnt help in any form. Hopefully somebody can help.

Thanks for reporting! It's a more global issue.

I've reproduced the issue and am working on the fix.

Will deploy shortly.

---------- Post added at 19:33 ---------- Previous post was at 19:08 ----------

The fix is deployed and should be available on auto-update, otherwise; http://www.six-updater.net/p/download.html

Share this post


Link to post
Share on other sites

I am still having the issue, I am not as computer savvy as some people. So if there is a solution, can someone refer it to me please.

As for your above post, "The fix is deployed and should be available on auto-update, otherwise; http://www.six-updater.net/p/download.html"

This does not tell me much or help me.

Share this post


Link to post
Share on other sites
I am still having the issue, I am not as computer savvy as some people. So if there is a solution, can someone refer it to me please.

As for your above post, "The fix is deployed and should be available on auto-update, otherwise; http://www.six-updater.net/p/download.html"

This does not tell me much or help me.

Launch PwS and it will auto update itself.

Share this post


Link to post
Share on other sites
Launch PwS and it will auto update itself.

Thanks, but SIX Updater in this case ;-)

Share this post


Link to post
Share on other sites
Launch PwS and it will auto update itself.

I am having the issue with SixUpdater not Play with Six.

Share this post


Link to post
Share on other sites

So is there a solution for...

Model is not of type Six::Serialization::Models::Mod. @a3a_units (Arma3Mod)

I've tried a older version as well and same thing...

Regards,

3Dog

Share this post


Link to post
Share on other sites
Hi Oxmox,

Go to the Mods browser and select a different mod than DayZ. You can also deselect any mod and therefore retrieve all servers, dayz and non dayz.

If you want to use filters to exclude DayZ servers, try using !dayz in the mod filter.

Is that possible with the Six Updater? When i try this in the mod or type column all servers are gone.

Share this post


Link to post
Share on other sites

Basic ARMA 3 support now also added to SIX Updater, and Custom repo support updated for new fields supported by Play withSIX.

Currently we recommend using Play withSIX for clients,

and SU for dedicated servers / custom repo management. Both of these use cases should be supported either in PwS or a separate app later on.

Share this post


Link to post
Share on other sites

Is there any way to override the mod path with the the _runA2CO_beta.bat created by the beta patch? I'm trying to get SweetFX to run with the beta Steam version, but there are problems when running it directly from the Expansions\beta\Arma2OA.exe path. When I go to the game profile and select Path>Exe then choose the .bat file, I don't think it runs from it. Is there any way to do this with Six Updater, because I don't think it would be possible to run the .bat with the startup parameters that Six Updater uses for my mod preset.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×