Jump to content
Balthy

Cannot join friend's server, Not crash, not kick, not mod

Recommended Posts

Greetings,

Asking your help for an issue that we had with some friends for quite a while now.

The issue is simple, when we try to log in any server hosted by any one of us with any mod (none being included in "any"), if the mission is already started, meaning that you can go farther than the lobby, you have something like an 80% chance of disconnecting instantly.

It is not a kick, neither an error, nor a crash, but it shows to the other players :

"user connected

user disconnected"

And that's all, nothing to the one that can't join, he simply goes back.

This apply either while joining from the launcher or with the game already started.

For some reason this error doesn't exist with other servers.

 

We found a way to outsmart this bug, glitch or whatever it is.

We get everyone to connect to the server while the host hasn't chosen a mission yet and this basically gets you to an infinite loading screen. 

There you can't be disconnected, so when the host launches the mission, everyone is in the lobby and you can play (hurrah !).

 

But this doesn't fix everything, if a player was to disconnect for any reason (lost connection, out of power, horny gf)

The only way to get him back in action is to do that all again from the start, which is quite a pain I'll let you know.

 

So that's why I ask you to help us, we've been living this for 6 months now and the fact that we spent all the last afternoon trying to get everyone to play without managing it eventually motivated me to post this here.

 

Share this post


Link to post
Share on other sites
On 06/06/2018 at 1:23 PM, Dedmen said:

Can you get the RPT from both players? The one that hosts the server and the one joining.

https://community.bistudio.com/wiki/Crash_Files#Arma_3

Sorry for the delay

I didn't think of it and I don't really know how to, but I'll try as soon as I can

Share this post


Link to post
Share on other sites
On 06/06/2018 at 1:23 PM, Dedmen said:

Can you get the RPT from both players? The one that hosts the server and the one joining.

https://community.bistudio.com/wiki/Crash_Files#Arma_3

 

Well,

Tried several times with a friend to recreate this issue.

Never managed it, either with or without mods, on scripted or unscripted scenarios.

So we tried to find that file you told me about, my friend is using windows 10 and the link you procured don't say how to get it with this version, and I couldn't find it either, despite using windows 7, because an issue had me lose all my app data file.

So we figured it may not be an issue when there is only 2 players, we'll try again as soon as possible, wit has more people.

Edited by Balthy
Typos and uncomplete informations

Share this post


Link to post
Share on other sites
3 hours ago, Balthy said:

So we tried to find that file you told me about, my friend is using windows 10 and the link you procured don't say how to get it with this version

Exactly the same as windows XP till windows 8.

Windows+R -> %userprofile%\AppData\Local\ -> press "OK" -> open Arma folder.

Or if you want it shorter. Just %localappdata%

Share this post


Link to post
Share on other sites

Ok, found it

Now I just have to wait for a buddy to be online and recreate the issue,

I'll send you the file right after that.

Share this post


Link to post
Share on other sites

disconnected just when the error ocured,

here's a link to download the rpt file : https://we.tl/gi20BYtJwj
it was launched with some mods, here's the list if you ever need to know :

https://we.tl/zYXcT1UNQT

 

these links will expire in something like 48 hours

*mission impossible style ^^'*

 

Edit: 6 days left actually

Share this post


Link to post
Share on other sites
On 23.6.2018 at 9:11 PM, Balthy said:

it was launched with some mods, here's the list if you ever need to know

RPT already contains the mod list.

On 6.6.2018 at 1:23 PM, Dedmen said:

Can you get the RPT from both players? The one that hosts the server and the one joining.

You only sent one RPT.

 

21:05:04 Skipping mods and signatures due to overflow flag being set.

That might be something. But the clientside log isn't really helpful. Which is why I asked for both.

Share this post


Link to post
Share on other sites

I have same problem connecting to a non dedicated server.  A game run on a friends computer.  Connects fine but just stops just before getting in.

 

I think its to do with ports.

 

I presume you have to ope ports in Windows firewall AND router firewall?

Are the required ports 2302-2303 UDP out only?

 

(We can both join the same dedicated server no problem)

 

Cheers

Share this post


Link to post
Share on other sites

Yeah, I did open all those ports in/out windows for both machines but not sure in the router.

 

Will try again tonight

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×