Jump to content
Flax

Flax's Arma Server Tool (F.A.S.T.)

Recommended Posts

Flax , Many thanks for the reply. I wasnt sure  but it definitley uses the comma from the MOD name as I removed the comma myself and then it started working No problem. I have 1 other thought about the new server tool  and possible a feature request. 

Is it possible to copy the Keys from Only the Selected Mods in the server profile rather than copying All the Keys at once.  We have some profiles that are set for Themed nights where we dont want players joining with all the mods selected and running.  

 

Cheers 

Jock 

 

Share this post


Link to post
Share on other sites

Hello Flax. Seems like a great tool. One question however: Is it possible to use this with a server that is hosted remotely? If not, what would take to implement that? We are using Gameservers.

Share this post


Link to post
Share on other sites
12 hours ago, Jockeyboy2_0 said:

Flax , Many thanks for the reply. I wasnt sure  but it definitley uses the comma from the MOD name as I removed the comma myself and then it started working No problem. I have 1 other thought about the new server tool  and possible a feature request. 

Is it possible to copy the Keys from Only the Selected Mods in the server profile rather than copying All the Keys at once.  We have some profiles that are set for Themed nights where we dont want players joining with all the mods selected and running.  

 

I'll look into the keys stuff for v2. 

 

11 hours ago, coolrobot said:

Hello Flax. Seems like a great tool. One question however: Is it possible to use this with a server that is hosted remotely? If not, what would take to implement that? We are using Gameservers.

 

 Unfortunately not, this will only work with dedi servers. 

Share this post


Link to post
Share on other sites

I know there has been a lack of progress recently. I wasn't happy with the first pass at the Server Profile UI, so started from scratch again for that part. Finally happy with it and will now add the functionality behind it then it'll be ready for release!

 

I've also added some stuff that was requested for FAST v1: 

  • Separate server and client mods (to make correct mods show up in launcher)
  • Server Auto Restart (currently supports twice a day a specific times)

 

1f6db653e3f2cfdfdc8c48023ffc141f.gif

  • Like 2

Share this post


Link to post
Share on other sites

I may be missing something so please excuse my ignorance.

How do i get my server mod list to show the workshop mods in this tool?  I have them all under the mods tab but when i set up the server it shows nothing for mod selection?

Share this post


Link to post
Share on other sites
8 hours ago, ohally said:

I may be missing something so please excuse my ignorance.

How do i get my server mod list to show the workshop mods in this tool?  I have them all under the mods tab but when i set up the server it shows nothing for mod selection?

 

Your not missing anything - that was a issue with V1 which is fixed in V2. Which is coming soon™  - I hit a major blocker where all the code was being executed twice. 

Share this post


Link to post
Share on other sites

Awesome, that is for the reply, can't wait. This is a brilliant tool.

Share this post


Link to post
Share on other sites

Is there anything like this for linux?
Currently, i have a arma server hosted with linux and i keep running into a few issues with mods etc.
Really i need something like this for linux. Any suggestions?

Share this post


Link to post
Share on other sites

I'm having a real problem getting my server to launch. Every time i attempt to launch it I get this error:
 

System.ComponentModel.Win32Exception (0x80004005): The system cannot find the file specified
   at System.Diagnostics.Process.StartWithShellExecuteEx(ProcessStartInfo startInfo)
   at System.Diagnostics.Process.Start()
   at FAST.NewServerTab.LaunchServer()
   at FAST.NewServerTab.LaunchServer_Click(Object sender, EventArgs e)
   at System.Windows.Forms.Control.OnClick(EventArgs e)
   at System.Windows.Forms.Button.OnClick(EventArgs e)
   at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.ButtonBase.WndProc(Message& m)
   at System.Windows.Forms.Button.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

Usually I can pick out a key word for what is causing the problem, but this just looks like gibberish to me. Anyone got any ideas?

Share this post


Link to post
Share on other sites
1 hour ago, Profanitizer said:

I'm having a real problem getting my server to launch. Every time i attempt to launch it I get this error:
 

Usually I can pick out a key word for what is causing the problem, but this just looks like gibberish to me. Anyone got any ideas?

 

Check to see if the server file is set correctly in the Server Profile - it can't find the Arma3Server.exe

Share this post


Link to post
Share on other sites
21 hours ago, Flax said:

 

Check to see if the server file is set correctly in the Server Profile - it can't find the Arma3Server.exe

That solved the issue, thanks, but now a new issue has appeared lol!

 

When i try and launch the server, with the mission file named "Antistasi.Altis"(.pbo), the server window shows an error stating "Can't find a mission collection / mission with template name: 'Antistasi.Altis', skipping to next mission."

 

I looked online for solutions, but most said to rename the mission file to have ".Altis" at the end and that didn't work. 

 

Here is what the config file contains: 

...;
class Missions {
	class Mission_1 {
		template = "Antistasi.Altis";
		difficulty = "Recruit";
	};
};

 

Is it something to do with the class name "Mission_1"? Or have I incorrectly placed the mission file? 
"Antistasi.Altis.pbo" was copied over from where the Antistasi mission is kept after downloading on the workshop, and was renamed as it was originally just "mission.pbo".

Share this post


Link to post
Share on other sites

@Profanitizer  Hmm not sure - that seems like more of an issue with the Server than the tool. I'll try to reproduce if I can. Can you share which steam version of Antistasi you are using?

 

 To everyone else on the thread - looking for a couple volunteers to try and break V2 it's pretty much feature ready and I want to try and catch as many validation/ runtime issues as I can before public release. Drop me a PM if you are interested. 

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
1 hour ago, Flax said:

@Profanitizer  Hmm not sure - that seems like more of an issue with the Server than the tool. I'll try to reproduce if I can. Can you share which steam version of Antistasi you are using?

 

 To everyone else on the thread - looking for a couple volunteers to try and break V2 it's pretty much feature ready and I want to try and catch as many validation/ runtime issues as I can before public release. Drop me a PM if you are interested. 

The reason i got that error is something to do with me editing the mission file by trying to change default parameters, but i figured out that server config file can be edited to force mission parameters.
Sadly, it seems that this tool overwrites what you've editied in the server.cfg file no matter what, so i guess I'm going to have to stick with the "leave as is" option on the TADST tool instead.

Maybe in the future you should add a feature to either edit parameters, or stop them from overwriting cfg files?

Share this post


Link to post
Share on other sites
1 hour ago, Profanitizer said:

The reason i got that error is something to do with me editing the mission file by trying to change default parameters, but i figured out that server config file can be edited to force mission parameters.
Sadly, it seems that this tool overwrites what you've editied in the server.cfg file no matter what, so i guess I'm going to have to stick with the "leave as is" option on the TADST tool instead.

Maybe in the future you should add a feature to either edit parameters, or stop them from overwriting cfg files?

 

Ah yeah that would make sense - I will see if there is a way to keep any changes that are manually made. 

Share this post


Link to post
Share on other sites

Hi Flax just a quick question I see that Flax tool version 2 is being worked on I assume the build from github is not possible to use right now untill you release a compiled version is that correct?.

 

Any way looking forward to using this for sure :)

Share this post


Link to post
Share on other sites

@stk2008 Yeah it's being worked on - beta testing builds only atm. I have the release build ready now but am just doing the write up for it all. I'll put a new thread up with the release later this week.

  • Like 1

Share this post


Link to post
Share on other sites

Hi thanks for replying.

 

Apriciate your hard work thank you and realy looking forward to this :)

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×