Jump to content
jakeplissken

Custom Arma 3 game loading graphics. [SOLVED]

Recommended Posts

Hello.

 

I am wondering how to create a custom Arma 3 loading splash screen. I mean the one that shows when the game is first loading. The graphics are in ui_f_data.pbo, but I cannot find the config entry for this. I extracted the files for Alive mod that has a custom screen, but the code was obfuscated. I just want to use a custom screen for my mod to make it stand out, but I came up empty searching of Google, as I could only find results for making custom mission splash screens. Any help would be appreciated. Thanks.

Share this post


Link to post
Share on other sites

Actually, this is my latest config. I solved the dependencies.

 

class RscDisplayStart: RscStandardDisplay
{
    class RscControlsGroup;
    class RscPictureKeepAspect;
    

    class controls
	{
		delete Text;
		delete Progress;
		delete Progress2;
		class LoadingStart: RscControlsGroup
		{
			idc=2310;
			x="0 * safezoneW + safezoneX";
			y="0 * safezoneH + safezoneY";
			w="1 * safezoneW";
			h="1 * safezoneH";
			class controls
			{
				class Black: RscText
				{
					idc=1000;
					x="0 * safezoneW";
					y="0 * safezoneH";
					w="1 * safezoneW";
					h="1 * safezoneH";
					colorBackground[]={0,0,0,1};
				};
				class Noise: RscPicture
				{
					idc=1201;
					text="\A3\Ui_f\data\IGUI\RscTitles\SplashArma3\arma3_splashNoise_ca.paa";
					x="0 * safezoneW";
					y="0 * safezoneH";
					w="1 * safezoneW";
					h="1 * safezoneH";
				};
				class Logo: RscPictureKeepAspect
				{
					idc=1200;
					text="\A3\Ui_f\data\igui\rsctitles\splasharma3\arma3_lite_splash_ca.paa";
					x="0.25 * safezoneW";
					y="0.3125 * safezoneH";
					w="0.5 * safezoneW";
					h="0.25 * safezoneH";
					onLoad="if (isClass (configfile >> 'CfgPatches' >> 'A3_Map_Tanoabuka')) then {(_this select 0) ctrlsettext '\A3\Ui_f\data\igui\rsctitles\splasharma3\arma3_lite_splash_ca.paa';};";
				};
			};
		};
	};
};

This config will load without errors, but it will not change the loading picture, it still says Arma 3 APEX. Am I changing the wrong section? Thanks. Or am I not able to overwrite this section.

Edited by jakeplissken
Posted newer config.

Share this post


Link to post
Share on other sites

I solved it. This config works.

 

class RscStandardDisplay;
class RscControlsGroup;
class RscPicture;
class RscPictureKeepAspect;
class RscDisplayStart: RscStandardDisplay
{
	class controls
	{
		class LoadingStart: RscControlsGroup
		{
			class controls {
				class Logo: RscPictureKeepAspect
				{
					text = "\A3\Ui_f\data\IGUI\RscTitles\SplashArma3\arma3_lite_splash_ca.paa";
					onLoad = "";
				};
			};
		};
	};
};

This was easy after all.

  • Like 1

Share this post


Link to post
Share on other sites

RE, this issue, I just wish I could load custom graphics from the mod folder in a PBO, but this does not seem to work. How do I specify the path of the images? This is really confusing. I cannot make my own graphics and load them into the mod as a custom game logo. Very annoying.

Share this post


Link to post
Share on other sites

Hey @jakeplissken, have you finally get it work ? I'm actually facing the same problem but I've no clue where to begin...

Share this post


Link to post
Share on other sites

Mh that's a pretty good idea, except that I think what we need to find is the addon root folder and not the mission root folder. I don't know if it's really possible, let's see...

Share this post


Link to post
Share on other sites

Actually, this code works, but sometimes it flickers back and forth from vanilla textures to the custom config.

 

class RscStandardDisplay;
class RscControlsGroup;
class RscPicture;
class RscPictureKeepAspect;
class RscDisplayStart: RscStandardDisplay
{
	class controls
	{
		class LoadingStart: RscControlsGroup
		{
			class controls {
				class Logo: RscPictureKeepAspect
				{
                    access = 1;
					text = "va\ui\arma3_beta_splash_va.paa";
					onLoad = "";
				};

                class Noise: RscPicture
                {
                    //access = 1;
                    text = "va\ui\c_eb_overview_ca.paa";
                    onLoad = "";
                };
			};
		};
	};
};

But this is a starting point. Defining va as the root addon folder. I wish there was code in the Arma 3 samples that would help with this. The Star Wars mod has custom splash graphics. I should see how they did it.

Edited by jakeplissken
More clear.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×