Jump to content
Sign in to follow this  
M1ke_SK

say3D - maxDistance broken ?

Recommended Posts

When I use say3D and set maxDistance (15 in example), the value is not relevant. Whatever I set there, I can hear sound far from source. Anybody have the same problem?

 

[_object, [_sound, 15, 1]] remoteExec ["say3D", 0, true];

//_sound defined in Description.ext in CfgSounds class
//15 - 15m from object
//1 - pitch 

 

Share this post


Link to post
Share on other sites

From my understanding of the command, it doesn't cut sound off at exactly x meters, but it starts to fade at that distance. Also note that in the description.ext the parameters are filename, volume, pitch and distance. You may be inadvertently setting the volume to 15 which may render the max distance fairly useless. I use this command in my mission and I haven't encountered any issues with it. 

Share this post


Link to post
Share on other sites
3 hours ago, M1ke_SK said:

When I use say3D and set maxDistance (15 in example), the value is not relevant. Whatever I set there, I can hear sound far from source. Anybody have the same problem?

 


[_object, [_sound, 15, 1]] remoteExec ["say3D", 0, true];

//_sound defined in Description.ext in CfgSounds class
//15 - 15m from object
//1 - pitch 

 

 

show us your CfgSounds config entry

Share this post


Link to post
Share on other sites
class CfgSounds
{
    class mySound
    {
        name = "mySound";
        sound[] = {"mySound.ogg", 1, 1, 15};
        titles[] = {};
        duration = 175;
    };
};

 

Share this post


Link to post
Share on other sites

Looks like it may also be happening with 'Say'

 

My request for information post on the topic

Share this post


Link to post
Share on other sites

Just a week ago I helped out @donnovan correct an issue with his say3d.

His syntax he used was broken and using a different one worked.

 

He used this syntax: _obj say3D ["sound in CfgSounds",volume];  EDITED - _obj say ["sound in CfgSounds",volume];

Which did not work for him

I directed him to use _obj say3d "sound in cfgSounds";

Which did work for him.

 

Now I am seeing more mods have issues with say3d

This tinme its being sent from FSM but is using the tested working syntax....

 

Not sure what's up with mp servers and say3d

 

Any other input on this one @killzone_kid

Share this post


Link to post
Share on other sites

well the copy and paste error was my issue.
Should have read this:
_obj say ["sound_name",1];

Nice community attitude there KK.
Good job on seeing that I resolved his issue already.
And great job on noticing my real issue if you read the entire post.

I never ask much if anything at all in these forums and this is what one gets for making the leap to asking a valid Q.

  • Like 2

Share this post


Link to post
Share on other sites
Guest

speed (pitch) parameter is optional in say, so it should work, if not work, its broken https://community.bistudio.com/wiki/say

 

And this distance parameter never worked as simple as that. You set it to 10 (10 meters?) and you can hear the sound for kilometers.

After Arma 3 1.72 it stoped to work. May be they fixed it and now 1 means 1 meter now. Who knows? I will just know if i fail in my quest to lose virginity, so i will back to Arma.

Share this post


Link to post
Share on other sites
13 hours ago, killzone_kid said:


And why would he do that? The syntax is crystal clear:

from say3D [sound, maxDistance, pitch]

https://community.bistudio.com/wiki/say3D

I don't see any volume there, do you see volume there?

 

C'mon KK, you're an important community member, but this seems a little over the top and puts people (like me) off asking questions in the first place.

Share this post


Link to post
Share on other sites
12 hours ago, DirtySanchez said:

well the copy and paste error was my issue.
Should have read this:
_obj say ["sound_name",1];

Nice community attitude there KK.
Good job on seeing that I resolved his issue already.
And great job on noticing my real issue if you read the entire post.

I never ask much if anything at all in these forums and this is what one gets for making the leap to asking a valid Q.

 

2 hours ago, donnovan said:

speed (pitch) parameter is optional in say, so it should work, if not work, its broken https://community.bistudio.com/wiki/say

 

And this distance parameter never worked as simple as that. You set it to 10 (10 meters?) and you can hear the sound for kilometers.

After Arma 3 1.72 it stoped to work. May be they fixed it and now 1 means 1 meter now. Who knows? I will just know if i fail in my quest to lose virginity, so i will back to Arma.

 

4 minutes ago, anfo said:

 

C'mon KK, you're an important community member, but this seems a little over the top and puts people (like me) off asking questions in the first place.

 

KK gave all the input there is to give.

If you think something is odd with a command just jump in the editor and try to find out what's wrong or what you think is wrong and open a ticket.

 

Just saying

14 hours ago, DirtySanchez said:

Not sure what's up with mp servers and say3d


doesn't really provide any info on what you think is "up" with mp servers and say3d.

 

Not gonna comment on the virginity part but I tested the say command and small distances and it seems that you have to be at least 0.25 * distance to be able to hear the sound, otherwise it will still play, but faded out too much.

The distance parameter indicates the maximum distance the sound will be played at, not the max distance the sound will be audible.

 

Seems there is some issue with the say command improperly fading the sound, you need to set the distance value to at least 200 to make the sound play at maximum volume when standing near the unit.

 

Cheers

 

 

 

 

  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×