Jump to content
Sign in to follow this  
malau

Today's new Steam update to Beta

Recommended Posts

This morning Steam auto downloaded an 8.x mb update to the beta files.

Since then, when I try to connect a Dayz Mod server via DZL, Arma throws up an error message box at the same time as the small box with the ticks on it....

ZeALeOG.jpg

If I continue past it, instead of the lobby (or try to launch with the mods preloaded and click on MULTIPLAYER), I get.....

ttYL8Ma.jpg

I am running on Windows 7 x64.

Share this post


Link to post
Share on other sites

Okay the first one looks like they implemented the corepatch mod as an addon to fix allotta errors but you will need either ACR dlc or ACR lite from now on. second one is one i also get when i disconect from a server haven't found a solution yet

Share this post


Link to post
Share on other sites

I have ACR full. It was already installed. I did a forced reinstall of ACR, and I still get the error message, I can now get into servers, but it's behaviour is REALLY flaky ! On one new server I got insta banned on spawn, on another new server I got Infistar (white screen) ban upon spawning in. Weird.

Share this post


Link to post
Share on other sites

if server is running anything Infistar then I'm not surprised because it can't handle any config deviation

wonder why are admins crazy to run it at all ...

anyway yes, we're looking into the issues with dependency (atm. the known troubles are for A2: OA 1.63 only data and w/o ACR data)

Edited by Dwarden

Share this post


Link to post
Share on other sites

Thanks Dwarden.

I also noticed that I was unable to view how many free/used slots there were in a vehicle. You know, how it usually says 10/50/1 or whatever on the top of the GEAR menu. Now the top of the gear menu is blank.

This was on an Overpoch Origins server, it may well work or not on other Dayz variants ?

Share this post


Link to post
Share on other sites
if server is running anything Infistar then I'm not surprised because it can't handle any config deviation

wonder why are admins crazy to run it at all ...

Because BattlEye wasn't up to the job, it created a market :( first came TSW anti-hack, then Gotcha and the only one that was reliable with regular updates was Infistar by Christian.

If there wasn't a huge demand for protection then 3rd party anti-hacks wouldn't exist, so the admins weren't crazy, they were left with no other option.

Share this post


Link to post
Share on other sites
Because BattlEye wasn't up to the job, it created a market :( first came TSW anti-hack, then Gotcha and the only one that was reliable with regular updates was Infistar by Christian.

If there wasn't a huge demand for protection then 3rd party anti-hacks wouldn't exist, so the admins weren't crazy, they were left with no other option.

like I said, most of those are completely useless and easy to go around but if you think you safe with those then w/e ...

---------- Post added at 14:56 ---------- Previous post was at 14:53 ----------

backup corepatch.pbo + both .bisign files

place this file instead https://www.dropbox.com/s/r7zmon7t96v9qry/CorePatch_ACR_Fix.7z?dl=0

and try again

it should work, not sure if I can get the update live to beta branch (signed) before Tuesday

---------- Post added at 14:57 ---------- Previous post was at 14:56 ----------

Thanks Dwarden.

I also noticed that I was unable to view how many free/used slots there were in a vehicle. You know, how it usually says 10/50/1 or whatever on the top of the GEAR menu. Now the top of the gear menu is blank.

This was on an Overpoch Origins server, it may well work or not on other Dayz variants ?

no idea if it's related, try the hotfix above

Share this post


Link to post
Share on other sites
like I said, most of those are completely useless and easy to go around but if you think you safe with those then w/e ...

I agree, nothing will ever be 100% but the more tools admins have the easier their job is, anything is better than just relying on BE, my point is still valid, BE doesn't stop skiddies, it helps but then so do the 3rd party apps you bash.

It's a cat and mouse game, scripts get released, anti-hack blocks the scripts, exactly the same as an anti-virus, keep the definition list up to date and you get less grief but an active admin team is still essential.

Share this post


Link to post
Share on other sites

Dwarden, unfortunately it did not work for me. I get the exact same error message as before.

Share this post


Link to post
Share on other sites
Dwarden, unfortunately it did not work for me. I get the exact same error message as before.

hard to believe as the dependency was removed completely in new file

or you mean the 2nd error with software exception?

Edited by Dwarden

Share this post


Link to post
Share on other sites

The "Corepatch requires a..........." error message.

I copied it to E:\Steam\SteamApps\common\arma 2 operation arrowhead\Expansion\Addons

It overwrote an existing corepatch.pbo, so i'm hoping this was the correct folder ?

Share this post


Link to post
Share on other sites

hotfix for ACR issue is live, signed too

Share this post


Link to post
Share on other sites

Cool, thanks.

I just signed into Steam, I was expecting it to download an update (?) But no downloads. Does it not work like that in this case ?

Share this post


Link to post
Share on other sites
Cool, thanks.

I just signed into Steam, I was expecting it to download an update (?) But no downloads. Does it not work like that in this case ?

are you signed up for Beta patches?

Share this post


Link to post
Share on other sites

I think so ? My option says "Beta -". The other optiions being "None...", or "1.62..."

Share this post


Link to post
Share on other sites
Friday evening now, still no Steam update.

change in steam settings you mirror you downloading from, the update is part of beta since Tuesday

Share this post


Link to post
Share on other sites

There we go !

Thanks Dwarden. Seems Valve racially profiled my IP and decided my perceived ethnicity was not appropriate to enjoy the Arma2OA update :-)

Switched to a white man's server location and the update downloaded.

Share this post


Link to post
Share on other sites

ye that would explain why some people were claiming that ACR dependency as unfixed, guess they had the old pbo ...

anyway today was another update,keep the feedback rolling in

Share this post


Link to post
Share on other sites

The lack of feedback may be because the new beta with corepatch is working so splendidly, and everyone is busy happily playing A2CO, making missions, and tuning mods! :)

Share this post


Link to post
Share on other sites
The lack of feedback may be because the new beta with corepatch is working so splendidly, and everyone is busy happily playing A2CO, making missions, and tuning mods! :)

well hopefully soon we get some code fixes , especially for the CU RE exploit

Share this post


Link to post
Share on other sites

I tried for the first time to connect to a Dayz server since I got the update. I got exactly the same dependency error as before.

As Dwarden mentioned a new 2nd update, I switched again to Steam's UK London server, but there was no 2nd update - so perhaps the update I got yesterday WAS the 2nd update.

Either way, it still shows the same error anyway.

Share this post


Link to post
Share on other sites
I tried for the first time to connect to a Dayz server since I got the update. I got exactly the same dependency error as before.

As Dwarden mentioned a new 2nd update, I switched again to Steam's UK London server, but there was no 2nd update - so perhaps the update I got yesterday WAS the 2nd update.

Either way, it still shows the same error anyway.

Malau please, can you provide me the corepatch.pbo file that you can find in your Expansion\addons folder? Thank you!!

Share this post


Link to post
Share on other sites
Here is my corepatch from E:\Steam\SteamApps\common\arma 2 operation arrowhead\Expansion\Addons

http://www.mediafire.com/download/wptc9ck45do557h/corepatch.rar

Thank you malau!

I've inspected the .pbo and it seems ok; there is no ACR dependency inside it. I've already uninstalled completely the ACR DLC and started A2:CO with you're corepatch.pbo file without any errors.

Now I have to know which mod you use with A2:OA and if there is, somewhere, inside one of the A2 folders or any other mod folder, another corepatch.pbo file.

Also, try to start A2:CO without DayZ mod and see if the error still there.

Thank you!

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×