Jump to content
beazley

Beazley's No BLUFOR Radio Protocol

Recommended Posts

s760pnq.png

BRIEF

Increases immersion by removing BLUFOR AI radio callouts and subtitles.

DOWNLOAD v1.1

Armaholic

Play withSIX

ArmA3.de

Alternate mirror (MediaFire)

INFO

Make sure everyone on your server is playing on the same level - without AI hints.

Make sure nobody is plagued by the robotic AI voices.

Make sure no screenshots of your unit's operations are ruined by radio subtitles.

Keeps the callouts for OPFOR/GREENFOR - you still hear those enemies shouting, for more 'mersion.

Test mission available here - drop into MPMissions, make sure Radio Subtitles are enabled in game options and try with and without the mod!

REQUIREMENTS

None!

SHOUTOUT

BL1P and serjames for sparking the curiosity

This mod developed for everyone in the 16 Air Assault Brigade

ZpWDlUp.png

WEB: www.16aa.net

TS3: ts3.16aa.net

CHANGELOG

v1.0 - release!

v1.1 - added 'require' module, fixed keys

Yes, I realise there's a menu option for this. This mod will ensure everyone using your modpack gets the same experience.

Please provide feedback below. I will attempt to fix any bugs as soon as possible.

Edited by Beazley

Share this post


Link to post
Share on other sites

Great idea! Will be using for sure. Am I correct in thinking that everyone will need to have this running, not just the host?

Share this post


Link to post
Share on other sites

Cool thanks Beazley will give this a try asap.

Share this post


Link to post
Share on other sites

This is awesome, my friends now can talk and radio freely with out disturbed. thank you so much.

Share this post


Link to post
Share on other sites

Wow - thanks Beazley !!

We were having trouble with the other script due to JIP issues we think.

Will test this out.

Big thanks from me and 3CB !

Share this post


Link to post
Share on other sites
Great idea! Will be using for sure. Am I correct in thinking that everyone will need to have this running, not just the host?

I would assume so - I have no idea what would happen if just the server were to run it. I guess it depends on where along the line the AI 'send' the radio messages. It would be an interesting thing to test, so here I go...

I've just realised that even if one was to include this in their modpack, clients could just delete the .pbo and keep the bisign, and as it won't add itself to the requiredAddons[] array in the mission ArmA would not complain at all. Most people probably won't realise this, but at any rate I'll update this later with a module you can place down in-mission to force the requirement.

---------- Post added at 14:28 ---------- Previous post was at 14:24 ----------

Okay, so I've just finished testing having it server-side only. AI that belong to the server will not broadcast radio commands, but any clients that are not running it still will. Whether they're picked up by other clients that are running it, I'm not sure; I tested it on my lonesome.

Share this post


Link to post
Share on other sites

Sweet addon! However the keys are invalid. It seems the signature file is not accepted by the key provided. Please resign your addon for us server owners who use battleye!

Share this post


Link to post
Share on other sites
I would assume so - I have no idea what would happen if just the server were to run it. I guess it depends on where along the line the AI 'send' the radio messages. It would be an interesting thing to test, so here I go...

I've just realised that even if one was to include this in their modpack, clients could just delete the .pbo and keep the bisign, and as it won't add itself to the requiredAddons[] array in the mission ArmA would not complain at all. Most people probably won't realise this, but at any rate I'll update this later with a module you can place down in-mission to force the requirement.

---------- Post added at 14:28 ---------- Previous post was at 14:24 ----------

Okay, so I've just finished testing having it server-side only. AI that belong to the server will not broadcast radio commands, but any clients that are not running it still will. Whether they're picked up by other clients that are running it, I'm not sure; I tested it on my lonesome.

I usually add the pbo manually to the requiredAddons array of the missions so that people cant bypass something we want ran on the server/mission.

Share this post


Link to post
Share on other sites
Sweet addon! However the keys are invalid. It seems the signature file is not accepted by the key provided. Please resign your addon for us server owners who use battleye!

That is really quite strange. Expect version 1.1 in a few hours - with a 'require' module and a fixed key. I'll even test the key first this time ;)

(Also, as above - feel free to re-sign it yourself if needs be and you're able.)

I usually add the pbo manually to the requiredAddons array of the missions so that people cant bypass something we want ran on the server/mission.

I think the requiredAddons array is re-generated every time you 'export' a mission using the editor (though it may only be additive, rather than a complete regeneration). If you pack it up yourself it's probably fine, but it's something to watch out for.

Share this post


Link to post
Share on other sites

New mod v1.2 available at withSIX. Download now by clicking:

@bzly_no_bluf_radio.png

@ Beazley ;

Soon you will be able to manage the promo pages of your content on our web platform and publish new content yourself.

To do so, please hit 'this is me' button on the page while logged in and you will get connected to your work.

For now you can send new content or releases our way through withsix.wetransfer.com or add your notification at getsatisfaction.withsix.com.

Edited by Sonsalt6

Share this post


Link to post
Share on other sites

Release frontpaged on the Armaholic homepage.

================================================

We have also "connected" these pages to your account on Armaholic.

This means in the future you will be able to maintain these pages yourself if you wish to do so. Once this new feature is ready we will contact you about it and explain how things work and what options you have.

When you have any questions already feel free to PM or email me!

Edited by Foxhound
versioning

Share this post


Link to post
Share on other sites

So, it this mod client or server side? Do I need to run it on the server or should running it on client's do the trick?

Share this post


Link to post
Share on other sites

@Foxhound & Sonsalt6 - sorry, I buggered up the version number. This latest version, in my post below, is v1.1.

So, it this mod client or server side? Do I need to run it on the server or should running it on client's do the trick?

Both. If it's server side only it will stop the AI that are running on the server from calling things out, but not other clients who are not running it.

Version 1.1 released

- Added a module to force requirement in a mission (Editor > Modules > Misc > Require 'No BLUF Radio').

- Fixed keys

http://www.mediafire.com/download/1gyht02uz9d1wv0/@bzly_no_bluf_radio.zip

Link in OP updated.

Share this post


Link to post
Share on other sites

Thanks for informing us of the update :cool:

Release frontpaged on the Armaholic homepage.

================================================

We have also "connected" these pages to your account on Armaholic.

This means in the future you will be able to maintain these pages yourself if you wish to do so. Once this new feature is ready we will contact you about it and explain how things work and what options you have.

When you have any questions already feel free to PM or email me!

Share this post


Link to post
Share on other sites

Hi Beazley,

We'd like to try this on our bikey'd dedicated server.

However, whenever a client tries to join, they get as far as the role selection screen and then receive a ban message.

From our server.cfg:

verifySignatures=2;
onHackedData = "ban (_this select 0)";

So the bisign/bikey is working, in so far as it allows the client to join the session, but then it detects something wrong with the mod files ("modification of signed pbo detected").

Apollo

3 Commando Brigade

Share this post


Link to post
Share on other sites

Apollo, is it possible the PW6 key wasn't applied ? Beazley did you sign them yourself ?

SJ

Share this post


Link to post
Share on other sites
Hi Beazley,

We'd like to try this on our bikey'd dedicated server.

However, whenever a client tries to join, they get as far as the role selection screen and then receive a ban message.

From our server.cfg:

verifySignatures=2;
onHackedData = "ban (_this select 0)";

So the bisign/bikey is working, in so far as it allows the client to join the session, but then it detects something wrong with the mod files ("modification of signed pbo detected").

Apollo

3 Commando Brigade

Apollo, is it possible the PW6 key wasn't applied ? Beazley did you sign them yourself ?

SJ

Yes, I did. I don't know why I'm having so much bloody trouble with the keys I generate for publicly releasing stuff, yet I sign everything for the 16AA's modpack all the time and have absolutely no issues. :(

You're welcome to re-sign them yourself, of course - and I'll do some testing to try and work out what the bloody hell is happening. Does my key for UIcorrections work for you? It was signed in exactly the same way, directly after this one.

Share this post


Link to post
Share on other sites
Apollo, is it possible the PW6 key wasn't applied ? Beazley did you sign them yourself ?

The key was in the key folder or I wouldn't have been able to join the server.

It's Beazley's key judging by the name bzly_bluf_radio.bikey.

---------- Post added at 18:11 ---------- Previous post was at 18:09 ----------

Am I imagining it or did I just see v1.2 on Play with Six?

Downloaded it, but now it says v1.1 again!

Edited by UK_Apollo

Share this post


Link to post
Share on other sites

The version number was a mistake made by me. I used my release template from UIcorrections and forgot to change the version number on the 'DOWNLOAD' section from 1.2 to 1.0 - so the initial release was incorrectly listed as 1.2 on AH and PWS. 1.1 is the latest.

Any ideas why it's detecting my signatures as being 'hacked'?

---------- Post added at 18:27 ---------- Previous post was at 18:16 ----------

Just tried this on our servers, and no issues. Relevant server.cfg entries:

// [sIGNATURE VERIFICATION]
onUnsignedData = "kick (_this select 0)";
onHackedData = "kick (_this select 0)";
verifySignatures=2;

I can't reproduce :(

Share this post


Link to post
Share on other sites

Cheers. I may pop on your TS at some point if we can't figure it out soon. 3CDO, right?

Share this post


Link to post
Share on other sites

You're the guys I meant anyway. I don't know nuthin' 'bout no new group.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×