Jump to content
major_shepard

ArmA3Sync - launcher and addons synchronization software for ArmA 3

Recommended Posts

Summary: When connecting to ArmA3Sync repo error message: "Repository: [repository name here] - Error: Connection failed. Trying to reconnect in 5 seconds"

Description: When attempting to connect to the repo through Arma 3 Sync, I am able to connect via the autoconfig, sync and see what mods I'm missing, however when it comes time to download/replace/delete files I loose connection with an error message (attached.) In the past, reinstalling Arma 3 Sync has worked, or I've been able to connect to the FTP directly however this time I'm not able to resolve the problem with any attempted troubleshooting (listed below.)

Troubleshooting attempted: Restarted PC, cleared and re-set repo connection, deleted & reinstalled Arma 3 sync, deleted and installed the newest version, ran as admin, shut off windows defender, no anti-virus running.



 

Share this post


Link to post
Share on other sites

Whenever I've patch files from remote a3s repo in Online tab game server connected with this repo appears.

And every time I have to delete it (because I have one but with different name).

Is it a feature or a bug?

If it is a feature maybe it would be good to check if such position exists comparing it with IP, port and pass currently existing ones.

Share this post


Link to post
Share on other sites

Hello I can contact you because I have a problem and it is 6 hours that I can not solve it ...

When I try to create a repository ca me ca, impossible to solve the problem
I have hundreds of players waiting behind me :(

mini_168425buga3s.png

Share this post


Link to post
Share on other sites
6 minutes ago, focheur said:

Hello I can contact you because I have a problem and it is 6 hours that I can not solve it ...

When I try to create a repository ca me ca, impossible to solve the problem
I have hundreds of players waiting behind me :(

mini_168425buga3s.png

 

Presumably wrong repository url setup in arma3sync.

Also paste the repository url on web browser from a local machine (=your PC) and check if you can browse and download files from there.

Share this post


Link to post
Share on other sites
On 29/05/2017 at 5:32 PM, kromka said:

Whenever I've patch files from remote a3s repo in Online tab game server connected with this repo appears.

And every time I have to delete it (because I have one but with different name).

Is it a feature or a bug?

If it is a feature maybe it would be good to check if such position exists comparing it with IP, port and pass currently existing ones.

 

It's defined server side by the arma3sync repository administrator.

Share this post


Link to post
Share on other sites
2 minutes ago, major_shepard said:

 

Presumably wrong repository url setup in arma3sync.

Also paste the repository url on web browser from a local machine (=your PC) and check if you can browse and download files from there.

From my pc I can access the server from filezila
On the other hand the url of the repository always tells me the same error, at home and on the server

Share this post


Link to post
Share on other sites

I think there is a wrong setup in FileZilla server. Use your web browser to find and fix it. ArmA3Sync is out of scope.

Share this post


Link to post
Share on other sites
7 minutes ago, major_shepard said:

I think there is a wrong setup in FileZilla server. Use your web browser to find and fix it. ArmA3Sync is out of scope.

What do you mean? I do not understand ^^

Share this post


Link to post
Share on other sites

So I have been having an issue on my dedicated box that the GUI is appearing incredibly small, any fixes that anybody could have would be greatly appreciated

 

Share this post


Link to post
Share on other sites
4 hours ago, shadow69th said:

deleted my mods and remaking the repo and this happen.

 

d71e8d9454f64aa3bfeecbe3f83652bc.png

53a44c2cbec744d69bfc22f717d3ec6e.png

 

 

Paste repository url on a web browser and see what happens.

Share this post


Link to post
Share on other sites
4 hours ago, major_shepard said:

 

Paste repository url on a web browser and see what happens.

2229e86e96e248d3b54b4e4ee3736b0c.png

Share this post


Link to post
Share on other sites

Was it the MIME configuration on II7 server as suggested returning 404 error with no extension files?

Share this post


Link to post
Share on other sites

Gday Shepard, 

I have a question about -filePatching within A3S on a server. There is the tickbox option which I have used but it does not seem to work, at least not on my end anyways. I have also tried within the additional parameters window adding -filePatching and as far as I can detect that doesn't work either. The server.cfg has "allowedFilePatching = 1;" so I am unsure as to why it is not working. I have been testing with the mod VCOM, but if I run A3S with no mods, is there a debug mode I can run in that I can see if it is working or not?

 

Also I'm sorry if someone has asked this question in the past but I was unsure if it is a new issue or not.

 

Cheers

 

 

Share this post


Link to post
Share on other sites
4 hours ago, LJFox said:

Gday Shepard, 

I have a question about -filePatching within A3S on a server. There is the tickbox option which I have used but it does not seem to work, at least not on my end anyways. I have also tried within the additional parameters window adding -filePatching and as far as I can detect that doesn't work either. The server.cfg has "allowedFilePatching = 1;" so I am unsure as to why it is not working. I have been testing with the mod VCOM, but if I run A3S with no mods, is there a debug mode I can run in that I can see if it is working or not?

 

Also I'm sorry if someone has asked this question in the past but I was unsure if it is a new issue or not.

 

Cheers

 

 

 

Create a shortcut on arma3.exe with -filePatching as argument and see what happens.

Share this post


Link to post
Share on other sites
50 minutes ago, major_shepard said:

 

Create a shortcut on arma3.exe with -filePatching as argument and see what happens.

 

I did this with arma3server.exe and it worked fine as far as I could see, just can't use A3S which is weird

Share this post


Link to post
Share on other sites

running arma3server.exe with -filePatching server side is useless as the server use the config file with "allowedFilePatching = 1"

You must run client side arma3.exe with argument -filePatching

Share this post


Link to post
Share on other sites

Im having a hell of a time getting arma3sync to work on my dedicated linux server. Im not sure if it would be a FTP (which I think it would be), HTTP or HTTPS, When I access it through filezilla its a sftp/username@the servers ip. Then wehn it asks for user login is that for the server itself or what would be used for the repo? Same question for the password. For the repository url would it be a general username@the servers ip or would it be the specific directory to the mods? Then for the main folder location would it be /home/desktop/Desktop/SteamCMD/steamcmd_linux/Arma3/mods? ()thats the directory Im using)

Share this post


Link to post
Share on other sites

Hi guys,

 

I've been running a repository for my team since 2014 and was quite happy with it. It has worked flawlessly since then.

However, since my buddies updated to 1.6, the repo doesn't work for them anymore:

 

Generated by ArmA3Sync 1.6.92
12 juin 2017 20:28:57

Check for Addons finished with errors for repository name: 09th WTAC Griffons
An unexpected error has occured.
StackTrace:
java.lang.IndexOutOfBoundsException: Index: 0, Size: 0
	at java.util.ArrayList.rangeCheck(Unknown Source)
	at java.util.ArrayList.get(Unknown Source)
	at fr.soe.a3s.service.connection.FtpService.determineFilesCompletion(FtpService.java:246)
	at fr.soe.a3s.service.synchronization.FilesCompletionProcessor.run(FilesCompletionProcessor.java:75)
	at fr.soe.a3s.ui.repository.workers.AddonsChecker.run(AddonsChecker.java:110)

 

Players running A3S 1.58 are still able to use the repo, though.

 

Any ideas? For now my official recommendation is to stick to 1.58...

 

Thank you!

Share this post


Link to post
Share on other sites

So I have Apache and PHP installed and working on my dedicated linux server and I was wondering how do you create a shared directory?

Share this post


Link to post
Share on other sites

Everything in the www folder will be shared. Before doing anything with ArmA3Sync, ensure you can browser and download files from from the Apache server with a web browser.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×