Jump to content
Sign in to follow this  
Kydoimos

Disabling Radio Chatter

Recommended Posts

Is there a way to disable radio chatter? A script, perhaps? I don't want grid references being called out at the beginning of the mission!

Share this post


Link to post
Share on other sites

And I don't mean by turning it off radio chat under options :)

Share this post


Link to post
Share on other sites

Fantastic, thanks! I always check first but - don't know how I missed that! :p

---------- Post added at 18:11 ---------- Previous post was at 18:05 ----------

And it works just fine, thanks again,

Share this post


Link to post
Share on other sites

What if I want to disable only the voice chatter of the AI but still want the text at the left corner for alerts as I play SP only?

 

Also, Its funny that the radio option under the audio options serves no purpose for AI. I have turned radio volume to 0 and still the stupid AI keeps barking like mad. Anyway to turn down their voices if I need them in a particular mission?

 

Thank you.

Share this post


Link to post
Share on other sites
this setSpeaker "NoVoice";

This might help.

 

But I've made the experience on DevBranch lately that whatever you do, enableRadio, enableSentences, remove radios from units, set speaker to "NoVoice", they keep shouting annoying things. Might just be a DevBranch problem at the moment.

Share this post


Link to post
Share on other sites
this setSpeaker "NoVoice";

This might help.

 

But I've made the experience on DevBranch lately that whatever you do, enableRadio, enableSentences, remove radios from units, set speaker to "NoVoice", they keep shouting annoying things. Might just be a DevBranch problem at the moment.

 

Danke. You are the man :D

 

I dont run on devbuild so I believe I should be ok !! :D

 

Thank you again.

Share this post


Link to post
Share on other sites

The command fadeRadio will stop all sounds sent via the conversation system.

0 fadeRadio 0;

This will still display the AI chatter on the screen. To disable this dialog, you can use showChat

showChat false;

Hope this helps,

 

Bull

Share this post


Link to post
Share on other sites

The command fadeRadio will stop all sounds sent via the conversation system.

0 fadeRadio 0;

This will still display the AI chatter on the screen. To disable this dialog, you can use showChat

showChat false;

Hope this helps,

 

Bull

Thanks Bull :D

Share this post


Link to post
Share on other sites

Sorry, returning the post:

How to tyrn off some radio channel?

Something of that worked once, but i retryed it all and it doesn't working:

description.ext

disableChannels[]={{0,true,true},{1,true,true},{2,true,true},{3,true,false}};
disableChannels[]={0,1,2,3};
class RadioChannels{
	class DirectSpeakingChannel{
		level = 0;
		micOuts = "micOuts";
		noise = "loop";
		pauseAfterNumber = 0;
		pauseAfterUnitList = 0.05;
		pauseAfterWord = 0;
		pauseInNumber = 0;
		pauseInUnitList = 0;
	};
	delete GlobalChannel;
	delete SideChannel;
	delete CommandChannel;
	delete GroupChannel;
	delete VehicleChannel;
};

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×