Jump to content

Recommended Posts

I'm looking, but there wasn't a dll in that mysqlplugin folder. Still looking

---------- Post added at 06:52 ---------- Previous post was at 06:36 ----------

08/14/2012 06:41:23 Error Caught exception of type System.IO.FileNotFoundException while loading addin Arma2NETMySQLPlugin

System.IO.FileNotFoundException: Could not load file or assembly 'Arma2NETMySQLPlugin, Version=0.1.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The system cannot find the file specified.

File name: 'Arma2NETMySQLPlugin, Version=0.1.0.0, Culture=neutral, PublicKeyToken=null'

at System.Reflection.RuntimeAssembly._nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, RuntimeAssembly locationHint, StackCrawlMark& stackMark, Boolean throwOnFileNotFound, Boolean forIntrospection, Boolean suppressSecurityChecks)

at System.Reflection.RuntimeAssembly.nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, RuntimeAssembly locationHint, StackCrawlMark& stackMark, Boolean throwOnFileNotFound, Boolean forIntrospection, Boolean suppressSecurityChecks)

at System.Reflection.RuntimeAssembly.InternalLoadAssemblyName(AssemblyName assemblyRef, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection, Boolean suppressSecurityChecks)

at System.Reflection.RuntimeAssembly.InternalLoad(String assemblyString, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection)

at System.Reflection.Assembly.Load(String assemblyString)

at System.UnitySerializationHolder.GetRealObject(StreamingContext context)

at System.AppDomain.DoCallBack(CrossAppDomainDelegate callBackDelegate)

at Arma2Net.Managed.AddInManager.LoadAddIn(String assemblyFile)

Sir, I appreciate your extreme understanding with me. I swear I'm not this stupid in other things.

---------- Post added at 07:05 ---------- Previous post was at 06:52 ----------

Sir, It works and I'm marking it up to your outstanding help and magic. I'm done for the night

Share this post


Link to post
Share on other sites

No dice, still crashes. File not found exception or so as before.

_result = call compile ("Arma2Net.Unmanaged" callExtension "MyPlugin [Hello]");
hint _result;

Works in the explorer fine though.

* UPDATE

MySQL plugin doesn't even function in explorer. Says couldn't find file i/o exception. It behaves the same as MyPlugin in-game, crashing it.

Edited by sparcdr

Share this post


Link to post
Share on other sites

sparcdr, are the DLL files blocked at all? You can check if you right click the DLL files and click Properties.

Share this post


Link to post
Share on other sites

I don't use UAC, so that option isn't there, so no it isn't blocked.

I completed my C# program using jayarma2lib, and it works, but I loathe the timing issues. Still would like to port it to a plugin for arma2net. Actually did it already, it's not much different, except removing the entry point, just have to do it again whenever a plugin won't crash ARMA2.

I'd like to know if arma2net works with ARMA 2 Free, since an eventual side-task may be porting back to it. (We use Chernarus) I hope you intend to support ARMA 3 (Granted loadext support) so you got my support, even though it hasn't yet worked for me, even the included plugins.

Give me infos about what version you develop for, and I'll try that too.

Edited by sparcdr

Share this post


Link to post
Share on other sites

Since you get a file not found (?) exception you might be able to find some details in the Fusion Log Viewer, detailed in http://msdn.microsoft.com/en-us/library/e74a18c4%28v=vs.100%29.aspx

Arma2NET should work in all games using the ARMA engine, provided the callExtension command is present. Thus you don't need a specific version of the game, just one with callExtension.

I've got a Mono version of Arma2Net.Unmanaged.dll working which we can try if all else fails.

Share this post


Link to post
Share on other sites

callExtension is only present in OA 1.62+ (and probably in the latest TKOH beta patch).

Share this post


Link to post
Share on other sites

Arma2NET has been updated to version 2.2 with the following changes:

- Arma2NET will now gracefully handle appdomain errors, adding partial support for .NET 4.5 and Windows 8 as a result.

- Added support for the Mono runtime as an alternative to .NET entirely.

- Improved logging functionality.

Download:

ZIP archive: https://bitbucket.org/Scott_NZ/arma2net/downloads/Arma2NET-2.2.zip

MSI installer: https://bitbucket.org/Scott_NZ/arma2net/downloads/Arma2NET-2.2.msi

If you would like to use the Mono runtime instead of the .NET runtime (this should work fine on Windows 8, if not let me know):

Download and install Mono 2.11.3 from http://www.go-mono.com/mono-downloads/download.html (make sure you use 2.11.3, there is a bug in the stable version which will prevent Arma2NET from functioning correctly)

Rename Arma2Net.Unmanaged.Mono.dll to Arma2Net.Unmanaged.dll and back up the old Arma2Net.Unmanaged.dll in case you want to revert.

Append the path to Mono's bin folder to your %PATH% environment variable.

Edit MonoPaths.txt to point to Mono's lib and etc folders.

Arma2NET should function almost exactly the same on Mono as it does on .NET.

Share this post


Link to post
Share on other sites

Is there any additional information on the Whitelist plugin? There isn't much in the wiki. Basically, how do I even use it?

Share this post


Link to post
Share on other sites

I removed whitelisting and the need for whitelisting a few patches ago because people were just disabling the associated features anyway.

Share this post


Link to post
Share on other sites

Hi all,

I am trying to setup Persistant DB for one of my mission/server. I'm really really new to MySQL and Arma2NET.

I am getting this in the log:

Info: 16:03:26 - Arma2NETMySQL Plugin Started.
Info: 16:03:26 - Version number: 0.1.0.0
Info: 16:03:26 - Loading databases...
Info: 16:03:26 - Database: arma IPAddress: 127.0.0.1 Port: 3306 Username: arma Password: NotShownForSecurityReasons
Info: 16:03:27 - Unable to open connection to database, trying again in 10 seconds.MySql.Data.MySqlClient.MySqlException (0x80004005): Unknown database 'arma'
  at MySql.Data.MySqlClient.MySqlStream.ReadPacket()
  at MySql.Data.MySqlClient.NativeDriver.AuthenticateNew(Boolean reset)
  at MySql.Data.MySqlClient.NativeDriver.Authenticate(Boolean reset)
  at MySql.Data.MySqlClient.NativeDriver.Open()
  at MySql.Data.MySqlClient.Driver.Open()
  at MySql.Data.MySqlClient.Driver.Create(MySqlConnectionStringBuilder settings)
  at MySql.Data.MySqlClient.MySqlPool.GetPooledConnection()
  at MySql.Data.MySqlClient.MySqlPool.TryToGetDriver()
  at MySql.Data.MySqlClient.MySqlPool.GetConnection()
  at MySql.Data.MySqlClient.MySqlConnection.Open()
  at Arma2NETMySQLPlugin.MySQL.OpenConnection(String connectionString)
Info: 16:03:37 - Unable to open connection to database, trying again in 10 seconds.MySql.Data.MySqlClient.MySqlException (0x80004005): Unknown database 'arma'
  at MySql.Data.MySqlClient.MySqlStream.ReadPacket()
  at MySql.Data.MySqlClient.NativeDriver.AuthenticateNew(Boolean reset)
  at MySql.Data.MySqlClient.NativeDriver.Authenticate(Boolean reset)
  at MySql.Data.MySqlClient.NativeDriver.Open()
  at MySql.Data.MySqlClient.Driver.Open()
  at MySql.Data.MySqlClient.Driver.Create(MySqlConnectionStringBuilder settings)
  at MySql.Data.MySqlClient.MySqlPool.GetPooledConnection()
  at MySql.Data.MySqlClient.MySqlPool.TryToGetDriver()
  at MySql.Data.MySqlClient.MySqlPool.GetConnection()
  at MySql.Data.MySqlClient.MySqlConnection.Open()

It seems it is having troubles getting into the database. Can anyone give me some advice on changing any settings in MySQL to allow proper connection please.

I have done all steps on this. I read a lot of threads to the point my head is about to explode.

Please forgive me if this is in the wrong thread. I will gladly delete and repost elsewhere.

Thank you for your time!!

Share this post


Link to post
Share on other sites

I think I have. I clicked "Create EER Model from SQL script" and used the "MSO(dat).sql" and saved the model as "arma".

Share this post


Link to post
Share on other sites

Any suggestions for an alternative or maybe it's something you can add back? Perhaps as an optional plugin? I am more script kiddie then programmer: I've built things from scratch but nothing even slightly complex.

Share this post


Link to post
Share on other sites

Not whitelist/blacklist plugins: I want to whitelist players. Instead of having a password (that is freely shared), I want to be able to whitelist who can get into my server, and auto-kick people who are not whitelisted.

Share this post


Link to post
Share on other sites

Hi :)

i want to test for purpose only arma2net. Im a c# newbie, what can of ide should i use ? Do you know a free, easy, efficient solution ?

I just took visual studio 2012 evaluation but i m not sure i can use it with arma2net.

Share this post


Link to post
Share on other sites

I m going to try it. I also install monodevelop it seems to be nice too.

My goal is to find the simpliest way to only write from arma sqf to serial port ?

arma -> arma2net -> my dll -> my device

Is it the simpliest way ?

Share this post


Link to post
Share on other sites
Should be simple enough. You can use the SerialPort class: http://msdn.microsoft.com/en-us/library/system.io.ports.serialport%28v=vs.100%29.aspx

i will test it tonight thanks :) i think normal i could use the class in mono environment, if it doesn't work, i will test with visual studio.

Edited by code34

Share this post


Link to post
Share on other sites

Thks Scott for you help. I did my job, and arma2net works like a charm.

I did a video about my test, you can see it at this place:

Edited by code34

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×