Jump to content
Sign in to follow this  
sirex

custom images

Recommended Posts

am i dreaming, or is it possible to make a little logo appear on the side of jeeps and things when you get in ? - i've seen some clans use this for their clan image but i dont know if its part of the mission, or something they did.

anyone know what thats all about ?

Share this post


Link to post
Share on other sites

IR%20logo.jpg

Talking about this ? wink_o.gif

You need a squad.xml on your server with all your data saved in that file. After you put your xml URL into "your player ID page" in the game the logo will show up on vehicles in the game.

Share this post


Link to post
Share on other sites

VERY COOL!! Is there detailed info on how to accomplish this?

Thanks...

Share this post


Link to post
Share on other sites

Hmm well i can send you the xml of my clan, so you can customize it.

It is simple... you create a xml file and save the Player ID, in game name etc. in that file.

Then you copy the URL of that xml file on the server into your game and when your player ID and ingame name are correct it will show up.

Send me your email address via PM and I will forward you our xml mate.

Share this post


Link to post
Share on other sites

so basically you cant do this on someone else's server ?

poop :-(

suma, plz plz plz ?!

edit: ^^ + cherry.

Share this post


Link to post
Share on other sites
so basically you cant do this on someone else's server ?

poop :-(

suma, plz plz plz ?!

edit: ^^ + cherry.

You can of course host the file on your personal webspace or find someone that would host your file. This I could do aswell, PM me smile_o.gif

Share this post


Link to post
Share on other sites

aha, server being webspace, not server being arma game server.

can you link to your xml file or summin so i can take a peek ? -- sounds wicked smile_o.gif

edit: msg'ed you my address, just i thought others might want to know for future reference.

Share this post


Link to post
Share on other sites

well, i've spent ages trying to get this damn thing working !

my id is 7 digits, is that ok ? - one of my clan mates says his is too. I've done the xml file, uploaded it with the image and all but nothing.

is there some sort of server setting needed to make this work ?

Share this post


Link to post
Share on other sites

yeah if anyone else gets thsi working can you maybe pm me and ill give you my msn or something, im fairly sure the xml file is fine, but every server i tried didnt oad any of the info, not just the logo.

Share this post


Link to post
Share on other sites

been on a server where other people had it working and i cant even get it working there. wtf ?!!

its on the root of my website, and ive put that site into the squad url box. -- ive edited the xml (with no reserved letters) and uploaded it and the other files needed.

can *anyone* that has this working show me their xml page ? - remove the id's if you want, whatever.

Share this post


Link to post
Share on other sites

Ok.. I have it working.. But it will only show on a few vehicles like the 5t truck.. It will not show on the hummer or striker.. The image is 256x256... I also noticed if I reduced the image size to say 128x128. 1 of 2 things happens to different people... 1 it wont show on any vehicle or 2 it is the same size as the previous image.. This is after all players restart ARMA...

Share this post


Link to post
Share on other sites
can *anyone* that has this working show me their xml page ? - remove the id's if you want, whatever.

Next time your playing and see one working just write down the URL you see in the player info screen. Alt-Tab out and load up the webpage. When the page loads right click on any empty spot and choose "view source". Id be willing to take a look at your xml and make sure its ok. PM a link to your xml addy if you would like.

Share this post


Link to post
Share on other sites

hmm, the image i was going to use is 64x64, but for now i been just trying to get the info to load.

ill focus on the st.truck now i know that though, and thats a great idea hudson :-p

Share this post


Link to post
Share on other sites

I cant seem to get this working too.

Ive done all the necessary stuff and all that but i get the "Not able to load textures from bla bla bla blabla (a tmp directory) *.paa" error.

However when i get into a vehicle the logo appears but only as a black square... together with the remark i added in the xml.

Anyone noe what i did wrong?

Share this post


Link to post
Share on other sites

well, the easy way of testing is to use anouther working paa file (team-mofo.com/dude.paa for our one) and see if that works. it needs to be in the same dir as the squad.xml file on your webserver, and the xml file must have the filename correct (dude.paa in this case, obviously).

if that works, you screwed up making the paa file. Dont worry, i screwed it up twice too, it takes some trail and error. -- make sure you have RLE compression (or whatever its called) turnerd off, that seemed to help for me.

Share this post


Link to post
Share on other sites

yea i guess it is the paa file.

I tried using direct from photshop with Kegetys' PAA plugin and it had so many buttons to press i didnt noe which one to pick.

Then i tried texview and converted the tga file to paa. Still doesnt work.

It still gives me the same error about not able to load the texture from my Arma TMP squads folder or something like that.

Other than that every thing else works fine.

Share this post


Link to post
Share on other sites

if you send me a link to the jpg of whatever ill convert it for you if you want. - it took a bit of fiddling but if i did it once, i can do it again.

edit: typo

Share this post


Link to post
Share on other sites

Hi sirex,

The tuts I found on how to do this with photoshop are outdated for photoshop 9

I'm able to do it in Paintshop11 first, then have to open up again in photoshop because it only save TGA 24bit in paintshop and then rename it to *.paa through texview.

I also installed "The Gimp" today and that does the job very well, but I'm used to Photoshop & would like to use this.

Could you tell me step by step on how to do this with Photoshop?

Thx a lot!

Seven

*edit: a paa plugin? wow_o.gif where to find that?

Share this post


Link to post
Share on other sites

i used the gimp, 'cos im a linux nut. biggrin_o.gif

photoshop is eeeeebil.

Share this post


Link to post
Share on other sites

Awwww, ive just read this forum because for ages i was wondering how to get sqaud xmls. Now that ive finally discovered how bloody complicated and so like ArmA it is (hardly eva works, and is different for different people) im a bit dissapointed, i reckon ther should have been a easy "create xml" page which u could have in game.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×