Jump to content
Barba-negra

create monitor object

Recommended Posts

Hello friends, greetings to all, I come here to ask for help, I am trying to create an object that serves as a monitor and helps me transmit images and videos, but I do not know what I will be missing because the object does not give me an image screen, I have the object created, and the configuration script like this:

 

this is the created object that acts as a screen:

 

imagen-objeto.png

 

this is the configuration in the config.cpp:

 

class CfgPatches
{
    class Barba_Bama_Config
    {
        units[]=
        {
            ""
        };
        weapons[]={};
        requiredAddons[]={};
        requiredVersion=1;
    };
};
class CfgVehicleClasses
{
    class Barba_Bama_Config
    {
        displayName="Barba_Bama_Config";
    };
};

 

class CfgVehicles
{

 

class NonStrategic;

 

class Leaflet_base_Fd: NonStrategic
    {
        mapSize=0.20999999;
        _generalMacro="Leaflet_base_Fd";
        scope=0;
        scopeCurator=0;
        displayName="";
        model="\Barba_Bama_Config\emptyd.p3d";
        icon="";
        vehicleClass="Small_items";
        destrType="DestructNo";
        cost=100;
    };
    
     class Poster_base_Fd: Leaflet_base_Fd
    {
        mapSize=0.41999999;
        _generalMacro="Poster_base_Fd";
    };
    
     class Land_Poster_01_Fd: Poster_base_Fd
    {
        mapSize=1.1900001;
        class SimpleObject
        {
            eden=0;
            animate[]={};
            hide[]={};
            verticalOffset=0.0049999999;
            verticalOffsetWorld=0;
            init="''";
        };
        editorPreview="";
        _generalMacro="Land_Poster_01_Fd";
        scope=1;
        displayName="";
        model="\Barba_Bama_Config\Poster_01_Fd.p3d";
        icon="";
        posterSize=2;
        hiddenSelections[]=
        {
            "camo"
        };
        hiddenSelectionsTextures[]=
        {
            "\Barba_Bama_Config\Textures\negra.paa"
        };

};

 

then I put the object in the editor and try to make it reproduce an image:

 

Monitor1 setObjectTextureGlobal [0, 'Medidor0.paa'];

 

but it doesn't show me the picture, what is missing? please help

Share this post


Link to post
Share on other sites

hiddenselection textures require the changing texture mesh selections to be defined in the sections list of model.cfg for that object

  • Like 1

Share this post


Link to post
Share on other sites
On 1/11/2020 at 12:13, HorribleGoat said:

Las texturas hiddenselection requieren que las selecciones de malla de textura cambiante se definan en la lista de secciones de model.cfg para ese objeto

ah ok friend I understand, excuse me, could you give me a graphic example? is that I do not have much knowledge in this please

Share this post


Link to post
Share on other sites
On 10/31/2020 at 8:41 AM, Walkero0 said:

Does your placed object have the name Monitor1? any issues showing up in rpt?

if friend the name of the object is correct, I think it is a problem in the configuration of the creation of the object as such

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×