Jump to content
Rich_R

Broken cTab - THREAD UPDATED WITH FIX

Recommended Posts

The latest update, and I think more specifically the addition of BIS_fnc_mapGridSize, has broken the awesome cTab. When starting the game and mission the following error appears

 

HNAWtE.png

 

It appears to work fine in-game

 

When I peek under the hood this is the part of the config the error is referencing

 

class RscTitles
{
	titles[] = {};
	class cTab_mapSize_dsp
	{
		idd = 13673;
		onLoad = "uiNamespace setVariable ['cTab_mapSize_dsp',_this select 0]";
		fadein = 0;
		fadeout = 0;
		duration = 1e+011;
		controlsBackground[] = {};
		objects[] = {};
		class controls
		{
			class mapSize: cTab_RscMapControl
			{
				idc = 1110;
				type = 100;
				x = "safeZoneXAbs + safeZoneWAbs";
				y = "safeZoneY + safeZoneH";
				w = 0.01;
				h = 10;
				scaleMin = 0.001;
				scaleDefault = 0.001;
				maxSatelliteAlpha = 0;
				ptsPerSquareSea = 10000;
				ptsPerSquareTxt = 10000;
				ptsPerSquareCLn = 10000;
				ptsPerSquareExp = 10000;
				ptsPerSquareCost = 10000;
				ptsPerSquareFor = 10000;
				ptsPerSquareForEdge = 10000;
				ptsPerSquareRoad = 10000;
				ptsPerSquareObj = 10000;
			};
		};
	};

Anyone have an idea how the above needs to be changed to meet these standards?

 

I'm going to reach out to the authors stated in (at least my version) of cTab and see if a) they have an idea and b) if someone can suggest a fix its okay to release an updated version.

 

Thanks everyone!

Share this post


Link to post
Share on other sites

Thanks Dedmen

 

Ive sent emails to two of the mods authorrs to ask for permission or for them to do it.

 

We’ll see!

Share this post


Link to post
Share on other sites

Just for those also interested; added the error and apparent fix to the mods official gitub. However, it looks rather inactive and I haven't heard back from the mod's creators.

 

 

  • Thanks 1

Share this post


Link to post
Share on other sites
On 3/8/2019 at 2:01 PM, Rich_R said:

Just for those also interested; added the error and apparent fix to the mods official gitub. However, it looks rather inactive and I haven't heard back from the mod's creators.

 

This is awesome, I'll fix mine, but please clarify which file this is about (where did you add the "widthRailWay = 4;" lines)

ctab.pbo\config.cpp ?

Since there's also the bamse ctab fix it's worth thinking about uploading a fixed pbo here by yourself.

Share this post


Link to post
Share on other sites

The ‘suggested’ fix applies to the config.cpp. Apologies if this wasn’t mentioned on the CTab  github comment linked above.

 

Im not sure how to do a ‘fix’ addon. Always interested to learn though!

Share this post


Link to post
Share on other sites
10 hours ago, Rich_R said:

Im not sure how to do a ‘fix’ addon. Always interested to learn though!

 

class CfgPatches {
    class cTabFix {
        units[] = {};
        weapons[] = {};
        requiredVersion = 1.90;
        author[] = {"Dedmen"};
        requiredAddon[] = {"cTab"};
    };
};

class cTab_RscMapControl {
    widthRailWay = 1;
};

The fix explained in the issue report is actually very inefficient. This one is way better.
I'm trying to make a pull request to the cTab repository (that won't get merged anyway but why now eh?) but Github is bugging around.

 

You can get a build of the patch here: https://github.com/Riouken/cTab/files/2982658/cTabFix.zip (https://github.com/Riouken/cTab/issues/164)

  • Like 4

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×