Jump to content
Sign in to follow this  
BRPVP

BIS_fnc_setIdentity causing severe slow down.

Recommended Posts

I run a dedicated server with a mission (BRPVP) and no mods.

On some restarts, suddenly fps starts to get severely afected. Sometimes this happens.

 

This just happened right now. And using the profiling Arma 3, i did that:

 

- Joined the server

- Teleported me far away on the ocean, with nothing more than water.

- FPS was 45, and normally in this situation FPS should be 150 or more.

- I take a performance shot using Arma 3 profiling.

 

On the performance shot i notced the problem is caused by the function BIS_fnc_setIdentity:

 

This is the relevant part of the performance shot:

* Thread Main Thread
total; 0.00942; 24.52281;""
 wSimu; 0.09401; 24.43348;""
  siScr; 2.90163; 15.54813;""
   scrVM; 3.21254; 15.23670;"BIS_fnc_setIdentity:20"
    memAR; 3.21496; 0.00993;""
    memAl; 3.22589; 0.00022;""
    memAR; 3.22720; 0.00687;""
    memAR; 3.23632; 0.00740;""
    memAR; 3.24587; 0.00728;""
    memAR; 3.25509; 0.00714;""
    memAR; 3.26386; 0.00722;""
    memAR; 3.27264; 0.00714;""
    memAR; 3.28182; 0.00714;""
    memAR; 3.29044; 0.00714;""
    memAR; 3.29909; 0.00706;""
	(1339 lines...)
    memLo; 18.31762; 0.00002;""
    memLo; 18.32825; 0.00003;""
    memLo; 18.33831; 0.00002;""
    memLo; 18.34898; 0.00002;""
    memLo; 18.35913; 0.00002;""
    memLo; 18.36943; 0.00002;""
    memLo; 18.38034; 0.00002;""
    memLo; 18.39138; 0.00002;""
    memFr; 18.40213; 0.00012;""
    memLo; 18.41284; 0.00002;""
    memLo; 18.42370; 0.00002;""
    memLo; 18.43463; 0.00002;""
    memLo; 18.44531; 0.00002;""

The mission don't use this function. May be something related to vanilla Arma 3?

Here the description of the function: https://community.bistudio.com/wiki/BIS_fnc_setIdentity

I apreciate your help.

 

Thanks.

 

  • Thanks 1

Share this post


Link to post
Share on other sites

I'm running BRPVP mission on a dedicated server.

www.brpvp.com

 

Zeus module is on.

Share this post


Link to post
Share on other sites

Can you run dev Branch. The BIS_fnc_setIdentity on dev branch is different, can you try that?

  • Like 1

Share this post


Link to post
Share on other sites

The problem happens in multiplayer enviroment. Not sure if i will be able to reprocuce it in a private dev server with just me playing around.

I believe the problem is not inside the function, but with some external caller tha calls the function thousands of times in a frame.

Share this post


Link to post
Share on other sites

It happened again, here the ASP Tracy and Arma 3 Profiling files:

 

Tracy: https://drive.google.com/file/d/1pSZQ2ZsvacLX-E-vPmWI-_tqh0tSHR10/view?usp=sharing

Profiling: https://drive.google.com/file/d/1x-g6f1tO2NHj1ZPEGBYICnFXyO_GE3Pp/view?usp=sharing

 

It is possible to change the BIS_fnc_setIdentity function to {true} so it runs faster and don't cause lag?

BIS_fnc_setIdentity = {true};

The function runs thousands of times per frame and this is the cause of lag.

Share this post


Link to post
Share on other sites

You should try dev version like I said, the old one had a bug that would cause recursive looping

Share this post


Link to post
Share on other sites

I will try DEV build, so.

 

If DEV is ok we can expect that to be fixed in the next Arma 3 update?

Share this post


Link to post
Share on other sites

Yes, i enable Arsenal for Admins.

 

They can use an option that run this code on their computer:

["Open",true] spawn BIS_fnc_arsenal;

 

Share this post


Link to post
Share on other sites

Unfortunately this is just a partial fix and might not be available in the next release as more changes need to be added

  • Like 4

Share this post


Link to post
Share on other sites

Remove Virtual Arsenal can help to stop the bug?

Share this post


Link to post
Share on other sites

Theoretically, it calls BIS_fnc_setIdentity. Probably same happens when you try to customise a unit in zeus

Share this post


Link to post
Share on other sites

I disabled Virtual Arsenal after you first mentioned it and since that had no problem with BIS_fnc_setIdentity.

Share this post


Link to post
Share on other sites

Should be fixed in the next update, might have been too close to release to include in this one

  • Thanks 1

Share this post


Link to post
Share on other sites
Posted (edited)
On 3/6/2019 at 11:47 AM, killzone_kid said:

Should be fixed in the next update, might have been too close to release to include in this one

Wooooooooooooooo killzone kid the legend

wadap m8

Edited by Dedmen
Removed allcaps. Rule 12

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×