Jump to content

Recommended Posts

Just now, GEORGE FLOROS GR said:

 

Thanks Griff , i'm going to check it now !

Thanks mate, It's been stumping me all evening!

  • Like 1

Share this post


Link to post
Share on other sites
5 minutes ago, Griffiths_4 said:

all evening

 

I just noticed that i forgot to update the whole scripts!

 

Thanks for reporting the issue !

I will update this now.

Share this post


Link to post
Share on other sites
Just now, GEORGE FLOROS GR said:

 

I just noticed that i forgot to update the whole scripts!

 

Thanks for reporting the issue !

I will update this now.

Glad I could be of help, do let us know when it's all ready!

  • Like 1

Share this post


Link to post
Share on other sites

George, first of all thank you for this great script. I have been using it in my new mission (new dev here) and I have to say it is very foolproof. Yet, there is something I have not been able to change... I have been trying to change the recon team composition.

this is what I do.

1. I uncomment [] execVM "GF_Crashsites\GF_Crashsites_vanilla_ravage.sqf";
2. go to vanilla_ravage.sqf and edit the chunk located between line 1188 and 1195

3. This is my code:

 

//	define your Group 
#define GF_Recon_Group "rhsgref_cdf_b_ngd_rifleman", "rhsgref_cdf_b_ngd_machinegunner", "rhsgref_cdf_b_ngd_rifleman_lite", "rhsgref_cdb_b_ngd_squadleader","rhsgref_cdb_b_ngd_grenadier_rpg"

GF_Recon_Teams = createGroup WEST;
//	Spawn the group 2000 meters from the drop
GF_Recon_Teams_randomPos = [[[GF_MOVE_TO_Crashsite_position, (1200)],[]],["water","out"]] call BIS_fnc_randomPos;
GF_Recon_Teams = [GF_Recon_Teams_randomPos, WEST,[GF_Recon_Group]] call BIS_fnc_spawnGroup;
GF_Recon_Teams setCombatMode "RED";

 

the outcome of changing this is none, the independent group still appears after changing the script. is there a way the editor caches the script so the changes are not reflected? 

hope you get some time to check it out!

 

Cheers.

  • Thanks 1

Share this post


Link to post
Share on other sites
2 hours ago, mcguiver178 said:

still appears after changing the script

 

Hello there mcguiver178 !

 

Welcome to Bis Forums !    :f:

 

Your problem , as i see might be that you might for some reason making a mistake on the files executed.

Be sure , that you are running the correct one.

 

 

Check if you have comment // the

[] execVM "GF_Crashsites\GF_Crashsites.sqf";

 

and then open the

GF_Crashsites_vanilla_ravage.sqf

and add this in the top of your script , just to be sure.

systemchat "GF_Crashsites_vanilla_ravage";

 

In any case , feel free to ask for anything you might want + i will be waiting for your mission release !

 

Share this post


Link to post
Share on other sites
//copy in your init or initserver
[] execVM "GF_Crashsites\Credits.sqf";	// Please keep the Credits or add them to your Diary
[] execVM "GF_Crashsites\GF_Crashsites.sqf";


/*
There is availale loot for Unsung , CUP , Ravage and combination of this
Unsung mod https://www.armanam.eu/
CUP mod http://cup-arma3.org/
Ravage mod http://www.armaholic.com/page.php?id=29638
*/

[] execVM "GF_Crashsites\GF_Crashsites_vanilla_ravage.sqf";

//[] execVM "GF_Crashsites\GF_Crashsites_CUP.sqf";	
//[] execVM "GF_Crashsites\GF_Crashsites_CUP_ravage.sqf";	

//[] execVM "GF_Crashsites\GF_Crashsites_unsung.sqf";	
//[] execVM "GF_Crashsites\GF_Crashsites_unsung_ravage.sqf";	

I checked what you mentioned and you were right I had uncommented both files when I was implementing it and it looks like they where conflicting, I will try this in the next hour or so. 
Do both have to be running or do I only need one of em? judging by the code I only need one of them right?

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, mcguiver178 said:

I only need one

 

Yes , mcguiver , you only need one of them !

Share this post


Link to post
Share on other sites

For spawning Units , you can also check some examples in my :

 

For more Scripts + News :

 

Thanks !

Share this post


Link to post
Share on other sites

This is from another topic:

11 minutes ago, jandrews said:

 


if (_5_GF_Recon_Teams_Cargo) then {

//    systemchat "_5_GF_Recon_Teams_Cargo";

GF_MOVE_TO_Cargo_position = _Cargo getRelPos [0, 12];
//    define your Group 
#define GF_Recon_Group_Cargo "I_G_Soldier_SL_F", "I_G_Soldier_TL_F", "I_G_Soldier_M_F","I_G_medic_F","I_G_Soldier_AR_F"  < -- here
        
GF_Recon_Teams_Cargo = createGroup independent;
//    Spawn the group 2000 meters from the drop
GF_Recon_Teams_Cargo_randomPos = [[[GF_MOVE_TO_Cargo_position, (200)],[]],["water","out"]] call BIS_fnc_randomPos;
GF_Recon_Teams_Cargo = [GF_Recon_Teams_Cargo_randomPos, independent,[GF_Recon_Group_Cargo]] call BIS_fnc_spawnGroup;
//GF_Recon_Teams_Cargo setCombatMode "RED"; <-- here
[GF_Recon_Group_Cargo, GF_MOVE_TO_Cargo_position, 25] call BIS_fnc_taskPatrol;    <----- Here and below.
 
{
   if(side _x == independent) then
   {
    _x unassignItem "NVGoggles";
    _x removeItem "NVGoggles";
    _x RemovePrimaryWeaponItem "acc_pointer_IR";
    _x addPrimaryWeaponItem "acc_flashlight";
    _x enableGunLights "forceon";
   };

 

 

I'm working on the GF_Missions script now and i have create a better way to spawn the groups :

 

ex:

//________________ Enemies Settings _____________

GF_Missions_Safe_Zone_distance			= 1000;					//	Add here the distance for the Safe Zones and players
GF_Missions_DAC_Area_Spawn_Meters 		= random 350 + 350;		//	The size of the area
GF_Missions_Enemy_Side					= east;					//	This is NOT for the DAC units
GF_Missions_Squad_Members				= 6 + floor random 6;
GF_Missions_set_AiSkill					= random 0.75 + 0.25 ;
GF_Missions_BIS_fnc_taskPatrol_distance = random 250 + 100;		//	The distance for BIS_fnc_taskPatrol
GF_Missions_Air_Patrol_distance			= random 500 + 500;		//	The distance for BIS_fnc_taskPatrol

 

	//________________	Missions Units Pool	________________
	
	//________________	Infantry	________________
	
GF_Missions_Pool_Infantry = [
	"O_G_officer_F","O_G_Soldier_SL_F","O_G_Soldier_TL_F","O_G_medic_F","O_G_engineer_F","O_G_Soldier_exp_F","O_G_Soldier_GL_F",
	"O_G_Soldier_M_F","O_G_Soldier_LAT_F","O_G_Soldier_A_F","O_G_Soldier_F","O_G_Soldier_lite_F","O_G_Sharpshooter_F",
	"O_G_Soldier_universal_F"
	];

 

//________________	GF_Missions_Spawn_Infantry_Patrol	________________

GF_Missions_Spawn_Infantry_Patrol = {

_Pos = GF_Missions_pos;
_Group_Pos = [[[_Pos, (25)],[]],["water","out"]] call BIS_fnc_randomPos;
_Group = createGroup GF_Missions_Enemy_Side;

for "_x" from 1 to (GF_Missions_Squad_Members) do {

_unit = _Group createunit [GF_Missions_Pool_Infantry select floor(random count GF_Missions_Pool_Infantry),_Group_Pos,[],0,"None"];
[_unit] JoinSilent _Group;
(leader _Group) setSkill GF_Missions_set_AiSkill;

if (GF_Missions_Change_Equipment) then {	
_unit spawn GF_Missions_Set_Custom_Loadout;
};
};
[_Group,_Pos,GF_Missions_BIS_fnc_taskPatrol_distance] call BIS_fnc_taskPatrol;
};

 

add this to use :

[] spawn GF_Missions_Spawn_Infantry_Patrol;

 

Share this post


Link to post
Share on other sites

HI GF.

You could implement a config extract function for classnames that will create arrays using current loaded mods without editing anything by user.

  • Like 1

Share this post


Link to post
Share on other sites
10 hours ago, davidoss said:

implement a config extract function for classnames

 

This would be very good ,

but still , i would have to set mission parameters including the possible mods to sort of the functions , right ?

Share this post


Link to post
Share on other sites

I'm not that much familiar with your code, i just saw lots of predefined arrays and though you can just let this to define automatically by config extract.

PS:

very nice coding clean and precise i like it

  • Thanks 1

Share this post


Link to post
Share on other sites

Thank you very much Davidoss !

 

I'm trying to keep it as simple as possible and to learn on , how to script better !

I 'm not any kind of professional , just an arma lover !

 

 

  • Like 1

Share this post


Link to post
Share on other sites

Hi George!

Is there a way to run this script without running CUP Terrains Core? For some reason, the script will not run unless I enable that mod. If it does run, the markers will not show without CUP.

Also... when I try to remove the CUP_Ravage and other scripts, it will not work at all. I just want to use the crashsites.sqf. Is this possible?

Share this post


Link to post
Share on other sites
36 minutes ago, Donnie_Plays said:

Is there a way

 

Hello Donnie_Plays !

 

I have seperate scripts that you can select depending on loot and the vehicles of the crashsite.

So there is a vanilla ravage file , are you using this ?

Share this post


Link to post
Share on other sites

I have Good news for this script!

 

One new script will be available very soon , with the auto loot scripts included ,

 

as it is in the GF Auto Loot Script

 

and there will be also some more improvement.

 

Thanks !

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, GEORGE FLOROS GR said:

I have Good news for this script!

 

One new script will be available very soon , with the auto loot scripts included ,

 

as it is in the GF Auto Loot Script

and there will be also some more improvement.

 

Thanks !


I really appreciate all the work you have done George.

I have spent a lot of time editing the crash sites script just to get them to work properly on a server I'm planning to be involved with. They work just fine and they currently work the way that I want them to. I do not want items auto added. I am being very specific with the types of things that spawn. The only issue I have... your scripts are requiring CUP Terrains Core to run. That's a 6GB mod that I would rather not use on the server.

I would like to remove the two CUP sqf's and the two unsung sqf's and just run the crashsites.sqf with Ravage.

As I look through the code in crashsites.sqf, I see no references to CUP or the other scripts so I'm confused why the script will not run properly without that mod.

Share this post


Link to post
Share on other sites
8 hours ago, Donnie_Plays said:

As I look through the code in crashsites.sqf, I see no references to CUP or the other scripts so I'm confused

 

You need to run only the certain script that you want , not all the scripts !

This is the problem ?

Share this post


Link to post
Share on other sites
16 hours ago, GEORGE FLOROS GR said:

 

You need to run only the certain script that you want , not all the scripts !

This is the problem ?


I'm only running crashsites.sqf.

That's what I'm saying. The script will not work if I remove the other sqf's from the folder. It also will only show the markers if I enable CUP terrains core, but I'm not using a marker from CUP

Share this post


Link to post
Share on other sites
11 hours ago, Donnie_Plays said:

I'm only running crashsites.sqf.

 

Might be that you have edit this and somehow not work for this reason?

Have you changed the wreck models of the planes with the Cup?

The included files for the selected loot - Mods used , are standalone scripts , you don't need to run the others.

 

You can paste the code here , in order for me to find the issue .

 

Share this post


Link to post
Share on other sites

I have fixed the CUP issue.

The only issue I'm finding now... I'm not sure what the best way to run the script on a server would be.

When playing hosted games, only the host can see the correct items for some reason and if two or three people are playing they cannot all see the same loot.

Share this post


Link to post
Share on other sites
56 minutes ago, Donnie_Plays said:

two or three people are playing they cannot all see the same loot.

 

They might not see the loot at all due to mods that might interfere or even if you have used wrong the items with the arrays , because there is a difference using ex:

 

addBackpackCargoGlobal or addItemCargoGlobal  or addMagazineCargoGlobal and addweaponCargoGlobal

 

# PS i just notice that it might be as well , because i haven't use the above .

addweaponcargo - addweaponcargo and addMagazineCargo need to be changed !

( to the ones above )

 

  • So else i will update this script as well !
  • Like 1

Share this post


Link to post
Share on other sites
16 hours ago, GEORGE FLOROS GR said:

 

They might not see the loot at all due to mods that might interfere or even if you have used wrong the items with the arrays , because there is a difference using ex:

 

addBackpackCargoGlobal or addItemCargoGlobal  or addMagazineCargoGlobal and addweaponCargoGlobal

 

# PS i just notice that it might be as well , because i haven't use the above .

addweaponcargo - addweaponcargo and addMagazineCargo need to be changed !

( to the ones above )

 

  • So else i will update this script as well !


It seems that everything works well for the host, whoever the host is each time. It's the indivdual clients who are connecting who are unable to see the same items. I'm currently using the loot spawning in a container at the crash sites, because I think it's better for performance. Sometimes I'll walk up and see a rifle and handgun but my friend looks in the same box and the weapons are not showing for some reason.

I'm getting items that I want to spawn, but sometimes I get vanilla scopes and items that I do not want. Specifically items like Thermal Weapon scopes that I do not want on the server. How do I keep vanilla items from spawning?

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×