Jump to content

Recommended Posts

4 hours ago, krzmbrzl said:

Yeah that is exactly right.

 

I had a look at my code though and in the dev version the problem with the ObjectRTD should be fixed already. However it now fails at pages like createUnit because people are putting notes in every shape and form everywhere all over the place, which basically makes it more or less impossible for me to process the necessary information properly. Combined with the fact that SQDev will switch to using OrinocoSQF for code linting and auto-complete, I guess I won't really update the algorithm accordingly.

If you need to change some syntax or anything because the plugin keeps misinterpreting certain things (or is missing a command), you can change the keyword file manually. There's a little note on that in the manual that also tells you where you can find that file: http://krzmbrzl.github.io/SQDev/resources/SQDev.pdf#subsection.5.2.3

Might aswell use the intercept command list if all you need is syntax.

 

Wiki isn't made to be machine readable.

Share this post


Link to post
Share on other sites
17 hours ago, Dedmen said:

Might aswell use the intercept command list if all you need is syntax.

It is not. I also strip out description, notes, examples, etc.

 

17 hours ago, Dedmen said:

Wiki isn't made to be machine readable.

Yeah I noticed this premise xD

 

Though I might be making a hybrid of getting most information off the biki but using your intercept list for syntaxes. After all the extraction of the syntaxes and return values and this kind of stuff is the root of all problems I'm having with the whole thing. On the other hand the whole point of having the update mechanism was to not needing someone to manually update some lists in some custom projects. But I guess this isn't feasible anymore.

I guess I'll give it a try then...

Share this post


Link to post
Share on other sites

Hi Guys

 

I have a problem installing this plugin for the Eclipse Photon.

I have performed all the installation steps according the manual but after restart i dont have any SQDev perspective nor preferences node section.

Neither do i have any new project wizard.

I have checked the installation and it is listed in the list of installed addons.

Any idea what is going on?

I have a PDT version of Eclipse which is basically the normal one with PHP tools.

Here is a screen https://pasteboard.co/I8IJlEJ.jpg

 

Share this post


Link to post
Share on other sites

Okay that seems kinda strange to me - Could you have a look at the Plug-Ins-tab (in the installation details you screenshotted) and check for all plugins having an ID starting with raven? Maybe the individual plugins  didn't get installed properly.

 

Also I think uninstalling and re-installing the plugin might be worth a try 🤔

Share this post


Link to post
Share on other sites
7 hours ago, krzmbrzl said:

Okay that seems kinda strange to me - Could you have a look at the Plug-Ins-tab (in the installation details you screenshotted) and check for all plugins having an ID starting with raven? Maybe the individual plugins  didn't get installed properly.

 

Also I think uninstalling and re-installing the plugin might be worth a try 🤔

I figured it out.

Plugins were indeed missing.

Then i remembered that i got eclipse in program files folder and to write there user needs to have elevated privileges.

So i started eclipse with admin rights and reinstalled - it worked.

However strange thing is that the old installation has not raised any errors? Like failed to copy plugins...

Anyway thanks for the idea!

 

  • Like 1

Share this post


Link to post
Share on other sites

Even better 👍

 

12 hours ago, Flanky said:

However strange thing is that the old installation has not raised any errors? Like failed to copy plugins...

Yeah one should expect some sort of error message - That's not in my hands though. Dunno why eclipse handles it like this...

 

12 hours ago, Flanky said:

Anyway thanks for the idea! 

Any time. I hope you'll find the plugin helpful.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×