Jump to content
Sign in to follow this  
paradoxparadoxon

Trouble with ArmA 3 Server

Recommended Posts

I have some problems with my ArmA 3 Server.

ive got a 2500 Ping on my Server. I have opened all the required ports.

But i can connect...

My ArmA 2 Server is working... I dont now whats wrong.

Thats my Basic.cfg

language="English";
adapter=-1;
MinBandwidth=94371840;
MaxBandwidth=966367641;
MaxMsgSend=384;
MaxSizeGuaranteed=512;
MaxSizeNonguaranteed=256;
MinErrorToSend=0.003;
MaxCustomFileSize=100000;
Windowed=0;
serverLongitude=0;
serverLatitude=52;
serverLongitudeAuto=0;
serverLatitudeAuto=52;

Startup Parameters

-port=2302 -config=server-cfg\server.cfg -cfg=server-cfg\basic.cfg -profiles=server-cfg\Logs

Its a dedicated machine with Windows Server 2008 R2 Enterprise and a 1 Gbit connection

-ParadoxParadoxon

Edited by ParadoxParadoxon
Fix basic.cfg

Share this post


Link to post
Share on other sites

steam ports open and defined in the ****.cfg?

I read something about server ping being seen as 2500, cant remember where, do a search for that. There is a solution somewhere

Share this post


Link to post
Share on other sites

I don't know what I should ask the provider. ICMP works, the ArmA 2 server runs without any problems.

And currently some Players are connectet to my Server. The 2500 ping will show only at the serverlist.

Share this post


Link to post
Share on other sites

Your Min and Max bandwidth look wrong.

If this is a 100Mbit connection you have theoretically 12.5Mbytes bandwidth available

That is 104857600 bits

On a 1Gigabit connectiontheoretically you have 1073741824 bits available

Realistically you wont get that, but should be getting something like 85-90%

So your max bandwidth could be something more inline with the following

Compare

966367641 (90% of 1 Gigabit connection)

94371840 (90% of 100 megabit connection)

25000000 (Your value)

And then you can bump your min bandwidth up too

The rest of the settings look fine

Share this post


Link to post
Share on other sites

I contacted the support. They offered help to time conditions of 50 € per 30 minutes directly on the server. ports should be free, they don't block anything.

I have fix the basic.cfg for 1Gbit connection

i still have trouble with the Ping...

In Serverlist 2500ms , in game 11ms

Share this post


Link to post
Share on other sites

Hi,

The problem with 2500ms in the server list is a problem with firewall.

Add ingoing rules for Arma3 launcher (.exe) in your firewall to solve the problem.

Greats.

Share this post


Link to post
Share on other sites

This one : "arma3server.exe"

I m also on WinServer 2008 running (on VM) and it solve the problem for me.

Edit : Haaa and run it as administrator !

Edited by Soldat_Ryan

Share this post


Link to post
Share on other sites

did you set the VM yourself and really do need it?

if not, try in the "normal not virtual instance" ...because, i had this problem too and there is absolutely no setting needed at all...

ALL THE SECRET IS: just start it as Administrator

Shift+rightclick and Run as Administrator

or you can edit the fileoptions itself (rightclick and setting - compatibility "always run as administrator" ) if you use any other launcher that starts the .exe

Share this post


Link to post
Share on other sites

try this

restart the server (can you do without VM? so its starting a "normal" instance of WinServ2008?)

1. Open command prompt (cmd).

2. Enter the following command:

netsh firewall set icmpsetting 8

*source

http://www.mickgenie.com/enable-icmp-request-through-windows-server-2008-firewall/

and then start arma with shift+rightclick - run as administrator and hold shift until serverconsole started.#

*EDIT: i assume you have configured all anti-virus/ 3rd party firewalls for all needed ports also?

Share this post


Link to post
Share on other sites

Run your steam client as Administrator

Ping is your clients perspective on the server

This will only be a server-side issue, if every other client has the same issue with your server

Share this post


Link to post
Share on other sites

Terox,

afaik is the problem the middleware ...also called that gamespy-crap

as the server reports the hostname to gamespy, which is asking for the ping ... if gamespy don't get the right/enough icmp packages back - it shows 2500ping -and then gamespy is reporting it to the clients.

Of course you are right with the "perspective" but if the "source" (gamespy) is getting/telling 2500 - the client will see 2500 too.

If another player is seeing the server with a ping of 100 but Paradox still sees 2500 - then there could be a clientside issue (for Paradox).

@ paradox: or does every other server in the gamelist shows you 2500 too?

Edited by Blue1

Share this post


Link to post
Share on other sites

ParadoxParadoxon, in regards of what Blue1 is writing here :

as the server reports the hostname to gamespy, which is asking for the ping ... if gamespy don't get the right/enough icmp packages back - it shows 2500ping -and then gamespy is reporting it to the clients.

Have you this line in your server.cfg ?

reportingIP="arma3pc.master.gamespy.com";

____

@Blue1 : i said i m using VM as i could have said i m using a PC or a Washing machine. It is not the problem met by ParadoxParadoxon. (I have edited my post and added () ). And Yes for me to run Arma3 server correctly it is usefull to run a VM because my main server is running under linux.

Greets.

Edited by Soldat_Ryan

Share this post


Link to post
Share on other sites

//
// server.cfg
//
// comments are written with "//" in front of them.

// STEAM

steamport=8766;
steamqueryport=27016;

// GLOBAL SETTINGS

hostname        = "[24th Platoon] Domination - MORE VEHICLES - Hosted by 24th-platoon.de";        // The name of the server that shall be displayed in the public server list
//password         = "ServerAccessPassword";            // Password for joining, eg connecting to the server
passwordAdmin         = "ÖÖÖÖÖÖ NO";                // Password to become server admin. When you're in Arma MP and connected to the server, type '#login xyz'
reportingIP         = "arma3pc.master.gamespy.com";            // This is the default setting. Leave empty for private servers if you do not want your server listed publicly
logFile            = "A3Master.log";
verifySignatures     = 2;

// JOINING RULES
maxPlayers        = 40;        // Maximum amount of players. Civilians and watchers, beholder, bystanders and so on also count as player.
// VOTING
voteMissionPlayers    = 1;        // Tells the server how many people must connect so that it displays the mission selection screen.
voteThreshold        = 0.33;        // 33% or more players need to vote for something, for example an admin or a new map, to become effective
//voteMissionPlayers    = 0;

// INGAME SETTINGS
disableVoN        = 0;        // If set to 1, Voice over Net will not be available
vonCodecQuality     = 8;        // Quality from 1 to 10
persistent        = 1;        // If 1, missions still run on even after the last player disconnected.

// MISSIONS CYCLE (see below)
class Missions
{
         class co24_Domination_2_99f_Blufor_Beta_VAS
	  {
             template="co24_Domination_2_99f_Blufor_Beta_VAS.Stratis";
             difficulty="Regular";
         };
};

Server Name: [24th Platoon] Domination - MORE VEHICLES - Hosted by 24th-platoon.de

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×