Jump to content
brfield

Mic Not Transmitting

Recommended Posts

My mic isn't working with ArmA 3 for some odd reason. Works with anything else I try it on to test with. It isn't (or should be) locked by any other programs. Only thing on my machine using the mic right now is Steam and ArmA. Steam sees my mic and detects my voice flawlessly, as I can use it in DOTA and other games. Yet in ArmA I get nothing.

Share this post


Link to post
Share on other sites
My mic isn't working with ArmA 3 for some odd reason. Works with anything else I try it on to test with. It isn't (or should be) locked by any other programs. Only thing on my machine using the mic right now is Steam and ArmA. Steam sees my mic and detects my voice flawlessly, as I can use it in DOTA and other games. Yet in ArmA I get nothing.

I found a similar issue last night, when there was a vehicle engine running my mic transmit both in ingame VON and TS3 was so garbled that no one could understand a word, as soon as vehicle engines stopped it was fine.

This is with a realtek HD onboard sound chip, I have an X-fi fatality installed but the headphones connected are currently in need of some rewiring so the device is disabled.

Share this post


Link to post
Share on other sites

you have your mic totaly muted on any program like steam or so? cause that overwrites it sometimes

Share this post


Link to post
Share on other sites
you have your mic totaly muted on any program like steam or so? cause that overwrites it sometimes

No I do not. When I go into steam, I can hit the test mic button, and it repeats to me my voice. Windows' little green bar graph thingy reacts, I can use Mumble (currently shut off).

Share this post


Link to post
Share on other sites

Same problem here, be very interested if there is a fix for this, glad I'm not alone though in some ways!

Share this post


Link to post
Share on other sites

Are your running Steam as Administrator?

Share this post


Link to post
Share on other sites

Running Steam in Administrator mode has worked... Never had that happen in Arma 2 but this is now sorted for me at least. Cheers!

Share this post


Link to post
Share on other sites

My mic is not working in game. It works in other games such as CS-S, CS-GO, TF-S, steam client, windows, mumble, ventrilo, and teamspeak, but not in arma 3. Is there a fix for this?

Share this post


Link to post
Share on other sites

Ive been battling this problem for some time, whilse teamspeak and steam could properly detect my microphone and its transmissions, ARMA would not transmit any sound, but i have now found a working solution

Right click your sound icon in the lower right part of the screen, and click "Recording Devices".

check your default device, if it is anything other than your microphone (for example, my sound card was selected as the default device), then right click your microphone and select "Set default device"

this shouldn't even need an ARMA restart, it seems ARMA uses your default recording device for VOIP rather than your default communications device

hope this helps some people :)

Share this post


Link to post
Share on other sites
Same problem here, be very interested if there is a fix for this, glad I'm not alone though in some ways!

Probably a bit late for you, must might be useful for anyone else that has the issue and finds this thread -

I just had this exact same problem after buying a new headset (Mad Catz F.R.E.Q 7). It worked in everything except Arma 3 (although that's the only Steam MP game, so it probably wouldn't have worked in others), and as I found out after reading a couple of forums posts, I also found it didn't work in Steam (and Steam is the problem).

I had to unplug the headset, restart the PC, installed the headset AND the drivers (even if windows installs the drivers automatically, install them manually as well).

Once I did that the mic was recognised by Steam and worked in Arma 3.

Share this post


Link to post
Share on other sites

Guys I've found a solution to this problem.

I recently installed arma 3 and noticed that my friends could barely hear me, even though I have the in game config Mic sensitivity maxed out.

The issue should be with steam. In the steam menu, click on 'steam' in the upper left. Then select settings. Go down to the voice tab. Under voice, you should see an option to 'Boost Microphone Gain'. You can test your mic now and you should be able to hear your own voice.

Hope this helped!

Share this post


Link to post
Share on other sites

I've only been able to resolve this issue by connecting to a server using the launcher, then disconnecting from that server, going back to the main menu, then connecting back to the server using the in-game server browser. My mic doesn't work when I load the game through the game launcher.

Share this post


Link to post
Share on other sites

If I have my headset connected to the mic port on my PC, all I have to click is the caps lock key, to talk, right?

Share this post


Link to post
Share on other sites

Allright I've come up with some solutions. I am a musician so I've used to tweak alot of audio options.

 

I am acctually usin Steinberg UR22 mk 2 external USB soundcard and singing mic for my voice. But any case any mic goes. There was a kind of a "bug" for whatever reason in my case only the channel number one (1) works inside Arma 3. Second did not have voice. Team Speak and any other place both channels worked just fine and equally. So it's kind of weird. I was used to use the second channel because there was more options.

 

I also tested that runnin' Steam as an admistrator and think it had no effect. You could try it by just going start menu typing in Steam and there pres second mouse button and "run as admistrator". That way you should have all the options available if something in Windows was before blocking it.

I want also point out that the speaker icon in Arma 3 has nothing to do with mic working in game. The icon is not ever there as a player.

USB MIC USERS POSSIBLE HELP:
I have KORG USB keyboard and there was DRIVER issue with USB IRQ numbering. It had to be top 4 of IRQ:s numerically to work properly. So easiest solution tu get it prioritized top or numerically top on the list is to unplug all USB devices and then put the USB mic first in to get it work.

 

Some things you can try.
-Make sure you got up to date drivers or go back old drivers if it was working before
-Be sure to use right audio interface driver. Most common is onboard audio own audio device mine is Realtek Digital Audio.
-Make sure mic is in mic port and you chose from plug and play options it is a mic not a speaker lol
-Do Armas own mic autosetting. In most cases I've seen it just maximizing it. Might have something to do with that in steam it is Default seting is set to half way volume. I'm not sure...
-Do Steam sound test by pressing in game Shift + Tab and check from advanced menu of the Audio options and test your mic. If you'll have voice you should have voice in game when pressin Default button CAPS LOCK
(Some players are assholes and just don't want to answer you in game so ask your friend to play with you and test does your mic work lol)
 

I don't think Arma 3 Launcher does not have any audio options.

I hope this was helpful. If you need further help you can add me on Steam. My nickname is Edizon. I might be able to pinpoint ur problem. Just post down or Steam. ❤️
____________________________________________
Donate: https://paypal.me/MGRIND?locale.x=fi_FI
Created by Edizón
https://soundcloud.com/markus-helenius-952570943

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×