Jump to content
Sign in to follow this  
drewmaw

50% GPU & CPU Usage During Helicopter Flight

Recommended Posts

I have a strange issue happening with ARMA 3 while flying, that my GPU and CPU drop to 50 percent and my framerate is 20-30. During infantry combat, I get 50-60, and I'm LOVVVING it.

Here are my specs:

Case: HAF 512

i5 3570 oc'd to 4.5Ghz w/Cooler Master 512

EVGA GTX 670 FTW OC'd

Sabertooth Z77

16GB Corsair Vengeance DDR1600 (Quad Channel)

850w Cooler Master PSU

During flight, my GPU and CPU usage drop to 50% or less. During infantry combat, when I get great frame-rate, it's full max usage between 90-100% and is awesome. Just during flight does it tank... I've tried changing my settings to get the usage up, but nothing happens.

During infantry combat, I run everything on ultra or very high at 1080p and it's glorious. All drivers are up to date too...

Edited by drewmaw

Share this post


Link to post
Share on other sites

For a FPS boost in vehicles/choppers, disable PiP

Share this post


Link to post
Share on other sites

With the recent large DEV branch update (and I suppose the first big main branch update) PiP takes a much smaller hit on resources

Share this post


Link to post
Share on other sites

I've got similar hardware as You(i5 3570k up to 4,1 and H7870) and it simply works fine. Check if Your hardware is not overheating.

Edited by Byku

Share this post


Link to post
Share on other sites
For a FPS boost in vehicles/choppers, disable PiP

Or put it to Ultra, which is what I did. Put shadows to Standard/High/Very High. Put everything except AA, PP, Terrain Detail, and Object Detail on High+. I've got Object detail at low, terrain detail at standard (because MP has that anyway), AA and PP are disabled. I've seen a boost in performance after doing that. Plus, idk if the new Nvidia driver helped (only matters if you have an Nvidia card), but definitely seems to run better whereas it really didn't yesterday. And I've got the dev build, so I've had the update for a couple days now.

How come most people here with i5's run the game fine? Anyone got an i7 and run the game fine?

Share this post


Link to post
Share on other sites

Yup - I got a similar setup to you OP (GTX 670, i7@4Ghz, SSD etc.) and can see the lowish use of cpu and gpu on the showcase. My fps are higher though (30-60) but that could be: I'm running the dev build - which is definitely better, and I have 1500/1000 view distance/object, which does help. Also have selected gpu for physx, but not sure if that's better or worse.

V. good performance in infantry show.

Share this post


Link to post
Share on other sites

I am using an i5 + hd radeon 6950 with settings in high / very high (default settings), and I don't see any difference with infantry combat and helis, it works perfectly and fps doesn't seem to change.

Share this post


Link to post
Share on other sites
How come most people here with i5's run the game fine? Anyone got an i7 and run the game fine?

My i7 does fine for the most part. Definitely not being utilized though.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×