Jump to content
Sign in to follow this  

Waypoint issue with chopper

Recommended Posts

Hopefully this is yet another noob question..

I have searhed the forums regarding this issue, however it seems like most similiar threads are concerning load/unload problems.

In my case the problem is as follows..

a civ pilot are moved in as cargo in a c130. The c130 is called in via radio command when team is ready on ground. The c130 is in not way grouped to the pilot in the cargo. At a certain point he is ejected and lands close to the civ hind chopper, he is orderd to get in and fly to the next wp where he will be "deleted"

The problem is that the pilot will not complete the final move wp, he takes off and pretty much stays there, hoovering.

This works fine in the editor, however on a local host or on a dedi server it fails (sometimes it actually works on a local server).Iv tried a few solutions like, domove, notarget, changed wp distance etc but no luck.

I was hoping that this could be sovled without a script, and thought this was a quite simple task, guess i was wrong :)

Edit: I have now tested the sequense alone in a new map on dedi server, and it works fine. So it seems like there is something that the ai pilot reacts to in the map, that makes him halt his wp orders.

Id appriciate any help.



Edited by Sjaba

Share this post

Link to post
Share on other sites

Found the issue. It may be a noob soloution, but still annoying nevertheless.

It seems like the problem is simply that the civs are not handling WP and orders as well as bluefor/opfor units.

I simply changed unit type, then all my problems was solved.

Share this post

Link to post
Share on other sites

How about using insurgents (warning: they must be set to be friendly) and, if you want the AI to look like a civilian, then change his appearance to a civ.

I recall seeing a thread in this forum where enemy units were to be hidden/disguised as civs.

That may do the trick.

My 2 cents. Good luck!


Share this post

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
Sign in to follow this