Jump to content
Sign in to follow this  

Vehicle floats but does not steer or accelerate in the water

Recommended Posts

I  copy the PhysX part of APC_Wheeled_03 (AFV_4 in game) for my Wheeled APC, and followed all the steps of ShipX on the BIS wiki,  everything working fine, but it does only floats (always keep on the speed of 8km/h when floats) does not steer or accelerate in the water(No propelling force, No friction, just like a space ship lose power in outer space)


I had tried to copy the PhysX part form BTR80 of RHS, also not work, (not the problem of PhysX i guess)


(Important)Also, my animations what use the sources of "InWater"   "propeller" does not work, like the game dont think my APC is floating on the water


I have made one successful Tracked Amphibious Vehicles before use the PhysX from BMP3 of RHS


CfgVehicle: https://pastebin.com/uZrniYr3

PhysX.hpp: https://pastebin.com/E2Fv0vev


buoyancy=1 was added to the geometry LOD and geometry_physX LOD (i confirmed it deterministically)

Share this post

Link to post
Share on other sites

I try to add



to my config and memory point, does not work

Share this post

Link to post
Share on other sites

Solved by copying Memory LOD form AFV-4 , but i still dont know which memory points are particular for amphibious vehicles


Also, i had rewrited the model.cfg and CfgVehicles, but nothing change before i copied Memory LOD form AFV-4




Memory point my wheeled APC used to solve the issue






Momery LOD my tracked APC used, also my Wheeled APC used before(just remove some wheel axis/bounds)






Share this post

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
Sign in to follow this