Jump to content
Euroworldnetworks Yun2k

AI won't shoot with rockets on vehicle target.

Recommended Posts

So, im setting up a SP mission. Out of complete randomness the AI decided to shoot at my jeeps with their RPG. i found that so dope so I wanted to have that in the mission but it just wont replicate.


I tried setting a Destroy waypoint on the vehicle - AI does nothing, just walks there.
I tried setting them to open fire and combat state and just let them stand around (which was basiclly the same that happened when it randomly worked) but they wont shoot at it....


so what am I supposed to do to make this horrendous AI work the way i want? shouldnt it be self explenatory to enable the AI to shoot rockets at vehicles?!?!

Share this post

Link to post
Share on other sites

Your Jeep needs to have Blueforce soldiers onboard or the enemy AI dont fire.


Often, AI soldiers will use their main weapon and never use their secondary weapon. Remove all weapons from the enemy AI except for their RPG.


If the enemy has a rifle with underslung grenade launcher it will never fire the grenade launcher. Remove all bullets and with no bullets will happily fire grenades.



Share this post

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now