Jump to content
RavenF18

Yellow chains, high CPU utilization

Recommended Posts

Hi,

I've been reading so many threads about this, and I know Arma 3 server is not perfect, but I would like to have feedback about our current setup.
We run 100 player coop missions with AI's running over 2 HC's hosted in a different machine. HC's seem to run fine, but arma3server goes up to +90% CPU usage at some point creating huge amounts of desync (rubberbanding, players teleporting literally 15 mins away in just 1 sec) together with yellow chains. 

We have tried with so many combinations of performance settings, but haven't really found anything to improve.

Server specs
Intel i7-7700K CPU @ 4.20GHz 
64 GB RAM 2400 MHz
500Mb Down & upload speed.

basic.cfg
 

Spoiler

MaxMsgSend = 1536;
MaxSizeGuaranteed = 512;
MaxSizeNonguaranteed = 256;
MinBandwidth = 10485760;
MaxBandwidth = 2097152000;
MinErrorToSend = 0.002;
MinErrorToSendNear = 0.02;
MaxCustomFileSize = 1310720;
class sockets{maxPacketSize = 1400;};
adapter=-1;
3D_Performance=1;
Resolution_W=0;
Resolution_H=0;
Resolution_Bpp=32;
terrainGrid=25.0;
viewDistance=1400;
Windowed=0;

 

 

Loading parameters:

Spoiler

-enableHT -nologs -bandwidthAlg=2 -malloc=tbb4malloc_bi_x64


Executable:

Spoiler

arma3server_x64.exe

 

Mods: 

 

Spoiler

@3den Enhanced;@ace;@ACE 3 Extension (Animations and Actions);@ACE Interaction Menu Expansion;@ACEX;@Achilles;@Advanced Rappelling;@Advanced Sling Loading;@Advanced Towing;@Advanced Urban Rappelling;@BackpackOnChest;@Boxloader - ACE compatability;@BoxLoader - Vehicle in Vehicle loading;@CBA_A3;@Community Factions Project (CFP);@CTab Blufor Tracker v2.2.3;@CUP ACE3 Compatibility Addon - Vehicles;@CUP ACE3 Compatibility Addon - Weapons;@CUP Units;@CUP Vehicles;@CUP Weapons;@Enhanced Movement;@FA-18 Super Hornet;@FEMAL3 Heads;@FFAA MOD;@FFAA MOD ACE3 Compatibility Addon;@Gren_EVO;@ILBE Assault Pack - Rewrite;@Immerse;@JFXAM's Spanish F-18 Super Hornet;@Lesh's Towing Mod;@Loadout Transfer 2;@Radio Animations for Task Force Radio;@RKSL Studios- Airfield Support Tug;@TFAR;@USAF;@Pook Boat Pack;@Pook Boat Pack (CUP);@Vanilla Scopes Compatible with Goggles(Night, Thermal);@ACE Compat- USS Nimitz;@USS Nimitz

 

Average CPU utilization once all players joined:  +/- 80%
Utilization once battling starting: 90/95% & desyncs

Average traffic utilization with max players:  35-45 Mbps

 

 

Share this post


Link to post
Share on other sites

Try this basic.cfg

language="English";
adapter=-1;
3D_Performance=1.000000;
Resolution_W=800;
Resolution_H=600;
Resolution_Bpp=32;
MaxMsgSend=384;
MaxSizeGuaranteed=512;
MaxSizeNonguaranteed=256;
MinErrorToSend=0.01;
MinErrorToSendNear=0.1;
MaxCustomFileSize=1310720;
Windowed=0;
Quote

-malloc=tbb4malloc_bi_x64


No need for that launch parameter as that is the default memory allocator
-bandwidthAlg=2, i've done extensive testing with the alternate bandwidth algorithm and it's better now without that launch parameter

  • Like 1

Share this post


Link to post
Share on other sites

Cheers @dave_beastttt I will give it a try.
Trying without the min/max bw was actually on my pending list.

*** Edit ***

Much better now!  😎 thanks

  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×