Jump to content
_Que_

BattleEye failed to update

Recommended Posts

So I am trying to join an Invade and Annex server run by our unit. As soon as I load in after a few seconds or even immediately it kicks me off the game and says "You were kicked off: BattleEye failed to update". I have tried deleting and verifying my game files multiple times without success. If anyone has a solution to this problem, I will greatly appreciate this.

 

Ps: This was after the Tanks DLC update.

Share this post


Link to post
Share on other sites

Same issue here. Have tried to delete file and verify, then download through that. I have uninstalled battleeye from PC then launched Arma and had it reinstall. Neither have worked. Any help/ planned hotfix from Bohemia?

Share this post


Link to post
Share on other sites
11 hours ago, grzegorz said:

Fortunately, now I have no problem. He was in the DEV and RC versions.

 

There was an issue with BattleEye after the release. The issue was not on our side and should be already solved. Try it again pls and let me know. (You don't need to reinstall anything, just try again).

  • Thanks 1

Share this post


Link to post
Share on other sites

I'm not sure if we understand each other. After yesterday's official update (release), stable branch (version 1.82.144647), I have no problem with BE. Now I can easily join game servers. This problem no longer exists for me in the official, stable branch of the game (it disappeared, it was solved automatically).

The problem that I had with BE in test versions now applies to other users but unfortunately in the stable version of the game and I was afraid of that.

My problem was present only in test versions of the game (RC, DEV).
I can check the current version of DEV for you (I have not used it for a long time) but only in the afternoon or at night.

 

In brief.
Stable version of the game and BE for me - OK.
Stable version of the game and BE for several other users - there is a problem and I predicted it earlier.
The DEV test version - I can check again.

Share this post


Link to post
Share on other sites

I think I got it ;). I was speaking about the issues the guys actually have. Now it should be solved for everyone. Namely for @_Que_ and "tavarišč" Stalin ;)

  • Thanks 1

Share this post


Link to post
Share on other sites

i have a problem of random disconnection too, sometimes with error "session lost" and sometimes with "kicked by battleye".
tried format my PC, reinstalled windows and steam, made new user...problem still there.
help

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×