Jump to content

Vehicle not moving with player spawning as cargo

Recommended Posts

I'm porting a mission from Arma 2 and have encountered an unusual problem. Player starts as cargo in an AI Humvee, but the vehicle does not move to its waypoint at the start, unless you get out and get back in again. 


I can't for the life of me figure it out. Vehicle is placed on the map in Eden with waypoints; it's a simple setup but something is obviously not right. 


I tried adding some waitUntil checks,  but no dice. The game seems satisfied the player is in the vehicle but won't start moving unless the player gets out and in again. 


I tried setVelocity, engineon, the usual tricks to try and give him a shove, but same result. Vehicle spawns in with the player in there with his two squad mates but won't budge until I select get out and get back in, at which point it's fine.


Works okay in ArmA 2.

Share this post

Link to post
Share on other sites

I fixed this; the copied over .sqm had 'CARGO' in the 'special' field of their  Vehicle section, and the units dutifully spawned correctly, but obviously the vehicle didn't move.


So I did it the old-fashioned way and started them outside with 'moveinCargo' statements in the init and it worked absolutely fine. Perhaps ArmA 2 handled this differently, but it works now.

Share this post

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now