Jump to content
paranoid_giraffe

Include file "..." not found

Recommended Posts

I have been using the terrain builder and addon builder tools for a small bit of time, and haven't had this problem before, ever. It doesn't seem that there is any ubiquitous fix either. 

 

This is what is says in the .rpt:

 

 

 

 

 

 

 

 

 


=====================================================================
== C:\Program Files (x86)\Steam\steamapps\common\Arma 3\arma3.exe
== "C:\Program Files (x86)\Steam\steamapps\common\Arma 3\arma3.exe" -skipIntro -noSplash "-name=Giraffe PVT." -malloc=system -cpuCount=4 -malloc=system -maxmem=14081 -maxvram=3585 -noPause -mod=P:\anc_destination\@anc_afghan

Original output filename: Arma3Retail_DX11
Exe timestamp: 2016/12/07 10:50:01
Current time:  2017/02/14 13:16:10

Type: Public
Build: Stable
Version: 1.66.139586

Allocator: Windows
=====================================================================

13:16:10 Cannot register unknown string STR_USRACT_ACTIVESENSORSTOGGLE
13:16:10 Cannot register unknown string STR_CONTROLS_TOOLTIPS_SENSORS
13:16:10 Cannot register unknown string STR_CLIENT_IS_HOST
13:16:10 Cannot register unknown string STR_CLIENT_IS_DS_ADMIN
13:16:10 Initializing stats manager.
13:16:10 sessionID: 5d8a603e37f97afa9536d09b5a118187119a62d5
ErrorMessage: Include file anc\anc_afghan\config.cpp not found.
=======================================================
-------------------------------------------------------
Exception code: 0000DEAD  at 771BA832
Version 1.66.139586
Fault time: 2017/02/14 13:16:16
Fault address:  771BA832 01:000D9832 C:\WINDOWS\System32\KERNELBASE.dll
file:     
world:    
Prev. code bytes: 32 02 00 83 C4 0C 8D 04 24 50 FF 15 90 83 25 77
Fault code bytes: 8B 4C 24 54 33 CC E8 B8 F3 01 00 8B E5 5D C2 10

Registers:
EAX:0344D858 EBX:17BD68E8
ECX:00000000 EDX:00000000
ESI:17BD68E0 EDI:00000000
CS:EIP:0023:771BA832
SS:ESP:002B:0344D858  EBP:0344D8B4
DS:002B  ES:002B  FS:0053  GS:002B
Flags:00000246
=======================================================
note: Minidump has been generated into the file C:\Users\Alex\AppData\Local\Arma 3\arma3_2017-02-14_13-16-10.mdmp
 

 

 

It says that the include file is missing. What does that even mean? This never happened until last time I packed the addon. Now, even when I unpack the working backup version I have and replace the files and pack the addon with the working files, I still get this error. I cannot seem to find any way to fix this. 

 

Any way to work it out?

 

Edit: Everything was fine in terms of file structure, but packing it this time just broke it. There's nothing different from what I can tell.

Share this post


Link to post
Share on other sites

Update: deleted the configs out of all of my .pbo files and there is no more error. Obviously it goes without saying I can't use anything from my mod now. So it's obviously a config error. There is a problem with all of the config files. It says that the config file is not in the specified location but they are all in the correct location. I deleted them one by one and it gave the same error for each config file in all four pbos

Share this post


Link to post
Share on other sites

DON'T use addon builder, it's well known as addon breaker for a reason. Use pboproject of mikeros tools https://dev.withsix.com/projects/mikero-pbodll/files

 

If there is a error with your files it will tell you whats wrong, unlike addon builder that just builds the pbo and pretends everything is fine. Addon Builder is a waste of space, just stay away from it and your life will be easier

Share this post


Link to post
Share on other sites

My folder structure:

/anc

      /anc_afghan

      /anc_main

      /anc_roads

 

When I pack the subfolders separately (each gets its own pbo) it tells me rapify is not recognized as an internal or external command, operable program, or batch file.

K1eRkMm.png

 

When I pack the root folder, it tells me the pbos cannot be backed due to an error with MakePbo.exe

AXtwCEr.png

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×