Jump to content

Recommended Posts

So I'm having an issue with setting a backpack skin onto my Altis Life server, before I continue I have posted on their forum as well but I can shake the feeling I'm a beggar when I post on there, I get the feeling the help is very, shall we say, limitied by choice, granted they are extremely helpful when they reply and I am very grateful for the help they provide but I kind of want to expand that help and not just confine it to the forum. Now to the issue. When I try and add the backpack skin in with the "if(backpackContainer player)" code my database throws a tanty and just gives me the 'request received from server.... validating' I've come to the conclusion that with the 'backpackContainer' part it's conflicting with the container sql code needed for housing storage. I'm fairly familiar with Arma coding but not that advanced to figure out a solution, so has anyone had this problem or doesn anyone know a solution the to problem, I'm at a loss as to fixing it.

 

Thank you.

 

(Please sir may I have some code?)

Share this post


Link to post
Share on other sites

You should use a comparator to check what backpack you want the texture applied to. I highly recommand reading the wiki.

You will need something like that

If (backpack player == "Backpack_Classname") then { setObjectTextureGlobal blabla...

Classnames are available on the wiki too (consider it like an arma holy bible), assets page.

Share this post


Link to post
Share on other sites

You should use a comparator to check what backpack you want the texture applied to. I highly recommand reading the wiki.

You will need something like that

If (backpack player == "Backpack_Classname") then { setObjectTextureGlobal blabla...

Classnames are available on the wiki too (consider it like an arma holy bible), assets page.

 

Yeah I tried that too it won't set the texture I had a look at the wikia before posting I have the correct classname and skin applied this code: If (backpack player == "Backpack_Classname") doesn't work either it was the first thing I tried after the container issue.

Share this post


Link to post
Share on other sites

****SOLVED****

 

Issue was I needed to add something along the lines of this below.

        waitUntil {backpack player == "B_Kitbag_cbr"};
        (unitBackpack player) setObjectTextureGlobal [0,"textures\skin_name.paa"];
        waitUntil {backpack player != "B_Kitbag_cbr"};
    };

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×