Jump to content
silente13

Arma 3 Server MOD [Linux]

Recommended Posts

Hello guys, i created an arma 3 server on a dedicate machine, and i want add some mod. In the configuration i have this: 

# ARMA 3 Modules
# add mods with relative paths:
# mods/\@CBA_A3\;
# or several mods as:
# mods/\@CBA_A3\;mods/\@task_force_radio
# and chmod modules directories to 775
mods="@servermod;@life_server;@extDB2"

# Server-side Mods
servermods="@servermod;@life_server;@extdb2"

But when i try to enter in the game, in the bottom i can't see the mod...

Share this post


Link to post
Share on other sites

# ARMA 3 Modules
# add mods with relative paths:
# mods/\@CBA_A3\;
# or several mods as:
# mods/\@CBA_A3\;mods/\@task_force_radio
 

 

you forgot the "\" in front of "@" and ";"

 

and why would you want to load the mods twice?

Share this post


Link to post
Share on other sites

not sure what you are doing here, the correct syntax for the params are

 

-mod=

-servermod=

 

not

 

mod=

servermod=

Share this post


Link to post
Share on other sites

# ARMA 3 Modules

# add mods with relative paths:

# mods/\@CBA_A3\;

# or several mods as:

# mods/\@CBA_A3\;mods/\@task_force_radio

 

 

you forgot the "\" in front of "@" and ";"

 

and why would you want to load the mods twice?

 

 

so, i thing like this?

 

mods="serverfiles/\@servermod\;serverfiles/\@life_server\;serverfiles/\@extDB2\";
 
# Server-side Mods
servermods="serverfiles/\@servermod\;serverfiles/\@life_server\;serverfiles/\@extDB2\";

 

not sure what you are doing here, the correct syntax for the params are

 

-mod=

-servermod=

 

not

 

mod=

servermod=

 

I do not know why that is, it was already set. 

Share this post


Link to post
Share on other sites

# ARMA 3 Modules
# add mods with relative paths:
# mods/\@CBA_A3\;
# or several mods as:
# mods/\@CBA_A3\;mods/\@task_force_radio
# and chmod modules directories to 775
mods=""

# Server-side Mods
servermods="\@servermod\;\@life_server\;\@extDB2"

Share this post


Link to post
Share on other sites

# ARMA 3 Modules

# add mods with relative paths:

# mods/\@CBA_A3\;

# or several mods as:

# mods/\@CBA_A3\;mods/\@task_force_radio

# and chmod modules directories to 775

mods=""

# Server-side Mods

servermods="\@servermod\;\@life_server\;\@extDB2"

 

Nothing, it still not work... When i try to enter in the server he say me that i have or miss some addons. And in the right i can't see @servemod or other...

Share this post


Link to post
Share on other sites

Well i think the best way to solve this problem is to ask in the "life" forums. I actually don't know what mods you need and which not. the important thing is that the server loads the mods. you can check this in the rpt.But the syntx should be correct.

 

maybe you could run this script in debug : ./blabla_startingScript -debug

there can watch the rpt live.

Share this post


Link to post
Share on other sites

# ARMA 3 Modules

# add mods with relative paths:

# mods/\@CBA_A3\;

# or several mods as:

# mods/\@CBA_A3\;mods/\@task_force_radio

 

 

you forgot the "\" in front of "@" and ";"

 

and why would you want to load the mods twice?Clear

 

# indicates a comment which is ignored... he isn't loading anything twice. 

 

Silente, where is your reference / from where did you get that file from? Normally you give mods / servermods as startup parameter to the shell / exe file.

./arma3server -serverMod="servermod" -mod=""

what also is possible, and might be the case here, is:

mods="mod1\;mod2"
servermods="servermod1\;servermod2"

./arma3server -serverMod="$servermods" -mod="$mods"

https://community.bistudio.com/wiki/Arma_3_Startup_Parameters says aswell: In Linux multiple folders arguments need the following separation syntax: -mod=mod1\;mod2\;mod3.

 

 

EDIT: check if your @servermod, @life_server and @extDB2 are in the same folder as @CBA_A3... if so the correct path in regards to these comments would be

servermods="mods/\@servermod\;mods/\@extDB2\;"
mods="mods/\@life_server\;"

if they're in the parent of the mods folder your parameters should be correct :/

Share this post


Link to post
Share on other sites

Well i think the best way to solve this problem is to ask in the "life" forums. I actually don't know what mods you need and which not. the important thing is that the server loads the mods. you can check this in the rpt.But the syntx should be correct.

 

maybe you could run this script in debug : ./blabla_startingScript -debug

there can watch the rpt live.

 

Do the sever parametres are correct? 

./arma3server -netlog -ip=89.163.225.147 -port=2302 -cfg=/home/arma3server/serverfiles/cfg/arma3-server.network.cfg -config=/home/arma3server/serverfiles/cfg/arma3-server.server.cfg -mod= -servermod=\@servermod\;\@life_server\;\@extDB2 -bepath= -autoinit -loadmissiontomemory

Share this post


Link to post
Share on other sites

# indicates a comment which is ignored... he isn't loading anything twice. 

 

Silente, where is your reference / from where did you get that file from? Normally you give mods / servermods as startup parameter to the shell / exe file.

./arma3server -servermods="@servermod" -mods=""

what also is possible, and might be the case here, is:

mods=â€â€
servermods="@servermod"

./arma3server -serverMod="$servermods" -mod="$mods"

https://community.bistudio.com/wiki/Arma_3_Startup_Parameters

 

So i try with $ and not @, 'right?

 

Edit: I tried it with $, same...

Share this post


Link to post
Share on other sites

So i try with $ and not @, 'right?

 

Edit: I tried it with $, same...

 

I've edited my answer, try it out :/

Share this post


Link to post
Share on other sites

I've edited my answer, try it out :/

 

What are the differences between mod and servermod?

Share this post


Link to post
Share on other sites

 

 

What are the differences between mod and servermod?

-mod=<string>

Loads the specified sub-folders for different mods. Separated by semi-colons. Absolute path and multiple stacked folders are possible.

In Linux multiple folders arguments need the following separation syntax: -mod=mod1\;mod2\;mod3

This setting always auto-disable in-game mod/extension management (in UI menu).

 

-serverMod=<string>

Loads the specified sub-folders for different server-side (not broadcasted to clients) mods. Separated by semi-colons. Absolute path and multiple stacked folders are possible.

In Linux multiple folders arguments need the following separation syntax: -mod=mod1\;mod2\;mod3.

 

Just google how to set up a altis life server. there a more than a million tutorials.

Share this post


Link to post
Share on other sites

-mod=<string>

Loads the specified sub-folders for different mods. Separated by semi-colons. Absolute path and multiple stacked folders are possible.

In Linux multiple folders arguments need the following separation syntax: -mod=mod1\;mod2\;mod3

This setting always auto-disable in-game mod/extension management (in UI menu).

 

-serverMod=<string>

Loads the specified sub-folders for different server-side (not broadcasted to clients) mods. Separated by semi-colons. Absolute path and multiple stacked folders are possible.

In Linux multiple folders arguments need the following separation syntax: -mod=mod1\;mod2\;mod3.

 

Just google how to set up a altis life server. there a more than a million tutorials.

 

I know how setup the other files, my problem are that the server don't read the mod...

Share this post


Link to post
Share on other sites

lol now i've got your problem!

 

lowercase!

 

rename all the mods to lowercase. also all the .pbo s. and use the right version of extDB2

Share this post


Link to post
Share on other sites

lol now i've got your problem!

 

lowercase!

 

rename all the mods to lowercase. also all the .pbo s. and use the right version of extDB2

 

Already done, same problem... I try to modify the parametres, same error.. I really don't know what can i do...

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×