Jump to content
Tethlah

Multiplayer difficulties being ignored.

Recommended Posts

I've tried a lot of stuff to fix this, nothing seems to work.  When I run this script:

call {
	private ["_diff", "_cfg", "_flags", "_res"];
	_diff = [];
	_cfg = configFile >> "CfgDifficulties";
	{
		_flags = _cfg >> configName _x >> "Flags";
		for "_i" from 0 to count _flags - 1 do {
			_diff pushBack configName (_flags select _i);
		};
	} forEach ("true" configClasses _cfg);
	_diff = _diff arrayIntersect _diff;
	_diff sort true;
	_res = text "";
	{
		_res = composeText [_res, parseText format [
			"<t align='left'>%1 - %2</t>", 
			_x, 
			[0, 1] select difficultyEnabled _x
		], lineBreak];
	} forEach _diff;
	hint _res;
};

It does return the values that are currently being used on the server.  So using that, i added this to our cfg thinking it would fix it.

class Missions
{
	class Lakeside
	{
		template = "UrbanRP.LakesideValley";
		difficulty = "Veteran";
	};
};
class CfgDifficulties
{
    class Veteran
    {
        class Flags
        {
            hud = 0;
            hudGroupInfo = 0;
            weaponCursor = 0;
        };
    };
};

However, cursor is still there, the octagon around players are still there... nothing is defining properly.  I tried using Difficulties, CfgDifficulties, CfgDifficultyPresets.  For the flags I've tried both flags and options.  I've also used all the combinations of them, but it seems like nothing works.  I tried putting the difficulty flags in both description.ext and server.cfg

 

I'm lost at this point, not a thing is working.  According to that check script, the settings above should work, but it's not.

Share this post


Link to post
Share on other sites

Some settings only work with certain difficulty classes. This is most likely your issue

Share this post


Link to post
Share on other sites

Is the "ServerUser".ArmA3Profile in the correct place.

system.ArmA3profile if running as a service

 

The correct location would be dependant on the -profile switch definition, if you have one

 

This thread may be of help....    https://forums.bistudio.com/topic/189417-linux-custom-serverarma3profile/

 

 

 

This is what we currently use.

 

We select either vet or regular, depending on if we want 3rd or not, apart from that they are identical, hope this helps

version=2;
useExtendetInfoType=1;
class Difficulties
{
  class recruit
  {
    class Flags
    {
      Armor=0;
      FriendlyTag=0;
      EnemyTag=0;
      MineTag=1;
      HUD=1;
      HUDPerm=0;
      HUDWp=0;
      HUDWpPerm=0;
      HUDGroupInfo=0;
      AutoSpot=0;
      Map=0;
      WeaponCursor=0;
      AutoGuideAT=1;
      ClockIndicator=1;
      3rdPersonView=1;
      UltraAI=0;
      CameraShake=1;
      UnlimitedSaves=1;
      DeathMessages=0;
      NetStats=0;
      VonID=1;
      ExtendetInfoType=1;
    };
    precisionAI=0.14;
    skillAI=0.60000002;
    aiLevelPreset=3;
  };


  class regular
  {
    class Flags
    {
      Armor=0;
      FriendlyTag=0;
      EnemyTag=0;
      MineTag=0;
      HUD=0;
      HUDPerm=0;
      HUDWp=1;
      HUDWpPerm=0;
      HUDGroupInfo=0;
      AutoSpot=0;
      Map=0;
      WeaponCursor=0;
      AutoGuideAT=0;
      ClockIndicator=0;
      3rdPersonView=1;
      UltraAI=0;
      CameraShake=1;
      UnlimitedSaves=1;
      DeathMessages=0;
      NetStats=0;
      VonID=1;
      ExtendetInfoType=0;
    };
    precisionAI=0.2;
    skillAI=0.60000002;
    aiLevelPreset=3;
  };


  class veteran
  {
    class Flags
    {
      Armor=0;
      FriendlyTag=0;
      EnemyTag=0;
      MineTag=0;
      HUD=0;
      HUDPerm=0;
      HUDWp=1;
      HUDWpPerm=0;
      HUDGroupInfo=0;
      AutoSpot=0;
      Map=0;
      WeaponCursor=0;
      AutoGuideAT=0;
      ClockIndicator=0;
      3rdPersonView=0;
      UltraAI=0;
      CameraShake=1;
      UnlimitedSaves=1;
      DeathMessages=0;
      NetStats=0;
      VonID=1;
      ExtendetInfoType=0;
    };
    precisionAI=0.2;
    skillAI=0.60000002;
    aiLevelPreset=3;
  };


  class mercenary
  {
    class Flags
    {
      Armor=0;
      FriendlyTag=0;
      EnemyTag=0;
      MineTag=1;
      HUD=1;
      HUDPerm=0;
      HUDWp=0;
      HUDWpPerm=0;
      HUDGroupInfo=0;
      AutoSpot=0;
      Map=0;
      WeaponCursor=0;
      AutoGuideAT=1;
      ClockIndicator=1;
      3rdPersonView=1;
      UltraAI=0;
      CameraShake=1;
      UnlimitedSaves=1;
      DeathMessages=0;
      NetStats=0;
      VonID=1;
      ExtendetInfoType=1;
    };
    precisionAI=0.2;
    skillAI=0.60000002;
    aiLevelPreset=3;
  };
};

Share this post


Link to post
Share on other sites

Hello,

I'm trying to force difficulty settings for a SP / MP mission. This current request seems hard to do!

I don't want to change my genera lsettings, just create a mission where I have custom settings, in SP as in MP.

 

Here is what I wrote in the description.ext:

class CfgDifficultyPresets
{
  class Custom
  {
    description = "Custom difficulty set by the player.";
    levelAI = "AILevelMedium";
    class Options
    {
      reducedDamage = 0;
      groupIndicators = 0;
      friendlyTags = 0;
      enemyTags = 0;
      detectedMines = 0;
      commands = 0;
      waypoints = 0;
      weaponInfo = 1;
      stanceIndicator = 1;
      staminaBar = 0;
      weaponCrosshair = 1;
      visionAid = 0;
      squadRadar = 0;
      thirdPersonView = 1;
      cameraShake = 1;
      scoreTable = 1;
      deathMessages = 1;
      vonID = 1;
      mapContent = 1;
      autoReport = 1;
      multipleSaves = 1;
    };
    displayName = "Custom";
    optionDescription = "Custom difficulty set by the player.";
    optionPicture = "\A3\Ui_f\data\Logos\arma3_white_ca.paa";
  };
  defaultPreset = "Custom"; // changed regular for custom here. All below unchanged.
  myArmorCoef = 1.5;
  groupArmorCoef = 1.5;
  fadeDistanceStart = 40;
  fadeDistanceSpan = 10;
  recoilCoef = 1;
  visionAidCoef = 0.8;
  divingLimitMultiplier = 1;
  animSpeedCoef = 0;
  cancelThreshold = 0;
  showCadetHints = 1;
  showCadetWP = 1;
};

That doesn't work as intended because I can see the general settings i have for the game (custom). So, no overhaul at all....

 

Any idea?

Thanks

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×