Jump to content

Recommended Posts

I have posted this question on a couple of threads , my apologies for duplicating it but I am a Newbie and it wouldnt let me start my own topic.

 

I am having trouble with my helicopter remaining stationary after ejecting the last of its AI paratroopers , despite it having waypoints to go too. It drops the troops ok but then just sits there and wont move. I have tried all sorts and its driving me nuts. Any help would be greatly appreciated. Many thanks.

Share this post


Link to post
Share on other sites

Adding more details to your problem goes a long way.

 

How do you make your chopper land (scripts, commands etc.)?

What have you already tried to resolve the issue?

The thread title and description of your problem is a bit misleading, in the title it says "paradrop", in the description it says the chopper sits there (on the ground?).

 

Cheers

Share this post


Link to post
Share on other sites

a lot of info missing here as Old Man said..

Share this post


Link to post
Share on other sites

Apologies , i shall try to explain myself better. I have created a UH80 flying (elevation 100m ) , it has 4 paratroopers in it . I set it to move to a waypoint and paradrop the troops along the way - which it does. After dropping the last trooper it then just hovers in the air at the last drop point , it doesnt continue to the waypoint i have set. I dont use much scripting but am learning , most of my missions are using the basic tools of the editor. I have tried very little in the way of scripting , mostly just tried to vary the waypoint commands but this doesnt work .

Share this post


Link to post
Share on other sites

what are the waypoint settings? the first and second

Share this post


Link to post
Share on other sites

the waypoint for the helicopter is just a move waypoint , i hadnt done any other waypoints as it didnt reach the first one !

Share this post


Link to post
Share on other sites

yes i have named the paratroopers A, B , C & D , then on the trigger I put A action ["Eject", helicopter] for the first trooper , this is repeated for each trooper.

Share this post


Link to post
Share on other sites

is the trigger at all synced with the waypoint?

Share this post


Link to post
Share on other sites

i have 4 triggers , 1 for each dropping trooper and they are all synced with the waypoint of the heli - yes

Share this post


Link to post
Share on other sites

If you do NOT want the helo to engage but instead fly on to the next waypoint then try setting first waypoint behaviour to careless. Don't change this in any other waypoint.

 

Then in the last waypoint i.e. name it "LandHere" and set it to type "GETOUT" and then put this in the waypoint On Act: settings.

UH80 land "LandHere";

The helo will then try and land at this last waypoint, or rather try and land at the nearest helipad. If there isn't one near your last waypoint, then put down an invisible helipad.

 

If that doesn't work, then set the Helo AND the pilot to setcaptive = true;

For example in the init of the helo put this

this flyInHeight 100;this setCaptive true;driver this setCaptive true;

Helo and the pilot will not be fired upon but gunners will still engage.

Then in the last Waypoint add this after the "LandHere";

UH80 setcaptive false;driver UH80 setCaptive false;

The above assumes UH80 is the name of your helo in the Editor

Share this post


Link to post
Share on other sites

ok I have tried both of the above , I renamed the helicopter to UH80 and tried that also , but it still hovers in mid-air after the last trooper is ejected and doesnt travel to the waypoint. I am beginning to think maybe i should make them catch the bus :blink:

Share this post


Link to post
Share on other sites

hi,

 

Did you try to unassignVehicle your troopers?

 

I also suggest you to use a paradrop script. It will be way more reliable.

 

Name your group (myGroupName = group this in group leader's init field) and execute the script with [myGroupName] execVM "myScriptName.sqf" in your trigger activation field.

if (!isServer) exitWith {};

_grp = _this select 0;

	{
		unassignVehicle (_x);
		(_x) action ["EJECT", vehicle _x];
		sleep 1;
	} foreach units _grp;

Or if you do not want to use script add unassignVehicle command in your trigger activation field.

unassignVehicle A;  A action ["Eject", helicopter];

cya.

 

Nikiller.

Share this post


Link to post
Share on other sites

Hi Nikiller, forgive me being an ignoramus but where do i put that script ? I have tried the unassignVehicle and that didnt work , so will have to try the group script. Do I copy this to a notepad and name it paradrop.sqf for example?

Share this post


Link to post
Share on other sites

Hi Nikiller, forgive me being an ignoramus but where do i put that script ? I have tried the unassignVehicle and that didnt work , so will have to try the group script. Do I copy this to a notepad and name it paradrop.sqf for example?

 

 Yes and put the sqf in your mission folder.

 

If unassignVehicle didn't work then something else is wrong. Maybe post a repro mission to see what is not working.

Share this post


Link to post
Share on other sites

Sorry for being stupid , whats a repro mission ? I am currently just trying to get this to work on an empty map before transferring it to the mission i have been working on , as thats complicated enough. I tried putting BOD = group this in the init field of the lead paratrooper , and put [bOD] execVM "paradrop.sqf" in the trigger act , but it came up type script , expected nothing. Many thanks for yours and everyones patience , i appreciate it isnt easy coping with noobs.

Share this post


Link to post
Share on other sites

Answered in this thread. See post #72

 

https://forums.bistudio.com/topic/153935-simple-paradrop-script/

Many thanks for helping beerkan , I downloaded the file Paradrop.Stratis and tried to run it but i need some mods from the workshop it seems , i tried to find them but need to stop for food because my only brain cell is overheating. I have been at this all day and need to break from it , i shall resume again some point soon , again cheers for all your help.

Share this post


Link to post
Share on other sites

Sorry for being stupid , whats a repro mission ? I am currently just trying to get this to work on an empty map before transferring it to the mission i have been working on , as thats complicated enough. I tried putting BOD = group this in the init field of the lead paratrooper , and put [bOD] execVM "paradrop.sqf" in the trigger act , but it came up type script , expected nothing. Many thanks for yours and everyones patience , i appreciate it isnt easy coping with noobs.

 

Sorry my bad you have to execute the script with 0 = [bOD] execVM "paradrop.sqf";

 

Should work.

Share this post


Link to post
Share on other sites

Sorry jambo, I have now removed MOD dependencies from my example mission. Revisit post. #72

Share this post


Link to post
Share on other sites

Sorry my bad you have to execute the script with 0 = [bOD] execVM "paradrop.sqf";

 

Should work.

ok the troops eject nicely , but the helo still hovers in mid-air at the first waypoint , im going to search for the mods that beerkan posted earlier in an attempt to solve this, its driving me crazy , i have been at it all day , just to make a helo move out of area ! thank you for all your help nikiller :)

Share this post


Link to post
Share on other sites

Sorry jambo, I have now removed MOD dependencies from my example mission. Revisit post. #72

Many thanks beerkan , i think if i copy this format in , it will do the job nicely. I well appreciate your help with this :)

Share this post


Link to post
Share on other sites

I've got another problem since 1.56 with the standard hellcat.
It doesn't attack any unit, no matter if the enemy is infantry, vehicle or another heli.

Hellcat pilots with max skill and wp seek&destroy (openfire&aware)
The hellcat comes from 1000m away and when the enemies are revealed - it stops and hovers till it's shot down!?
When there are backdoor gunners, they try to engage, but the pilot never tries to use the main weapons of the heli.

When the heli is a Littlebird, all works as in former versions:
The heli reveals the enemies itself, flies away, turns around and attacks with minigun and rockets.

I'm new here and hope that someone can help me out, to finish my mission.

THANKS VERY MUCH!          

Share this post


Link to post
Share on other sites

@Jambo45

 

 Did a quick read and you said 

 

 

i have 4 triggers , 1 for each dropping trooper and they are all synced with the waypoint of the heli - yes

Your waypoint will not "fire" with a trigger synced to it unless the trigger conditions are all met i.e conditions are true. This maybe why the helo is not moving. 

 

Nomad

  • Like 1

Share this post


Link to post
Share on other sites

hi,

 

@Jambo45

 

 Did a quick read and you said 

Your waypoint will not "fire" with a trigger synced to it unless the trigger conditions are all met i.e conditions are true. This maybe why the helo is not moving. 

 

Nomad

I thought about that afterwards but I think nomadd is right if you use the script I wrote, make the waypoint just cross your trigger area without synchro and execute the paradrop script in the trigger activation field, it should work.

 

Note that you need only one trigger.

 

cya.

 

Nikiller.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×