Jump to content
Sign in to follow this  
magnetar

Game Updater. Error 0x406

Recommended Posts

I keep getting this error in game updater when trying to update the dev branch:

 

 

Error! App '107410' state is 0x406 after update job. Potential causes:

- Loss of internet connection

- Insufficient privilege (0x204)

- Logged in elsewhere (0x006)

- Insufficient hard drive space (0x606)

 

None of the above seems a valid reason since:

 

a) Internet connection is present.

b) Non-protected folder.

c) Only logged on steam.

d) There are still 200 Gb available.

 

The tool never finishes the update and I have to constantly restart it in order to advance the download. Any suggestions? This happens on a Windows 10 OS system.

Share this post


Link to post
Share on other sites

Hello,

Having the logs could help because the 0x606 is usually because of Insufficient disk space but not only. Also, is the destination disk a link, a junction or a usual partition? Are the destination disk and SteamCMD the same?

Share this post


Link to post
Share on other sites

I would be glad if you could point me out which logs do you need. I will happily provide them :)

 

I am trying to install the Dev-branch on the same partition where steam is installed. This is my set-up with the relevant programs (I do not know what you mean by "normal partition" xD):

 

- C drive (SSD, Boot) with Arma 3. 32GB free

- D drive (RAID 0) with Steam, Arma 3 Tools and "redirected" User folders during Windows 10 Installation. 210 GB free with dev-branch installed prior to 1.52 release.

 

I can update the dev-branch in question but I always get the 0x406 error after a few mb are downloaded. Restarting game updater allows downloading a bit more before getting the error and so on.

Share this post


Link to post
Share on other sites

I will need two sets of logs. The first is located in Arma 3 Tools\Logs and named GameUpdater* whereas the second is in Arma 3 Tools\GameUpdater\logs\. In the latter, I just need the following files: stderr.txt and content_log.txt.

 

Normal partition: Because it could have been a network drive, a substitute etc...

Share this post


Link to post
Share on other sites

Done. I have uploaded the files in the feedback tracker. Issue ID: 0026375.

Share this post


Link to post
Share on other sites

I had a look at your logs and it seems that at a moment, it fails to evaluate a response from the Steam servers. There's not a lot of softs that can impact http communication*, so first, are you using an anti-virus (E.g. Kaspersky :rolleyes:) or any other security software.

 

* Assuming you don't have any network issue.

Share this post


Link to post
Share on other sites

No, I have tried to pull this without any firewall since this is what I initially thought. Same error and I made sure the windows firewall is off as well since it activates as soon as I deactivate the Kaspersky one (how much I dislike this OS... rant over)

 

Edit:

Share this post


Link to post
Share on other sites

Any updates on this issue? It still persists and it is not caused by any firewall nor interruptions in internet connection...

Share this post


Link to post
Share on other sites

I've recently spent some time working on Game Updater and looking into your logs, the only issue I found is network related:

Assert( Assertion Failed: Unsupported HTTP version in response received by HTTP client from valve411.cs.steampowered.com (162.254.196.21:80): ????|140??f?-??Qc.??v?×?g?-g?k*c???#? ):httpclient.cpp:1034

So, I'm still investigating the issue... A good thing would be to have all the logs (the entire folder Logs in Game Updater).

  • Like 1

Share this post


Link to post
Share on other sites

I've recently spent some time working on Game Updater and looking into your logs, the only issue I found is network related:

Assert( Assertion Failed: Unsupported HTTP version in response received by HTTP client from valve411.cs.steampowered.com (162.254.196.21:80): ????|140??f?-??Qc.??v?×?g?-g?k*c???#? ):httpclient.cpp:1034

So, I'm still investigating the issue... A good thing would be to have all the logs (the entire folder Logs in Game Updater).

 

I will send them as soon as I get home. If you also need some sort of testing done I will gratefully do it.

Share this post


Link to post
Share on other sites

Could you give it one more try with the development branch of Arma 3 Tools? Both Game Updater and SteamCMD have been updated and this might help. In case of failure, I will need all the logs like the previous time.

Share this post


Link to post
Share on other sites

Hi getting the same issue. After many... many retarts i can pull down 5-10 GB updates. The licence reads 2008 for arma tools is the game updater still valid with modren steam systems and netcode. If this system is not upto current spec plz consider a revamp or possible changes in the method.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×