Jump to content
Sign in to follow this  

Arma 2 OA stopped working (when joining a server)

Recommended Posts


I'm having problems to join servers for 4 days now. It all started last friday (14.03.2014, 14:24) when our server crashed (all clients freezed and freezed again on reconnect, restart of the server solved it for most people). I've been playing for more than 1 year without any issues. In the evening of the same day I had problems to join the server, because like 90% of my attempts to join ended in a crash. Since saturday it's nearly 100% (2 times out of around 100+ joins I got in the game and were able to play).

I did no client modifications within this time (no Windows updates, no GPU driver updates, no Game updates), so this problem comes out of nowhere and some other players report similar issues. (btw: has there been a silent BattlEye update?)

I mostly play DayZ Origins, but other mods crash the same way (so it isn't really related to Origins I think)

What I tried so far:

- reinstalled Arma + Arma OA

- reinstalled the Mod

- completely reinstalled the whole PC

- reinstalled Arma + Arma OA again

- deleted player profiles

- installed via Steam

- tried different Beta patches

- reinstalled Arma + Arma OA again, again and again

The weird thing is: the installation on my notebook has no problems...so I moved this installation (program files, profiles, registry keys) to my PC, but with the problem stays.

I'm out of ideas and it really s....

I reported this as a bug ticket, but not sure if you still care about this page: dev.withsix.com/issues/74231

Thanks in advance


Share this post

Link to post
Share on other sites


at first, sorry for my english.

I have exactly the same problem, played on DayZ like 2 years, and since the 14/03/14 i can't join any server on any mod; Arma 2 OA in multiplayers don't works too.

I had tried everything, except formating the whole PC and reinstalling the OS like Seb.

I had played before the 14/03/14 and haven't any problem, my Windows Update was disable, nothing change between the 13/03 and 14/03 (no updates from windows, the game or anything else).

The game crash when I join anymods (vanilla too).

Seb, i was playing on the same mod of you (Origins when this happened, but i'm out of idea... there is no game update since the 03/03/14 (1.7.8 > i really don't understand... and we have exactly the same problem and tried the same things...

If you find something, please tell me i'm really out of ideas....

Have a good day,


Edited by Foxysama

Share this post

Link to post
Share on other sites


I fixed it "a bit" (means: I can join, but 1-2 crashes per day, less fps) by adding "-malloc=system" to the Parameters (in DayZ commander you can add it in the settings or you add it to the Shortcut on your Desktop). It seems that the real problem is the tbb4####.dll (memory management) which doesn't work anymore.

It worked and doesn't work anymore. And it affects many players, not only me. Why isn't this a bug? Is it a feature?

btw: RPT file is in the bug report. When I reinstall the game or delete all appdata files it works one time (and only one time).


Share this post

Link to post
Share on other sites

My players are getting alot of this but it is due to Battleye not updating.

New version????

[2014-03-19 | 12:37:42] Player #13 Thud (*******) has been kicked by BattlEye: Failed to update

Share this post

Link to post
Share on other sites

yeap...also noticed that if you do not "unblock" the dll bad things happen.

But seems like the server is the issue. the server has 500 Mbps down and 500 Mbps up. (verified by http://www.speakeasy.net/speedtest/ via RDP) But for the world of me I can come even remotely close to the limit. Best I can do is around 12 Mbps with 60 players and I have tried about every basic.cfg difference I can find/ figure out. If the server goes down to around 30 players it's manageable and no one is getting the battleye client response error.

Share this post

Link to post
Share on other sites

Ok I did it !

This is what I did step by step :

- Unistalled Arma 2 & Arma 2 OA by Steam

- Unistalled DayZ Commander

- Deleted the "ArmA 2" & "ArmA 2 Other Profiles" folders from "Librairy\Documents"

- Deleted the "ArmA 2" & "ArmA 2 OA" from "C:\Users\XXX\AppData\Local"

- Deleted the "Arma 2" & "Arma 2 Operation Arrowhead" from "...\Steam\SteamApps\common"

- Deleted "DayZCommander" from "C:\Program files"

- Deleted "DayZCommander" from "C:\Users\XXX\AppData\Local"

- Opened CCleaner and clean the registry

- Restarted the computer

- Opened CCleaner and re-clean the registry (just checking if i didn't have ArmA 2 reg anymore)

- Installed Arma 2

- Installed Arma 2 OA

- Installed DayZ Commander

- Launched one time Arma 2 & Arma 2 OA

- Launched DayZ Commander , patching Arma 2 and installed MOD i want to play

... and miraculously, this is working.

At first Seb, if you have still this problem, i think the crash from the 14/03/14 from GTXGaming corrupted some files for some ppl.

(reinstalling BattleEye files didn't work for me)

Try at first to launch DayZCommander, click on "Install/Update" icon, search DayZ Origins and click on the "Info" button.

After this, click on "Clear cache".

This work for a friend, maybe this can help you.

Have a good day,

Share this post

Link to post
Share on other sites

Today I removed the "-malloc=system" from my shortcut because the game crashed when I interacted with the gear of objects and now the game works without any crashes so far.

No idea what caused this problems but now it works (and I didn't Upgrade/Update anything since the last posts).

Thanks for the help!

Share this post

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
Sign in to follow this