Jump to content
Sign in to follow this  
Schoff

ACRE mod - Installing on dedicated server (need command line help)

Recommended Posts

Hi everyone,

I’m trying to install the ACRE mod on to a dedicated server that I have FTP access, command line access (haven’t used), and RCON access to. I have gotten the ACRE mod to work on my end (tested on other servers), but am having trouble getting it to work on our server.

I’ve tried looking for some guidance on how to install ACRE mod to a dedicated server but haven’t seen much outside of the client-side installation. If you know of any how-to’s please reply with the link—it would be greatly appreciated. There are a few posts on here, but I'm looking for specific help on the command line side of getting the mod to work.

I was told that the installation server-side was the same as client-side. Following that, I have copied the @ACRE, @CBA_A3, and @JayArma mods into the parent directory and created the ‘userconfig>ACRE’ folder and pasted the 2 config files in that folder. FYI - For the client side setup I did not use the steam 'launch options' to enable the mod--I enabled it in-game via the 'configure>expansion' settings and then restarted Arma 3. This seemed to work without a problem. I realize I need launch options server-side, but don't know where they need to go.

The questions I have:

Is the server-side installation the same as the client-side installation? I saw a post mentioning that the @JayArma isn't necessary server-side. Can someone confirm?

Where do I need to put the command line on the server side? Does it go in the server.cfg file (where I set server name/password and messages), or does it go somewhere else?

From what I understand, the command line needs to look something like -mod=@CBA-A3'@ACRE;

I have read the following page, but still need further guidance.

http://forums.bistudio.com/showthread.php?147537-Tutorial-How-to-run-ArmA3-on-a-dedicated-server

Thanks in advance,

Schoff

Share this post


Link to post
Share on other sites
what it's not clear?

take a look also here but you have nothing to do except add mod to launch options

http://community.bistudio.com/wiki/Arma2:_Startup_Parameters

I appreciate you trying to help. What is not clear is where I add the launch options for the server-side installation.

I don't access the server files through a desktop--I log onto an FTP to add the server files. What is not clear is where, in the server files directory, I add the command line that tells the server to load the mods upon starting the server. I have a server.cfg file that defines the name, RCON password, server messages, etc.--does it go in here somewhere?

Ramius, are you not linking me information that enables the mod on the client side? As mentioned above, I have the mod working when I join a server (client side setup), but I'm trying to enable it on my server.

Share this post


Link to post
Share on other sites

Startup parameters are the same for client and server ( 90% or more ), if you can't modify the startup launch parameters you can't simply launch additionals mod... take a look if you see a batch file or something like around in the arma 3 directory.. otherwise you have to contact your server reseller and ask him to add this mod to your launch parameters

Share this post


Link to post
Share on other sites
Startup parameters are the same for client and server ( 90% or more ), if you can't modify the startup launch parameters you can't simply launch additionals mod... take a look if you see a batch file or something like around in the arma 3 directory.. otherwise you have to contact your server reseller and ask him to add this mod to your launch parameters

Thank you, Ramius. I know where it needs to go. Just a matter of getting it to work now...

Share this post


Link to post
Share on other sites

I still can't get it working on my server. I've added the command line -mod=@ACRE;CBA_A3 to the server command line prompt and I get errors when I try and join.

Anyone else know what I can do?

Share this post


Link to post
Share on other sites

First CBA then ACRE.

I know a lot of dedicated servers with problems regarding ACRE. Ultimately it helped to copy all the cba, jay, acre pbos in the addon folders, although it is a mess to extract them later..

Share this post


Link to post
Share on other sites

your mod line should look like this (yes the server also needs jayarma3lib)

-mod=@CBA_A3;@jayArma3lib;@ACRE

(doing this from memory so might not be exact mod names - also make sure your upper/lower case is correct)

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×